在线检测未来函数

通达信牛股战法主图指标公式

来源:Internet,编辑:股旁网,2016-05-09

涨停:=C>REF(C,1)*1.098 AND C=H;
MA5:=MA(C,5);
操作:=MA((L+H+C)/3,5);
压力线:HHV(操作,60)COLORCYAN,LINETHICK2;
VAR3:=EMA((EMA(C*V,3)/EMA(V,3)+EMA(C*V,6)/EMA(V,6)
+EMA(C*V,12)/EMA(V,12)+EMA(C*V,24)/EMA(V,24))/4,13);
支撑线:1.06*VAR3,COLORWHITE,LINETHICK1;
VAR4:=EMA(C,9);
上轨:EMA(VAR4*1.14,5)COLORFF00FF,LINETHICK1;
妖股线: MA(HIGH,30)*(1+15/100),COLOR00B7FF,LINETHICK2;
转强:=100*(C-REF(C,12))/REF(C,12);
超强:=((H+L+C)/3-MA((H+L+C)/3,88))/(0.015*AVEDEV((H+L+C)/3,88));
通道:=1.07*DMA(C,ABS((2*C+H+L)/4-MA(C,26))/MA(C,26));
趋势:=MA(ATAN(通道-REF(通道,1)),3);
QS1:=IF((C>O OR C<O) AND H>=REF(C,1),ATAN(MA(H,5)*1.02-REF(MA(C,5)*1.02,1)),0);
QS2:=IF((C>O OR C<O) AND H<REF(C,1),-ATAN(REF(MA(C,5)*1.02,1)-MA(H,5)*1.02),0);
分界:=MA(REF((QS1+QS2),1),26);
强势:=趋势>分界 AND 趋势>REF(趋势,1) ;
天量:=V>REF(HHV(V,BARSLAST(BARSCOUNT(C)=1)+1),1) ;
DRAWTEXT(天量,L,'大黑马'),COLORYELLOW;
超级牛股:=强势 AND 超强>200 AND 转强>20 AND C>REF(C,1) ;
DRAWTEXT(超级牛股,L*0.95,'超牛'),COLORRED,LINETHICK2;
A:=REF(H/REF(C,1)>=1.098 AND C<H AND C/REF(C,1)>=1.05,1) AND C>O AND C>REF(H,1);
B:=REF(H/REF(C,1)>=1.098 AND C<H AND C/REF(C,1)>=1.05,2) AND REF(C>O,1) AND C>REF(H,2);
XG:=A OR B;
DRAWTEXT(XG,L*0.96,'风清扬'),;
东方不败:=(REF(EVERY(涨停,2),1)OR(REF(EVERY(涨停,2),2) AND REF(C>REF(C,1)AND C>O,1))) AND C<REF(C,1) AND C>O ;
DRAWTEXT(东方不败,L*0.96,'东方不败')COLORCYAN;
双涨停:=EVERY(C/REF(C,1)>=1.098 AND C=H,2);
调整天数:=BARSLAST(双涨停)<=30 AND BARSLAST(双涨停)>=5;
主升浪:=COUNT(双涨停,30)>0 AND 调整天数 AND C/REF(C,1)>=1.098;
主升:=REF(主升浪,1)AND C>O AND C>REF(C,1)*1.02;
DRAWTEXT(主升,L,'主升浪')COLORYELLOW;
大黑马:=REF(EVERY(涨停 AND C>O,2)AND C>=HHV(C,100),1) AND C>O AND C>REF(C,1)*1.02;
DRAWTEXT(大黑马,L,'大黑马');

通达信牛股战法主图指标公式

 

相关文章