在线检测未来函数

大智慧加仓空仓指标公式

来源:Internet,编辑:股旁网,2016-06-20

VAR1:=(VOL / (((HIGH - LOW) * 2) - ABS((CLOSE - OPEN))));
买盘:=IF((CLOSE > OPEN),(VAR1 * (HIGH - LOW)),IF((CLOSE < OPEN),(VAR1 * ((HIGH - OPEN) + (CLOSE - LOW))),(VOL / 2)));
卖盘:=IF((CLOSE > OPEN),(0 - (VAR1 * ((HIGH - CLOSE) + (OPEN - LOW)))),IF((CLOSE < OPEN),(0 - (VAR1 * (HIGH - LOW))),(0 - (VOL / 2))));
bb:SUM(-卖盘,5),COLOR00EE00;
cg:=SUM(买盘,5);
hhgff:STICKLINE(cg>bb,cg,bb,4,0),colorFF33FF;
jjggf:STICKLINE(cg<bb,cg,bb,4,0),Color445555;
TGLXS:cg-bb,COLORSTICK;
mm:=TGLXS-ref(TGLXS,1);
STICKLINE(TGLXS>0,100,100+TGLXS,8,0),COLOR553388;
STICKLINE(TGLXS>0,100,100+TGLXS,7,0),COLOR553399;
STICKLINE(TGLXS>0,100,100+TGLXS,6,0),COLOR5533AA;
STICKLINE(TGLXS>0,100,100+TGLXS,5,0),COLOR5533BB;
STICKLINE(TGLXS>0,100,100+TGLXS,4,0),COLOR5533CC;
STICKLINE(TGLXS>0,100,100+TGLXS,3,0),COLOR5533DD;
STICKLINE(TGLXS>0,100,100+TGLXS,2,0),COLOR5533EE;
STICKLINE(TGLXS>0,100,100+TGLXS,1,0),COLOR5533FF;{//红柱}
STICKLINE(TGLXS<0,100,100+TGLXS,8,0),COLOR008800;
STICKLINE(TGLXS<0,100,100+TGLXS,7,0),COLOR009900;
STICKLINE(TGLXS<0,100,100+TGLXS,6,0),COLOR00AA00;
STICKLINE(TGLXS<0,100,100+TGLXS,5,0),COLOR00BB00;
STICKLINE(TGLXS<0,100,100+TGLXS,4,0),COLOR00CC00;
STICKLINE(TGLXS<0,100,100+TGLXS,3,0),COLOR00DD00;
STICKLINE(TGLXS<0,100,100+TGLXS,2,0),COLOR00EE00;
STICKLINE(TGLXS<0,100,100+TGLXS,1,0),COLOR00FF00;{//绿柱}
STICKLINE(TGLXS=0 AND REF(TGLXS,1)>=0,100,100+TGLXS,8,0),COLORRED;
STICKLINE(TGLXS=0 AND REF(TGLXS,1)<0,100,100+TGLXS,8,0),COLORGREEN;
买卖差:=(买盘 + 卖盘);
lk1:STICKLINE(TGLXS < 0 and c<o,0,-买卖差,4,1),COLORAACC33;
STICKLINE(TGLXS < 0 and mm<0 and c<o,0,-买卖差,6,0),COLOR88DD22;
JX1:=BARSSINCE(买盘);
JY1:=IF(((121 > JX1) AND (JX1 > 0)),JX1,120);
JY2:=IF(((4 > JX1) AND (JX1 > 0)),JX1,3);
VAR30:=MA(VOL,JY2);
神比:=(买盘 / VAR30);
鬼比:=(卖盘 / VAR30);
VAR2:=(HIGH - LOW);
VAR3:=ABS((OPEN - CLOSE));
VAR4:=(HIGH - IF((CLOSE > OPEN),CLOSE,OPEN));
VAR5:=(IF((CLOSE > OPEN),OPEN,CLOSE) - LOW);
VAR6:=((VAR3 / VAR2) * VOL);
VAR7:=((VAR4 / VAR2) * VOL);
VAR8:=((VAR5 / VAR2) * VOL);
VAR9:=IF(((VOL / CAPITAL) > 0.001),1,EXP(ABS(LOG(((VOL / CAPITAL) * 100)))));
VARA:=(((CLOSE - MA(CLOSE,5)) / MA(CLOSE,5)) * 100);
VARB:=(((MA(CLOSE,5) > MA(CLOSE,10)) AND (MA(CLOSE,10) > MA(CLOSE,30))) AND (MA(CLOSE,30) > MA(CLOSE,60))); VARC:=((MA(CLOSE,5) < MA(CLOSE,10)) AND (MA(CLOSE,10) < MA(CLOSE,30)));
VARD:=REF(CLOSE,1);
VARE:=((SMA(MAX((CLOSE - VARD),0),6,1) / SMA(ABS((CLOSE - VARD)),6,1)) * 100);
VAR40:=((IF((((VAR6 >= VAR7) AND (VAR6 >= VAR8)) AND (CLOSE > OPEN)),VAR6,买盘) + 买盘) / 2);
VAR41:=((IF(((VAR7 > VAR6) AND (VAR7 > VAR8)),VAR7,买盘) + 买盘) / 2);
VAR42:=((IF(((VAR8 > VAR6) AND (VAR8 > VAR7)),VAR8,买盘) + 买盘) / 2);
VAR50:=((IF((((VAR6 >= VAR7) AND (VAR6 >= VAR8)) AND (CLOSE < OPEN)),VAR6,卖盘) + 卖盘) / 2);
STICKLINE(( TGLXS>0 and 买盘 > 0 and CLOSE >MA(CLOSE,20) ),-买盘,0,4,1),COLORFF00FF;
STICKLINE(( TGLXS>0 and 买盘 > 0 and CLOSE >MA(CLOSE,20) and mm>0 ),-买盘,0,4,0),COLORRED;
STICKLINE((((TGLXS>0 and VAR6 >= VAR7) AND (VAR6 >= VAR8)) AND (CLOSE > OPEN) and CLOSE >MA(CLOSE,20)),0,-VAR6,4,0),COLOR00FFFF;
my:1*(TGLXS-ref(TGLXS,1))/1000,colorFF00FF;

大智慧加仓空仓指标公式

 

相关文章