在线检测未来函数

通达信登峰VOLUME指标公式

来源:Internet,编辑:股旁网,2016-08-15

M1:5;
M2:10;
N:5;
VOLUME:VOL,VOLSTICK;
MAVOL1:MA(VOLUME,M1);
MAVOL2:MA(VOLUME,M2);
X_1:=CLOSE-REF(CLOSE,1);
X_2:=100*EMA(EMA(X_1,N),N)/EMA(EMA(ABS(X_1),N),N);
X_3:=IF(LLV(X_2,2)=LLV(X_2,7) AND COUNT(X_2<0,2) AND CROSS(X_2,MA(X_2,2)),1,0);
X_4:=IF(HHV(X_2,2)=HHV(X_2,7) AND COUNT(X_2>50,2) AND CROSS(MA(X_2,2),X_2),1,0);
STICKLINE(FILTER(X_3=1,5),VOLUME,0,3.5,0),COLOR0D0C6A;
STICKLINE(FILTER(X_3=1,5),VOLUME,0,2.5,0),COLOR0D06AA;
STICKLINE(FILTER(X_3=1,5),VOLUME,0,1.5,0),COLOR2108C1;
STICKLINE(FILTER(X_3=1,5),VOLUME,0,0.5,0),COLOR9F5DFF;
STICKLINE(FILTER(X_4=1,5),VOLUME,0,3.5,0),COLOR1B7411;
STICKLINE(FILTER(X_4=1,5),VOLUME,0,2.5,0),COLOR17A715;
STICKLINE(FILTER(X_4=1,5),VOLUME,0,1.5,0),COLOR08D306;
STICKLINE(FILTER(X_4=1,5),VOLUME,0,0.5,0),COLOR40FF00;
X_5:=VOL>=REF(VOL,1)*1.91 AND CLOSE>REF(CLOSE,1);
STICKLINE(X_5,VOLUME,0,3.5,0),COLOR080E71;
STICKLINE(X_5,VOLUME,0,2.5,0),COLOR0B0E8C;
STICKLINE(X_5,VOLUME,0,1.5,0),COLOR0905B0;
STICKLINE(X_5,VOLUME,0,0.5,0),COLOR0204F2;
X_6:=(HHV(HIGH,25)-LLV(LOW,25))/EMA(CLOSE-LLV(LOW,25),5);
X_7:=HHVBARS(X_6,30);
X_8:=BARSLASTCOUNT(X_7=0);
X_9:=LOW<REF(LOW,1) OR CLOSE<OPEN;
X_10:=BARSLASTCOUNT(X_9);
X_11:=X_8>=3 AND X_10>=3;
X_12:=EXPMA(CLOSE,25);
X_13:=X_7=0 AND LOW=LLV(LOW,20) AND X_11;
X_14:=REF(X_13,1) AND CLOSE>OPEN;
X_15:=BARSLAST(X_14);
X_16:=CLOSE/X_12>1.03;
X_17:=COUNT(X_16,X_15+1)=1 AND X_16 AND TOTALBARSCOUNT>200;
STICKLINE(X_17,VOLUME,OPEN,3.2,0),COLOR002288;
STICKLINE(X_17,VOLUME,OPEN,2.6,0),COLOR0033AA;
STICKLINE(X_17,VOLUME,OPEN,1.9,0),COLOR0044CC;
STICKLINE(X_17,VOLUME,OPEN,1.2,0),COLOR0055EE;
STICKLINE(X_17,VOLUME,OPEN,0.6,0),COLOR0077FF;
STICKLINE(X_17,VOLUME,OPEN,0.3,0),COLOR0088FF;
X_18:=14;
X_19:=6;
X_20:=EXPMEMA(MAX(MAX(HIGH-LOW,ABS(HIGH-REF(CLOSE,1))),ABS(REF(CLOSE,1)-LOW)),X_18);
X_21:=HIGH-REF(HIGH,1);
X_22:=REF(LOW,1)-LOW;
X_23:=EXPMEMA(IF(X_21>0 AND X_21>X_22,X_21,0),X_18);
X_24:=EXPMEMA(IF(X_22>0 AND X_22>X_21,X_22,0),X_18);
X_25:=X_23*100/X_20;
X_26:=X_24*100/X_20;
X_27:=EXPMEMA(ABS(X_26-X_25)/(X_26+X_25)*100,X_19);
X_28:=EXPMEMA(X_27,X_19);
F:CROSS(X_25,X_26) AND CROSS(X_25,X_27) AND CROSS(X_25,X_28) AND CLOSE/REF(CLOSE,1)>1.05;
STICKLINE(F,VOLUME,OPEN,3.2,0),COLOR002288;
STICKLINE(F,VOLUME,OPEN,2.6,0),COLOR0033AA;
STICKLINE(F,VOLUME,OPEN,1.9,0),COLOR0044CC;
STICKLINE(F,VOLUME,OPEN,1.2,0),COLOR0055EE;
STICKLINE(F,VOLUME,OPEN,0.6,0),COLOR0077FF;
STICKLINE(F,VOLUME,OPEN,0.3,0),COLOR0088FF;
趋势线:EMA(EMA(CLOSE-REF(CLOSE,1),6),6)*100/EMA(EMA(ABS(CLOSE-REF(CLOSE,1)),6),6),COLORRED,LINETHICK3;
IF(趋势线<REF(趋势线,1),趋势线,DRAWNULL),COLORGREEN,LINETHICK3;

通达信登峰VOLUME指标公式

 

相关文章