在线检测未来函数

通达信精准追底副图及选股指标公式

来源:Internet,编辑:股旁网,2016-11-21

AA:=VOL/((H-L)*2-ABS(C-O));
买量:=AA*(H-L);
卖量:=0-AA*((H-C)+(O-L));
进出量:=(买量+卖量)>0;
AA1:=FILTER(L=LLV(L,13),8);
AA2:=IF(LLV(L,3)=LLV(L,13) AND C<REF((H+L)/2,1),MAX(REF(LLV(L,12),BARSLAST(AA1)+1)-L,0),0);
AA3:=EMA(AA2,3)*3;
AA4:=SUMBARS(AA3>0,21);
AA5:=SUM(AA3,AA4)/21;
AA6:=REF(AA3,1)=HHV(AA3,3) AND REF(AA3,1)>AA5*3 AND COUNT(C/REF(C,1)<0.9025,8)=0 AND LLV(L,3)/HHV(H,18)<0.88;
均线条件:=EMA(C,5)>=REF(EMA(C,5),1) ; {增加这个条件过滤掉那些股票价格继续下行,而出现信号}
反转:=FILTER(AA6 AND 进出量 AND 均线条件,3); {增加了过滤信号语句,减少重复信号}
STICKLINE(CLOSE,0,AA3,2.7,1),COLORYELLOW;
STICKLINE(反转,0,AA3,2.7,0),COLORRED;

{
选股公式:

AA:=VOL/((H-L)*2-ABS(C-O));
买量:=AA*(H-L);
卖量:=0-AA*((H-C)+(O-L));
进出量:=(买量+卖量)>0;
AA1:=FILTER(L=LLV(L,13),8);
AA2:=IF(LLV(L,3)=LLV(L,13) AND C<REF((H+L)/2,1),MAX(REF(LLV(L,12),BARSLAST(AA1)+1)-L,0),0);
AA3:=EMA(AA2,3)*3;
AA4:=SUMBARS(AA3>0,21);
AA5:=SUM(AA3,AA4)/21;
AA6:=REF(AA3,1)=HHV(AA3,3) AND REF(AA3,1)>AA5*3 AND COUNT(C/REF(C,1)<0.9025,8)=0 AND LLV(L,3)/HHV(H,18)<0.88;
均线条件:=EMA(C,5)>=REF(EMA(C,5),1) ;
反转:=AA6 AND 进出量 AND 均线条件;
XG:FILTER(反转,3);
}

通达信精准追底副图及选股指标公式

 

相关文章