在线检测未来函数

通达信短线王组合看盘主图指标公式

来源:Internet,编辑:股旁网,2016-12-22

CC:IF(CURRBARSCOUNT<18,CONST(REF(C,1)),DRAWNULL),COLOR848484;
止赢:1.05*CC,COLOR0080FF;
止损:0.97*CC,COLORFFFF00;
量能饱和度:IF((AMOUNT/C)/(HHV(AMOUNT,20)/HHV(C,20))*100>100,100,(AMOUNT/C)/(HHV(AMOUNT,20)/HHV(C,20))*100),NODRAW;
MA6一号线:MA(C,6),COLOR00FFFF,LINETHICK3;
A12二号线:MA(C,12),COLORFF26FF;
A24三号线:MA(C,24),COLORRED;
A50四号线:MA(C,50),COLOR00D2D2,LINETHICK3;
DK:=A24三号线;
STICKLINE(DK<=C AND CLOSE>=OPEN,HIGH,LOW,0,1),COLORRED;
STICKLINE(DK<=C AND CLOSE>=OPEN,CLOSE,OPEN,3.2,0),COLOR6600FF;
STICKLINE(DK<=C AND CLOSE>=OPEN,CLOSE,OPEN,2.7,0),COLORDD33FF;
STICKLINE(DK<=C AND CLOSE>=OPEN,CLOSE,OPEN,2.1,0),COLORFF55FF;
STICKLINE(DK<=C AND CLOSE>=OPEN,CLOSE,OPEN,1.5,0),COLORFF88FF;
STICKLINE(DK<=C AND CLOSE>=OPEN,CLOSE,OPEN,0.9,0),COLORFFAAFF;
STICKLINE(DK<=C AND CLOSE>=OPEN,CLOSE,OPEN,0.3,0),COLORFFCCFF;
STICKLINE(DK<=C AND CLOSE<OPEN,HIGH,LOW,0,1),COLORRED;
STICKLINE(DK<=C AND CLOSE<OPEN,CLOSE,OPEN,3.2,0),COLOR000033;
STICKLINE(DK<=C AND CLOSE<OPEN,CLOSE,OPEN,2.7,0),COLOR000066;
STICKLINE(DK<=C AND CLOSE<OPEN,CLOSE,OPEN,2.1,0),COLOR000099;
STICKLINE(DK<=C AND CLOSE<OPEN,CLOSE,OPEN,1.5,0),COLOR0000CC;
STICKLINE(DK<=C AND CLOSE<OPEN,CLOSE,OPEN,0.9,0),COLOR0000FF;
STICKLINE(DK<=C AND CLOSE<OPEN,CLOSE,OPEN,0.3,0),COLORCC66FF;
STICKLINE(DK>C AND CLOSE>=OPEN,HIGH,LOW,0,1),COLORFFFF00;
STICKLINE(DK>C AND CLOSE>=OPEN,CLOSE,OPEN,3.2,0 ),COLOR990000;
STICKLINE(DK>C AND CLOSE>=OPEN,CLOSE,OPEN,2.7,0 ),COLORCC0000;
STICKLINE(DK>C AND CLOSE>=OPEN,CLOSE,OPEN,2.1,0),COLORFF4400;
STICKLINE(DK>C AND CLOSE>=OPEN,CLOSE,OPEN,1.5,0 ),COLORFF8800;
STICKLINE(DK>C AND CLOSE>=OPEN,CLOSE,OPEN,0.9,0 ),COLORFFCC00;
STICKLINE(DK>C AND CLOSE>=OPEN,CLOSE,OPEN,0.3,0 ),COLORCYAN;
STICKLINE(DK>C AND CLOSE<OPEN,HIGH,LOW,0,1),COLORWHITE;
STICKLINE(DK>C AND CLOSE<OPEN,CLOSE,OPEN,3.2,0 ),COLOR555555;
STICKLINE(DK>C AND CLOSE<OPEN,CLOSE,OPEN,2.7,0 ),COLOR777777;
STICKLINE(DK>C AND CLOSE<OPEN,CLOSE,OPEN,2.1,0 ),COLOR999999;
STICKLINE(DK>C AND CLOSE<OPEN,CLOSE,OPEN,1.5,0 ),COLOR999999;
STICKLINE(DK>C AND CLOSE<OPEN,CLOSE,OPEN,0.9,0 ),COLORDDDDDD;
STICKLINE(DK>C AND CLOSE<OPEN,CLOSE,OPEN,0.3,0 ),COLORFFFFFF;
买:IF(MA6一号线>REF(MA6一号线,1),MA6一号线,DRAWNULL),COLORRED,LINETHICK3;
卖:IF(MA6一号线<REF(MA6一号线,1),MA6一号线,DRAWNULL),COLORFFFF00,LINETHICK3;
今日保护价:(REF(C,1)+REF(C,2)+O)/3,NODRAW;
看空:IF(CLOSE<SAR(4,2,10),SAR(4,2,10),DRAWNULL),CIRCLEDOT,COLOR005900;
看多:IF(CLOSE>SAR(4,2,10),SAR(4,2,10),DRAWNULL),CIRCLEDOT,COLORRED ;
均价:=(C+REF(C,1)+REF(C,2)*3)/5;
压力J:=1.025*均价;
支撑JR:=0.97*均价;
TT0:=CONST(BARSLAST(压力J));
TT1:=CONST(BARSLAST(支撑JR));
STICKLINE(PERIOD=5 AND CURRBARSCOUNT=TT1+1,支撑JR,支撑JR+0.01,6,0),COLOR00FF00;
STICKLINE(PERIOD=5 AND CURRBARSCOUNT=TT0+1,压力J,压力J-0.01,6,0),COLORMAGENTA;
ARE4:=MA(C,20); ARE5:=(C>MA(C,5)); ARE6:=(MA(C,5)>MA(C,10)); ARE7:=(C>MA(C,10));
ARE8:=(MA(C,5)>MA(C,20)); ARE9:=(C>MA(C,20)); ARE10:=REF(ARE4,1); ARE11:=(ARE4>ARE10);
AVX:=(((((IF(ARE5,10,(0-10))+IF(ARE6,10,(0-10)))+IF(ARE7,10,(0-10)))+IF(ARE8,10,(0-10)))+IF(ARE9,10,(0-10)))+IF(ARE11,10,(0-10)));
DSLX:=(C/INDEXC); DSLX1:=MA(DSLX,5); DSLX2:=MA(DSLX,10);VRE1:=MA(V,5); VRE2:=MA(V,10);
阻力位:=IF((C>200),(C*1.01),(C*1.07)); 阻力位1:=IF((C<10),(C*1.05),阻力位);
止损位:=IF((C>200),(C*0.99),(C*0.93)); 止损位1:=IF((C<10),(C*0.95),止损位);
TJTS1:=ISLASTBAR AND C<500; TJTS2:=ISLASTBAR AND C>500;
KDAT:=REFDATE(HHV(H,45)/1.01,DATE);{解盘位置}
解盘1:=CONST(IF(TJTS1 AND((CROSS(AVX,1) AND (VRE1 >= VRE2)) AND (DSLX >= DSLX1)) ,1,0));
解盘2:=CONST(IF(TJTS1 AND((CROSS(AVX,1) AND (VRE1 < VRE2)) AND (DSLX >= DSLX1)) ,1,0));
解盘3:=CONST(IF(TJTS1 AND((CROSS(AVX,1) AND (VRE1 > VRE2)) AND (DSLX < DSLX1)) ,1,0));
解盘4:=CONST(IF(TJTS1 AND((CROSS(AVX,1) AND (VRE1 <= VRE2)) AND (DSLX < DSLX1)) ,1,0));
解盘5:=CONST(IF(TJTS1 AND((CROSS(1,AVX) AND (VRE1 >= VRE2)) AND (DSLX >= DSLX1)) ,1,0));
解盘6:=CONST(IF(TJTS1 AND((CROSS(1,AVX) AND (VRE1 < VRE2)) AND (DSLX >= DSLX1)) ,1,0));
解盘7:=CONST(IF(TJTS1 AND((CROSS(1,AVX) AND (VRE1 >= VRE2)) AND (DSLX < DSLX1)) ,1,0));
解盘8:=CONST(IF(TJTS1 AND((CROSS(1,AVX) AND (VRE1 < VRE2)) AND (DSLX < DSLX1)) ,1,0));
解盘9:=CONST(IF(TJTS1 AND((((AVX >= 1) AND (REF(AVX,1) > 0)) AND (VRE1 >= VRE2)) AND (DSLX >= DSLX1)) ,1,0));
解盘10:=CONST(IF(TJTS1 AND((((AVX >= 1) AND (REF(AVX,1) > 0)) AND (VRE1 < VRE2)) AND (DSLX >= DSLX1)) ,1,0));
解盘11:=CONST(IF(TJTS1 AND((((AVX >= 1) AND (REF(AVX,1) > 0)) AND (VRE1 >= VRE2)) AND (DSLX < DSLX1)) ,1,0));
解盘12:=CONST(IF(TJTS1 AND((((AVX >= 1) AND (REF(AVX,1) > 0)) AND (VRE1 < VRE2)) AND (DSLX < DSLX1)) ,1,0));
解盘13:=CONST(IF(TJTS1 AND((((AVX < 1) AND (REF(AVX,1) < 0)) AND (VRE1 >= VRE2)) AND (DSLX >= DSLX1)) ,1,0));
解盘14:=CONST(IF(TJTS1 AND((((AVX < 1) AND (REF(AVX,1) < 0)) AND (VRE1 < VRE2)) AND (DSLX >= DSLX1)) ,1,0));
解盘15:=CONST(IF(TJTS1 AND((((AVX < 1) AND (REF(AVX,1) < 0)) AND (VRE1 >= VRE2)) AND (DSLX < DSLX1)) ,1,0));
解盘16:=CONST(IF(TJTS1 AND((((AVX < 1) AND (REF(AVX,1) < 0)) AND (VRE1 < VRE2)) AND (DSLX < DSLX1)) ,1,0));
解盘17:=CONST(IF(TJTS2 AND(CROSS(AVX,1) AND (VRE1 >= VRE2)) ,1,0));
解盘18:=CONST(IF(TJTS2 AND(CROSS(AVX,1) AND (VRE1 >= VRE2)) ,1,0));
解盘19:=CONST(IF(TJTS2 AND(CROSS(AVX,1) AND (VRE1 < VRE2)) ,1,0));
解盘20:=CONST(IF(TJTS2 AND(CROSS(AVX,1) AND (VRE1 < VRE2)) ,1,0));
解盘21:=CONST(IF(TJTS2 AND(CROSS(1,AVX) AND (VRE1 >= VRE2)) ,1,0));
解盘22:=CONST(IF(TJTS2 AND(CROSS(1,AVX) AND (VRE1 < VRE2)) ,1,0));
解盘23:=CONST(IF(TJTS2 AND(((AVX >= 1) AND (REF(AVX,1) > 0)) AND (VRE1 >= VRE2)) ,1,0));
解盘24:=CONST(IF(TJTS2 AND(((AVX >= 1) AND (REF(AVX,1) > 0)) AND (VRE1 < VRE2)) ,1,0));
解盘25:=CONST(IF(TJTS2 AND(((AVX < 1) AND (REF(AVX,1) < 0)) AND (VRE1 >= VRE2)) ,1,0));
解盘26:=CONST(IF(TJTS2 AND(((AVX < 1) AND (REF(AVX,1) < 0)) AND (VRE1 < VRE2)) ,1,0));
解盘文字1:=IF(解盘1=1,'该股的量能理想,有明显走强迹象,可以考虑中线进场参与,仓位在2/3左右',
IF(解盘2=1,'该股虽然走势趋强,但量能还显不足,可以考虑短线进场,仓位在1/2左右',
IF(解盘3=1,'该股量价配合良好,但相对其它股票并没有明显走强,可以考虑短线进场,仓位1/2左右',
IF(解盘4=1,'该股形态尚可,但量能不足,股票也未完全走强,可以短线参与,仓位1/3左右',
IF(解盘5=1,'该股形态变坏,但走势相对其它股票尚可,重仓者减持大半,清仓者可以观望',
IF(解盘6=1,'该股随大盘一起下跌,程明显缩量走势,考虑到大盘风险,减持或清仓',
IF(解盘7=1,'该股放量下跌,走势明显偏弱,离场观望',
IF(解盘8=1,'该股缩量下跌,走势偏弱,离场观望',
IF(解盘9=1,'该股形态良好,强势明显,量能充足,可以继续持有',
IF(解盘10=1,'该股上行趋势不变,强势依然,但量能开始转弱,注意风险',
IF(解盘11=1,'该股仍然具备上涨潜力,但股性偏弱,可考虑减仓',
IF(解盘12=1,'该股走势趋弱,量能不足,减持大部分筹码',
IF(解盘13=1,'该股形态不佳,注意成交量的变化,但目前不适合参与',
IF(解盘14=1,'该股趋势不明,股价偏弱,注意量能变化,目前不宜参与',
IF(解盘15=1,'该股有走强迹象,但量能不足,趋势不明,不适合操作',
IF(解盘17=1,'大盘量能理想,有明显走强迹象,可以考虑中线进场参与,仓位在2/3左右',
IF(解盘19=1,'大盘虽然走势趋强,但量能还显不足,如果前期经过一轮下跌 ',
IF(解盘21=1,'大盘形态走坏,重仓者可以减去大部分仓位 ',
IF(解盘22=1,'大盘缩量调整,注意风险,短线清仓观望',
IF(解盘23=1,'大盘走势良好,量能理想,可以继续持有强势股',
IF(解盘24=1,'大盘形态良好,但量能稍显不足,随时准备减仓',
IF(解盘25=1,'大盘趋势不明,注意成交量变化,目前不适宜进场',
IF(解盘26=1,'大盘趋势向下,量能萎缩,不适合进场',DRAWNULL)))))))))))))))))))))));
解盘文字2:=IF(解盘16=1,'该股走势太弱,没有参与价值',IF(解盘18=1,' 如前期经过一轮下跌,此时为最佳买点,但如果前期有过一段涨幅则介入需谨慎',
IF(解盘20=1,' 可以考虑短线进场,仓位在1/2左右,一旦量能放大可以加仓买入',DRAWNULL)));
DRAWTEXT(CURRBARSCOUNT=75{位置} AND(解盘1=1 OR 解盘2=1 OR 解盘3=1 OR 解盘4=1 OR 解盘5=1 OR 解盘6=1 OR 解盘7=1 OR
解盘8=1 OR 解盘9=1 OR 解盘10=1 OR 解盘11=1 OR 解盘12=1 OR 解盘13=1 OR 解盘14=1 OR 解盘15=1 OR 解盘17=1 OR
解盘19=1 OR 解盘21=1 OR 解盘22=1 OR 解盘23=1 OR 解盘24=1 OR 解盘25=1 OR 解盘26=1),(KDAT*0.99),解盘文字1),COLOR00FFFF;
DRAWTEXT(CURRBARSCOUNT=75{位置} AND (解盘16=1 OR 解盘18=1 OR 解盘20=1),IF(解盘18=1 OR 解盘20=1,KDAT*0.98,KDAT*0.96),解盘文字2),COLOR00FFFF;

通达信短线王组合看盘主图指标公式

 

相关文章