在线检测未来函数

通达信趋势彩丝带主图指标公式

来源:Internet,编辑:股旁网,2017-01-11

X2:=EMA(((SLOPE(C,22)*20)+C),55);
压力:=MA(REF(HHV(C,30),1),2);
支撑:=MA(REF(LLV(C,30),1),2);
DRAWBAND(压力,RGB(171,130,255),X2,RGB(171,130,255));
DRAWBAND(X2,RGB(137,104,205),支撑,RGB(137,104,205));
K:=BARSLAST(CURRBARSCOUNT=120);
GD:=CONST(IF(ISLASTBAR=1,HHV(H,K),0));
DD:=CONST(IF(ISLASTBAR=1,LLV(L,K),0));
STICKLINE(CURRBARSCOUNT=1,GD,DD,0,-1),COLORGREEN;
{彩色K线}
TYX3:=MA(REF(HHV((C+L+O+H)/4,30),1),3);
TYX4:=MA((C+L+O+H)/4,13);
TYX5:=EMA((C+L+O+H)/4,21);
{空心红}
STICKLINE(C<TYX5 AND C>O,H,L,0,0),COLORRED;
STICKLINE(C<TYX5 AND C>O,C,O,5,1),COLORRED;
{深绿}
STICKLINE(C<TYX5 AND C<O,H,L,0,0),COLOR007700;
STICKLINE(C<TYX5 AND C<O,C,O,5,0),COLOR005500;
STICKLINE(C<TYX5 AND C<O,C,O,5,0),COLOR006600;
{蓝}
STICKLINE(C>TYX5 AND C<O,H,L,0,0),COLORFFDD44;
STICKLINE(C>TYX5 AND C<O,C,O,5,0 ),COLORFF7700;
STICKLINE(C>TYX5 AND C<O,C,O,5,0 ),COLORFFAA22;
{黄}
STICKLINE(C>TYX5 AND C>O,H,L,0,0 ),COLOR00EEFF;
STICKLINE(C>TYX5 AND C>O,C,O,5,0 ),COLOR00AAFF;
STICKLINE(C>TYX5 AND C>O,C,O,5,0 ),COLOR00CCFF;
{粉红}
STICKLINE(C>TYX4 AND C>O,H,L,0,0),COLORFF66AA;
STICKLINE(C>TYX4 AND C>O,C,O,5,0 ),COLORFF11FF;
STICKLINE(C>TYX4 AND C>O,C,O,5,0 ),COLORFF44FF;
{亮灰}
STICKLINE(C>TYX4 AND C<O,H,L,0,0),COLOR999999;
STICKLINE(C>TYX4 AND C<O,C,O,5,0),COLOR555555;
STICKLINE(C>TYX4 AND C<O,C,O,5,0),COLOR777777;
{深红}
STICKLINE(C>TYX3 AND C>O,H,L,0,0),COLOR0000DD;
STICKLINE(C>TYX3 AND C>O,C,O,5,0),COLOR000099;
STICKLINE(C>TYX3 AND C>O,C,O,5,0),COLOR0000BB;
STICKLINE(C/REF(C,1)>1.095,C,O,3.5,0),COLORYELLOW;
∑:=DMA(CLOSE,IF((CLOSE < 100),(VOL / CAPITAL),(VOL / SUM(VOL,240))));
DRAWICON(ISLASTBAR,∑,20);
DRAWICON(ISLASTBAR,(∑ * 1.1),38);
DRAWICON(ISLASTBAR,(∑ * 1.21),22);
DRAWICON(ISLASTBAR,(∑ * 0.91),39);
DRAWICON(ISLASTBAR,(∑ * 0.826),21);
DI:=EMA(C,12)-EMA(C,13);
DE:=EMA(DI,3);
TJ:=VOL>=REF(V,1)*1.91 AND C>REF(C,1)*1.01;
DRAWICON(TJ,LOW*0.986,11);
短线BBI:=(MA(CLOSE,3)+MA(CLOSE,6)+MA(CLOSE,12)+MA(CLOSE,24))/4,COLORGREEN,LINETHICK2;
长线EBBI:=(EMA(C,6)+EMA(C,18)+EMA(C,54)+EMA(C,162))/4,COLOR0000FF,LINETHICK2;
STICKLINE(CROSS(短线BBI,长线EBBI),L,L-0.09,4,0),COLORYELLOW;
DRAWTEXT(CROSS(短线BBI,长线EBBI),L-0.13,'走牛') ,COLORWHITE;
VARA8:=REF(CLOSE,1);
VARE:=SMA(MAX(CLOSE-VARA8,0),6,1)/SMA(ABS(CLOSE-VARA8),6,1)*100;
DRAWTEXT(DATE>700101 AND CROSS(84,VARE),HIGH,'☆卖出提示'),COLORGREEN;
临界线:= (13*C+12*REF(C,1)+11*REF(C,2)+10*REF(C,3)+9*REF(C,4)+8*REF(C,5)+
7*REF(C,6)+ 6*REF(C,7)+5*REF(C,8)+4*REF(C,9)+3*REF(C,10)+2*REF(C,11)+
1*REF(C,12))/(13+12+11+10+9+8+7+6+5+4+3+2+1),COLORWHITE;
临界:=MA(临界线,6),COLORLIMAGENTA;
DRAWICON(CROSS(临界线,临界),L,34);
DRAWICON(CROSS(临界,临界线),H,35);
持仓:IF(CLOSE>=SAR(4,2,20),SAR(4,2,20),
DRAWNULL),CIRCLEDOT,COLORRED,{COLOR9955FF};
空仓:IF(CLOSE<=SAR(4,2,20),SAR(4,2,20),
DRAWNULL),CIRCLEDOT,COLORGREEN,{COLORDDFF00};

通达信趋势彩丝带主图指标公式

 

相关文章