在线检测未来函数

通达信佐罗风控指标公式

来源:Internet,编辑:股旁网,2017-01-13

AAX:=(C/MA(C,5)-1)*100;
VAR3:=(CLOSE-MA(CLOSE,6))/MA(CLOSE,6)*100;
VAR4:=(CLOSE-MA(CLOSE,24))/MA(CLOSE,24)*100;
VAR5:=(CLOSE-MA(CLOSE,32))/MA(CLOSE,32)*100;
VAR6:=(VAR3+VAR4+VAR5)/3;
VAR7:=EMA(VAR6,5);
VAR8:=IF(VAR6<=-20,10,0);
VAR9:=HHV(VAR8,10);
K:=EMA(VAR7,5)*2;
D:=EMA(K,5);
J:=K*3-D*2;
VARA:=IF(VAR9 AND CROSS(MA(CLOSE,3),MA(CLOSE,5)),20,0);
VARB:=BETWEEN(CLOSE,MA(CLOSE,3),MA(CLOSE,5)) AND J>10;
换手:=VOL/CAPITAL*100;
成交〖万手〗:=VOL/10000;
VAT4:=(LOW+HIGH+CLOSE)/3;
操作:=MA(VAT4,5);
拉升:=HHV(操作,13);
压力:=HHV(操作,60);
买卖:=LLV(操作,13);
底部支撑:=LLV(LOW,60)*1.02;
顶部:=HHV(HIGH,60)*0.98;
稳定1:=CROSS(C,顶部);
VAR1:=LLV(LOW,21);
VAR2:=HHV(HIGH,21);
AK1:=EMA((((CLOSE - VAR1) / (VAR2 - VAR1)) * 100),5);
AK:=EMA((((CLOSE - VAR1) / (VAR2 - VAR1)) * 50),13);
A3:=(C-LLV(L,9))/(HHV(H,9)-LLV(L,9))*100;
A4:=SMA(A3,3,1);
A5:=SMA(A4,3,1);
A6:=3*A4-2*A5;
A7:=C-REF(C,1);
A8:=100*EMA(EMA(A7,6),6)/EMA(EMA(ABS(A7),6),6);
可买:=LLV(A8,2)=LLV(A8,7) AND COUNT(A8<0,2) AND CROSS(A8,MA(A8,2));
稳定:=(CLOSE>REF(OPEN ,1))AND(VOL>REF(VOL,1));
安全买:=(CLOSE>REF(OPEN ,1))AND(VOL>REF(VOL ,1))AND(REF(CLOSE,1)<REF(OPEN ,1));
神底:=CROSS(AK1,AK);
稳:=稳定 OR 稳定1;
次级买:=可买 OR 安全买;
抄底:=CROSS(C,底部支撑) AND O<HHV(H,1);
买入:=CROSS(C,底部支撑) OR CROSS(C,买卖) OR CROSS(C,操作);
买:=(ZIG(3,5)>REF(ZIG(3,5),1)) AND (REF(ZIG(3,5),1)<=REF(ZIG(3,5),2)) AND (REF(ZIG
(3,5),2)<=REF(ZIG(3,5),3));
上升:=AAX>0;
出货:=(CLOSE<REF(OPEN,1))AND(VOL>REF(VOL ,1))AND(REF(CLOSE ,1)>REF(OPEN ,1));
快卖:=(CLOSE<REF(OPEN ,1))AND(VOL>REF(VOL ,1))AND(REF(CLOSE,1)>REF(OPEN ,1));
次级卖:=出货 OR 快卖;
卖出:=CROSS(拉升,C) OR CROSS(买卖,C) OR CROSS(压力,C) OR CROSS(操作,C);
卖:=(ZIG(3,5)<REF(ZIG(3,5),1)) AND (REF(ZIG(3,5),1)>=REF(ZIG(3,5),2)) AND (REF(ZIG
(3,5),2)>=REF(ZIG(3,5),3));
下降:=CROSS(0,AAX);
XG:=买 AND (稳 OR 抄底 OR 上升 OR 神底);
XG1:=BARSLAST(买=1)=1 AND (次级买 OR 稳 OR 抄底 OR 买入 OR 上升);
XG2:=BARSLAST(买=1)=2 AND (次级买 OR 稳 OR 抄底 OR 买入 OR 上升);
GO:=XG OR XG1 OR XG2;
开:=FILTER(GO,2);
XGS:=卖 AND ( 次级卖 OR 卖出 OR 卖 OR 下降);
XGS1:=BARSLAST(卖=1)=1 AND ( 次级卖 OR 卖出 OR 卖 OR 下降);
RUN:=XGS OR XGS1;
关:=FILTER(RUN,2);
开时:=BARSLAST(开);
关时:=BARSLAST(关);
风控多头:开时<关时,COLOR3333FF;
风控空头:开时>关时,COLORC2FF68;
DRAWTEXT_FIX((风控多头>0 AND BARSTATUS=2),0.5,0.5,0,'【当前风控市况:多头强势,追击龙头 谢谢孤星】'),COLOR3333FF,LINETHICK3;
DRAWTEXT_FIX((风控空头>0 AND BARSTATUS=2),0.5,0.5,0,'【当前风控市况:空头强势,禁止操作 谢谢孤星】'),COLORC2FF68,LINETHICK3;

通达信佐罗风控指标公式

 

相关文章