在线检测未来函数

通达信黑马换手指标公式

来源:Internet,编辑:股旁网,2017-01-23

TOTAL:=IF(PERIOD=1,5,IF(PERIOD=2,15,IF(PERIOD=3,30,IF(PERIOD=4,60,IF(PERIOD=5,240,1)))));
MTIME:=MOD(FROMOPEN,TOTAL);
CTIME:=IF(MTIME<0.5,TOTAL,MTIME);
VOLPERCENT:=VOL*10000/FINANCE(7);
VVOL:IF(CURRBARSCOUNT=1,VOLPERCENT*TOTAL/CTIME,DRAWNULL),NODRAW;
STICKLINE(CURRBARSCOUNT=1 && (SETCODE=0 || SETCODE=1),VVOL,0,-1,-1),COLOR00C0C0;
VOL_TR:VOLPERCENT,COLORLIGREEN,VOLSTICK;
MAVOL5:MA(VOL_TR,5);
MAVOL35:MA(VOL_TR,35)LINETHICK3;
MAVOL60:MA(VOL_TR,60);
MAVOL135:MA(VOL_TR,135),LINETHICK2;
BL:=VOLPERCENT=HHV(VOLPERCENT,20);
STICKLINE(BL AND C>O,VOL_TR,0,1.5,0),COLORYELLOW;{符合选股条件在K线上用黄色显示}
STICKLINE(BL AND C<O,VOL_TR,0,1.5,0),COLOR00FF00;{符合选股条件在K线上用绿色显示}
DL5:=VOLPERCENT=LLV(VOLPERCENT,5) AND C<O;
STICKLINE(DL5,0,VOL_TR,1.5,0),COLOR00FF00;
百日低量:=VOLPERCENT<=LLV(VOLPERCENT,100);
DRAWTEXT(百日低量,VOLPERCENT,'百'),COLORGREEN;
即时虚拟量:=IF(CURRBARSCOUNT=1 AND PERIOD=5,VOLPERCENT/FROMOPEN*240,DRAWNULL);
虚拟量:=IF(CURRBARSCOUNT>1,VOLPERCENT,即时虚拟量);
即时量比:=虚拟量/REF(MA(虚拟量,5),1);
YD:=IF(C>O AND VOLPERCENT>REF(VOLPERCENT,1)*1.10,1,IF(C<O AND VOLPERCENT<REF(VOLPERCENT,1)*0.90,1,IF(VOLPERCENT>REF(VOLPERCENT,1)*0.90 AND VOLPERCENT<REF(VOLPERCENT,1)*1.1,0,-1)));
量价异动:SUM(YD,10) * IF(HHV(即时量比,10)>1.5,1,0),NODRAW;
红胜:=C>O AND C>REF(C,1);
三日不破顶:=MIN(LLV(C,2),C)>=REF(C,3) AND REF(C,3)>REF(O,3) AND REF(C,3)>REF(C,4);
三日不破底:=MIN(LLV(C,2),C)>=REF(O,3) AND REF(C,3)>REF(O,3) AND REF(C,3)>REF(C,4);
三日量缩:=MAX(HHV(V,2),V)<REF(V,3);
三日价涨:=MIN(LLV(C,2),C)>=REF(C,3);
三日价不破:=MIN(LLV(C,2),C)>=REF(O,3);
缩倍柱:=VOLPERCENT*1.95<=REF(VOLPERCENT,1);
倍量柱:=VOLPERCENT>=REF(VOLPERCENT,1)*1.95 AND 红胜;
四日倍量柱:=REF(VOLPERCENT,3)>1.95*REF(VOLPERCENT,4);
黄金柱:=四日倍量柱 AND 三日不破顶 AND 三日量缩 AND 三日价涨;
BACKSET101:=BACKSET(黄金柱,4);
FILTER101:=FILTER(BACKSET101,3);
ISNOTGOLDLINE:=IF(FILTER101,0,1);
将军柱:=四日倍量柱 AND 三日不破底 AND 三日量缩 AND 三日价不破;
BACKSET102:=BACKSET(将军柱,4);
FILTER102:=FILTER(BACKSET102,3) AND ISNOTGOLDLINE;
T:=VOLPERCENT>0;
VO:=VOLPERCENT=LLV(VOLPERCENT,100) AND T;
地量柱:VOLPERCENT * VO,COLORBLUE;
DRAWTEXT(地量柱,VOLPERCENT,'地'),COLORBLUE;
BLZ:=VOLPERCENT>REF(VOLPERCENT,1)*1.9;
BLZ1:=VOLPERCENT<REF(LLV(VOLPERCENT,13),1);
BLZ2:=VOLPERCENT<REF(LLV(VOLPERCENT,55),1);
倍量:VOLPERCENT*倍量柱,COLORYELLOW;
HJZ:=(3*C+H+L+O)/6;
HJZ2:=(8*HJZ+7*REF(HJZ,1)+6*REF(HJZ,2)+5*REF(HJZ,3)+4*REF(HJZ,4)+3*REF(HJZ,5)+2*REF(HJZ,6)+REF(HJZ,8))/36;
HJZ3:=VOLPERCENT=HHV(VOLPERCENT,10) AND VOLPERCENT>2*REF(VOLPERCENT,1) AND CLOSE>HJZ2 AND C>O;
黄金:FILTER(HJZ3,5)*VOLPERCENT,STICK,COLORRED,LINETHICK4;
DRAWTEXT(FILTER101,VOLPERCENT,'黄'),COLORRED;
DRAWTEXT(FILTER102,VOLPERCENT,'将'),COLORMAGENTA;
DRAWICON(CROSS(MA(V,5),MA(V,60)),0,23);
FLZ:=VOLPERCENT>REF(VOLPERCENT,1)*0.98 AND VOLPERCENT<REF(VOLPERCENT,1)*1.02,LINETHICK0;
DRAWTEXT(FLZ,VOLPERCENT,'平'),COLORMAGENTA;
{对手盘:(PERIOD=5)*(COUNT(C>REF(C,1) AND OPEN<CLOSE AND VOLPERCENT>REF(VOLPERCENT,1),10)-COUNT(C<REF(C,1) AND VOLPERCENT>REF(VOLPERCENT,1),10)),NODRAW}
十日换手:SUM(VOLPERCENT,10),NODRAW;

通达信黑马换手指标公式

 

相关文章