在线检测未来函数

通达信起伏指标公式

来源:Internet,编辑:股旁网,2017-02-20

Y1:=SMA(ABS(L-REF(L,1)),34,1);
Y2:=SMA(MAX(L-REF(L,1),0),34,2);
W:=-(EMA(IF(L<= LLV(L,34),Y1/Y2,-3),9));
A:=-(EMA(IF(L<= LLV(L,8),Y1/Y2,-3),9));
Y3:=SMA(ABS(H-REF(H,1)),34,1);
Y4:=-SMA(MIN(H-REF(H,1),0),34,2);
X:=3-(EMA(IF(H>= HHV(H,34),-Y3/Y4,3),9));
B:=3-(EMA(IF(H>= HHV(H,8),-Y3/Y4,3),9));
STICKLINE(X>3,X,3,3,0),COLORLIBLUE;
STICKLINE(X>10,X,REF(X,1),8,0),COLORBLUE;
STICKLINE(X>0,X,0,1,0),COLORRED;
STICKLINE(X<B,B,X,1,0),COLORYELLOW,LINETHICK1;
STICKLINE(W>A,0,3-A,3,-1),COLORCYAN,LINETHICK1;
{STICKLINE(W>A,3-W,3-A,3,0),COLORCYAN,LINETHICK1;}
STICKLINE(W<0,0,ABS(W),3,0),COLORMAGENTA;
NOTEXT0:0,COLORWHITE;
DIFL:=EMA(V,12)-EMA(V,26);
DIF:=EMA(C,12)-EMA(C,26);
底BL:=DIFL>REF(DIFL,1) AND DIF<REF(DIF,1);
顶BL:=DIFL<REF(DIFL,1) AND DIF>REF(DIF,1);
DRAWICON(((W<0 AND W<REF(W,1)) OR (A<0 AND A<REF(A,1))) AND 底BL,0.1,1);
DRAWICON(((X>0 AND X>REF(X,1)) OR (B>0 AND B>REF(B,1))) AND 顶BL,3,2);
K:="SKDJ.K";
DRAWICON(((W<0 AND W<REF(W,1)) OR (A<0 AND A<REF(A,1))) AND 底BL AND K<20,-0.2,13);
DRAWICON(((X>0 AND X>REF(X,1)) OR (B>0 AND B>REF(B,1))) AND 顶BL AND K>80,3.2,14);

通达信起伏指标公式

 

相关文章