在线检测未来函数

通达信中短方向指标公式

来源:Internet,编辑:股旁网,2017-03-01

DRAWGBK(1,RGB(38,16,6.18),RGB(16,38,6.18),0,1,0);
VAR1:=(C+L+H)/3;
VAR2:=SMA(VAR1,5,1)-SMA(VAR1,13,1);
VAR3:=(VAR2-SMA(VAR2, 3,1))*100,COLORFFCCFF,NODRAW;
VAR4:=SMA(VAR3,5,2),COLORRED,LINETHICK0;
VAR5:=IF(VAR3>=REF(VAR3,1),VAR3,DRAWNULL);
VAR6:=IF(VAR3<REF(VAR3,1),VAR3,DRAWNULL);
STICKLINE(VAR5,0,VAR3,1,0),COLORRED;
STICKLINE(VAR6,0,VAR3,1,0),COLORLICYAN;
VAR7:=EMA(CLOSE,12)-EMA(CLOSE,26)*10;
VAR8:=EMA(VAR7,9);
涨跌线:VAR3,COLORYELLOW,NODRAW;
VAR9:=(HHV(HIGH,25)-LLV(LOW,25))/EMA((CLOSE-LLV(LOW,25)),5);
趋势H:(EMA(VAR9,20)-2.5)*3,COLORGREEN,LINETHICK1;
中趋势L:(-EMA(VAR9,20)+2.5)*3,COLORMAGENTA,LINETHICK1;
DRAWICON(((((LLV(VAR3,4)>0) AND (VAR3<REF(VAR3,1)))
AND (REF(VAR3,1)>REF(VAR3,2))) AND (REF(VAR3,2)>REF(VAR3,3))),中趋势L,2);
DRAWICON(((((HHV(VAR3,4)<0) AND (VAR3>REF(VAR3,1)))
AND (REF(VAR3,1)<REF(VAR3,2))) AND (REF(VAR3,2)<REF(VAR3,3))),中趋势H,1);

通达信中短方向指标公式

 

相关文章