在线检测未来函数

通达信看趋势主图指标公式

来源:Internet,编辑:股旁网,2017-03-08

E:=FINANCE(34);
F:=FINANCE(20);
G:=FINANCE(21);
I:=(FINANCE(37)>=-20)*FINANCE(37)+(FINANCE(37)<-20)*-20;
P:=(FINANCE(18)>0.01)*FINANCE(18)+(FINANCE(18)<0.01)*0.01;
S:=(FINANCE(32)>=-2.5)*FINANCE(32)+(FINANCE(32)<-2.5)*-2.5;
T:=FINANCE(1);
U:=(FINANCE(19)>=0)*FINANCE(19)+(FINANCE(19)<0)*0.01;
M:=CLOSE;
SY:=DYNAINFO(39);
WF:=1/(S/CLOSE+1);
SJ:=0.2/(E/M+2)+1;
JZ:=3/(I+21)+1;
GJ:=M/P*0.01+1;
YL:=1/(G/F+1);
GQ:=T/U+1;
市盈率:SY,COLOR3FAB3F,NODRAW;
毛利润率:G/F*100,COLOR3FD13F,NODRAW;
市净率:CLOSE/E,COLORBBFF3F,NODRAW;
股东人数:FINANCE(8),NODRAW;
人均持股:FINANCE(7)/FINANCE(8),NODRAW;
每股现金流量:FINANCE(25)/FINANCE(1),NODRAW;
利润同比%:FINANCE(43),NODRAW;
收入同比%:FINANCE(44),NODRAW;
净资产收益率:=FINANCE(30)/FINANCE(19)*100;
DRAWTEXT_FIX(1>0,0.0,0,0,'净资产收益率');
DRAWNUMBER_FIX(1>0,0.0,0.25,0,净资产收益率);
DRAWTEXT_FIX(1>0,0.28,0,0,'行业板块');
DRAWTEXT_FIX(1>0,0.28,0.25,0,HYBLOCK);
DRAWTEXT_FIX(1>0,0.38,0,0,'概念板块');
DRAWTEXT_FIX(1>0,0.38,0.25,0,GNBLOCK);
{每股净资产}
DRAWTEXT_FIX(1>0,0.1,0,0,'每股净资产');
DRAWNUMBER_FIX(1>0,0.1,0.25,0,FINANCE(34));
{流通市值}
流通市值:=FINANCE(40)/100000000;
DRAWTEXT_FIX(1>0,0.2,0,0,'流通市值');
DRAWNUMBER_FIX(1>0,0.2,0.25,0,流通市值);
MB1:=EMA(C,5),COLORRED,LINETHICK2;
MB2:EMA(MB1,2),COLORYELLOW;
MB3:EMA(MB2,2),COLORYELLOW;
MB4:EMA(MB3,2),COLORYELLOW;
MB5:EMA(MB4,2),COLORYELLOW;
MB6:EMA(MB5,2),COLORYELLOW;
MB7:EMA(MB6,2),COLORYELLOW;
MB8:EMA(MB7,2),COLORYELLOW;
MB9:EMA(MB8,2),COLORYELLOW;
MB10:EMA(MB9,2),COLORYELLOW;
MB11:EMA(MB10,2),COLORYELLOW;
MB12:EMA(MB11,2),COLORYELLOW;
MB13:EMA(MB12,2),COLORYELLOW;
MB14:EMA(MB13,2),COLORYELLOW;
A1:IF(MB1<REF(MB1,1),MB2,DRAWNULL),COLORBLUE,LINETHICK1;
A2:IF(MB2<REF(MB2,1),MB2,DRAWNULL),COLORBLUE,LINETHICK1;
A3:IF(MB3<REF(MB3,1),MB3,DRAWNULL),COLORBLUE,LINETHICK1;
A4:IF(MB4<REF(MB4,1),MB4,DRAWNULL),COLORBLUE,LINETHICK1;
A5:IF(MB5<REF(MB5,1),MB5,DRAWNULL),COLORBLUE,LINETHICK1;
A6:IF(MB6<REF(MB6,1),MB6,DRAWNULL),COLORBLUE,LINETHICK1;
A7:IF(MB7<REF(MB7,1),MB7,DRAWNULL),COLORBLUE,LINETHICK1;
A8:IF(MB8<REF(MB8,1),MB8,DRAWNULL),COLORBLUE,LINETHICK1;
A9:IF(MB9<REF(MB9,1),MB9,DRAWNULL),COLORBLUE,LINETHICK1;
A10:IF(MB10<REF(MB10,1),MB10,DRAWNULL),COLORBLUE,LINETHICK1;
A11:IF(MB11<REF(MB11,1),MB11,DRAWNULL),COLORBLUE,LINETHICK1;
A12:IF(MB12<REF(MB12,1),MB12,DRAWNULL),COLORBLUE,LINETHICK1;
A13:IF(MB13<REF(MB13,1),MB13,DRAWNULL),COLORBLUE,LINETHICK1;
A14:IF(MB14<REF(MB14,1),MB14,DRAWNULL),COLORBLUE,LINETHICK1;
VAR2:MB1,COLORMAGENTA,LINETHICK2;
VAR3:IF(VAR2<REF(VAR2,1),VAR2,DRAWNULL),COLORBLUE,LINETHICK2;
DRAWKLINE(H,O,L,C);

通达信看趋势主图指标公式

 

相关文章