在线检测未来函数

通达信反转形态主图指标公式

来源:Internet,编辑:股旁网,2017-03-13

HT:=HHVBARS(H,15);
LT:=LLVBARS(L,15);
DF1:=(REF(C,LT)-REF(C,HT+1))/REF(C,HT+1)*100;
DF2:=(C-REF(C,LT+1))/REF(C,LT+1)*100;
TJ:=C>=REF(C,HT);
V型:=HT>LT AND DF1<-5 AND COUNT(TJ,HT+1)=1 AND TJ AND ((C-REF(C,1))/C>0.04 OR (C-O)/C>0.04);
XGT:=BARSLAST(V型);
HQF:=BACKSET(V型,HT+1);
LQF:=BACKSET(V型,LT+1);
HQFT:=BARSLAST(CROSS(HQF=1,0.5));
LQFT:=BARSLAST(CROSS(LQF=1,0.5));
NOTEXT1:DRAWLINE(HQFT=0,H,LQFT=0,L,0),COLORRED,LINETHICK6;
NOTEXT2:DRAWLINE(LQFT=0,L,V型,L,0),COLORRED,LINETHICK6;
TJ1:=O/C>1.05 AND C/REF(C,1)<0.94;
TJ2:=REF(C,1)/REF(C,2)<1.09 AND L=LLV(L,5);
TJ3:=TJ1 AND TJ2;
TJ4:=BARSLAST(TJ3);
TJ5:=BETWEEN(TJ4,4,15);
TJ6:=C/REF(C,1)>1.02 AND O/REF(C,TJ4)<1.03 AND C/REF(C,TJ4)>1.02;
TJ7:=COUNT(TJ6,TJ4)=1;
TJ8:=REF(O,1)/REF(C,TJ4)>1.03;
TJ9:=C/REF(C,1)>1.04;
TJ10:=EVERY(BETWEEN(O/REF(C,TJ4),1.05,0.9),TJ4);
U型:=TJ5 AND TJ6 AND TJ7 AND TJ9 AND REF(TJ10,1);
QF2:=BACKSET(U型=1,TJ4+1);
QFT2:=BARSLAST(CROSS(QF2=1,0.5));
NOTEXT3:DRAWLINE(QFT2=0,L,U型,REF(L,QFT2),0),COLORMAGENTA,LINETHICK8;
STICKLINE(QFT2=0,O,L,3,0),COLORMAGENTA;
STICKLINE(U型,C,REF(L,BARSLAST(QFT2=0)),3,0),COLORMAGENTA;
T:=BARSLAST(H<REF(L,1));
LKL:=REF(L,T+1);
TJ110:=HHV(H,T+1);
TJ11:=CROSS(C,REF(L,T+1));
TJ12:=TJ110<REF(L,T+1);
突破幅度:=(C/REF(L,T+1)-1)*100;
突破量:=VOL/REF(VOL,1);
ZF:=(REF(L,T+1)-LLV(L,T+1))/LLV(L,T+1)*100;
岛型:=REF(TJ12,1) AND TJ11 AND 突破量>2 AND ZF<10 AND 突破幅度>3;
QF:=BACKSET(岛型,T+2);
QFT:=BARSLAST(CROSS(QF=1,0.5));
NOTEXT4:DRAWLINE(QFT=0,L,岛型,REF(L,QFT),0),COLORYELLOW;
STICKLINE(岛型,C,O,3,0),COLORYELLOW;
FT:=BACKSET(岛型,T+1);
STICKLINE(FT AND 岛型=0,C,O,3,0),COLORYELLOW;
STICKLINE(FT AND 岛型=0,H,L,0,0),COLORYELLOW;
STICKLINE(FT AND 岛型=0,LKL,LKL,4,0),COLORYELLOW;
STICKLINE(FT AND 岛型=0,REFX(REF(TJ110,1),BARSNEXT(岛型)),REFX(REF(TJ110,1),BARSNEXT(岛型)),4,0),COLORYELLOW;

通达信反转形态主图指标公式

 

相关文章