在线检测未来函数

通达信阻力支撑很准指标公式

来源:Internet,编辑:股旁网,2017-06-05

STICKLINE(TIME2=94100 AND REF(C,BARSLAST(TIME2=94100))>=REF(C,BARSLAST(TIME2=93100)),DYNAINFO(3)*1.03,DYNAINFO(3)*0.97,1,-1),COLORRED;
STICKLINE(TIME2=94100 AND REF(C,BARSLAST(TIME2=94100))<REF(C,BARSLAST(TIME2=93100)),DYNAINFO(3)*1.03,DYNAINFO(3)*0.97,1,-1),COLORGREEN;
STICKLINE(TIME2=95100 AND REF(C,BARSLAST(TIME2=95100))>=REF(C,BARSLAST(TIME2=94100)),DYNAINFO(3)*1.03,DYNAINFO(3)*0.97,1,-1),COLORRED;
STICKLINE(TIME2=95100 AND REF(C,BARSLAST(TIME2=95100))<REF(C,BARSLAST(TIME2=94100)),DYNAINFO(3)*1.03,DYNAINFO(3)*0.97,1,-1),COLORGREEN;
STICKLINE(TIME2=100100 AND REF(C,BARSLAST(TIME2=100100))>=REF(C,BARSLAST(TIME2=95100)),DYNAINFO(3)*1.03,DYNAINFO(3)*0.97,1,-1),COLORRED;
STICKLINE(TIME2=100100 AND REF(C,BARSLAST(TIME2=100100))<REF(C,BARSLAST(TIME2=95100)),DYNAINFO(3)*1.03,DYNAINFO(3)*0.97,1,-1),COLORGREEN;
SJ1:=TIME2=93100;T1:=BARSLAST(SJ1);SJ2:=TIME2=94100;
SJ4:=TIME2=95100;T2:=BARSLAST(SJ2);T4:=BARSLAST(SJ4);
H1:=IF(TIME2=94100,REF(C,T2),DRAWNULL)=C;
H2:=IF(TIME2=95100,REF(C,T4),DRAWNULL)=C;
CS2:=CONST(REF(C,T2));
CS4:=CONST(REF(C,T4));
GL2:=FILTERX(H1,T2);
GL4:=FILTERX(H2,T4);
L1:=IF(TIME2=93100,REF(C,T1),DRAWNULL)=C;
CS1:=CONST(REF(C,T1));
GL1:=FILTERX(L1,T1);
DA:=CONST(IF(REF(GL2,BARSLAST(GL2)),REF(BARSLAST(GL1),BARSLAST(GL2)),DRAWNULL));
DA1:=CONST(IF(REF(GL4,BARSLAST(GL4)),REF(BARSLAST(GL2),BARSLAST(GL4)),DRAWNULL));
A:=IF(BARSLAST(GL1)>=0 AND BARSLAST(GL1)<=DA,((CS2-CS1)/DA)*BARSLAST(GL1)+CS1,DRAWNULL);
B:=IF(BARSLAST(GL2)>=0 AND BARSLAST(GL2)<=DA1,((CS4-CS2)/DA1)*BARSLAST(GL2)+CS2,DRAWNULL);
IF(A>=REF(A,2),A,DRAWNULL)COLORLIMAGENTA,LINETHICK3;
IF(A<REF(A,2),A,DRAWNULL)COLORGREEN,LINETHICK5;
IF(B>=REF(B,2),B,DRAWNULL)COLORLIMAGENTA,LINETHICK3;
IF(B<REF(B,2),B,DRAWNULL)COLORGREEN,LINETHICK3;
XSJ1:=TIME2=95100;
XT1:=BARSLAST(XSJ1);
XSJ2:=TIME2=100100;
XT2:=BARSLAST(XSJ2);
XCS2:=CONST(REF(C,XT2));
XL1:=IF(TIME2=95100,REF(C,XT1),DRAWNULL)=C;
XH1:=IF(TIME2=100100,REF(C,XT2),DRAWNULL)=C;
XCS1:=CONST(REF(C,XT1));
XGL1:=FILTERX(XL1,XT1);
XGL2:=FILTERX(XH1,XT2);
XDA:=CONST(IF(REF(XGL2,BARSLAST(XGL2)),REF(BARSLAST(XGL1),BARSLAST(XGL2)),DRAWNULL));
XA:=IF(BARSLAST(XGL1)>=0 AND BARSLAST(XGL1)<=XDA,((XCS2-XCS1)/XDA)*BARSLAST(XGL1)+XCS1,DRAWNULL);
IF(XA>=REF(XA,1),XA,DRAWNULL)COLORLIMAGENTA,LINETHICK3;
IF(XA<REF(XA,1),XA,DRAWNULL)COLORGREEN,LINETHICK3;
时间:=TIME2=100100;
N:=BARSLAST(时间);
C1:CONST(IF(N,MAX(REF(HHV(H,0),N+1),DYNAINFO(4)),HHV(H,0))),DOTLINE,COLORRED;
C2:CONST(IF(N,MIN(REF(LLV(L,0),N+1),DYNAINFO(4)),LLV(L,0))),DOTLINE,COLORGREEN;
C3:(C1+C2)/2,DOTLINE,COLORYELLOW;
VV:=HHV(V,0);
ZF:=(C1/C2-1)*100;
DRAWTEXT(CURRBARSCOUNT=2,C1,VARCAT(VARCAT(VARCAT(VARCAT('上限:',VAR2STR(C1,2)),'元'),VARCAT('振幅:',VAR2STR(ZF,2))),'%')),COLORRED;
DRAWTEXT(CURRBARSCOUNT=2,C3,VARCAT(VARCAT('中限:',VAR2STR(C3,2)),'元')),COLORYELLOW;
DRAWTEXT(CURRBARSCOUNT=2,C2,VARCAT(VARCAT('下限:',VAR2STR(C2,2)),'元')),COLORGREEN;
DRAWTEXT(C1/C2<=1.03 AND CROSS(C,C1) AND V>=VV,C1*1.005,'★买入')COLORRED;
DRAWTEXT(C1/C2<=1.03 AND CROSS(C2,C) AND V>=VV,C2*0.998,'★卖出')COLORGREEN;
STICKLINE(C1/C2<1.03 AND CROSS(C,C1) AND V>=VV,DYNAINFO(3)*1.03,DYNAINFO(3)*0.97,1,0),COLORRED;
AAA:=MAX(DYNAINFO(3),DYNAINFO(5));
BBB:=MIN(DYNAINFO(3),DYNAINFO(6));
CCC:=AAA-BBB;
中轨:=(AAA+BBB)/1,POINTDOT;
阻力:BBB+CCC*7/8,COLORBLUE,POINTDOT;
支撑:BBB+CCC*1/8,COLORMAGENTA,POINTDOT;
支撑1:BBB+CCC*0.5/8,POINTDOT;
上顶:BBB+CCC*2/3,POINTDOT;
下底:BBB+CCC/3,COLORBLUE,POINTDOT;
STICKLINE(C>阻力,阻力,C,2,0),COLORGREEN;
STICKLINE(C<支撑,支撑,C,2,0),COLORLIMAGENTA;
DRAWTEXT(LONGCROSS(支撑1,C,2),下底,'B'),COLORYELLOW; DRAWTEXT(LONGCROSS(C,阻力,2),上顶,'S'),COLORRED;

通达信阻力支撑很准指标公式

 

相关文章