在线检测未来函数

通达信峰谷趋势主图指标公式

来源:Internet,编辑:股旁网,2017-08-01

N:=6;
AA:=REF(H,N)=HHV(H,2*N+1);
BB:=BACKSET(AA,N+1);
CC:=FILTER(BB,N) AND H=HHV(H,N+1);
DD:=BARSLAST(CC);
EE:=IF(CC,CURRBARSCOUNT,0);
GG:=IF(DD,REF(H,DD),H);
HH:=IF(DD,REF(EE,DD),EE);
KK:=REF(GG,DD+1);
CS1:=CONST(HH);
JJ:=REF(HH,DD+1);
CS2:=CONST(JJ);
近高:DRAWLINE(CURRBARSCOUNT=CS1,H,ISLASTBAR,REF(H,CS1-1),1)COLOR00FF00 DOTLINE;
前高:DRAWLINE(CURRBARSCOUNT=CS2,H,ISLASTBAR,REF(H,CS2-1),1)COLOR00FF00 DOTLINE;
A1:=REF(H,N)=HHV(H,2*N+1); B1:=FILTER(A1,N); C1:=BACKSET(B1,N+1); D1:=FILTER(C1,N);
A2:=REF(L,N)=LLV(L,2*N+1); B2:=FILTER(A2,N); C2:=BACKSET(B2,N+1); D2:=FILTER(C2,N);
E1:=(REF(LLV(L,2*N),1)+REF(HHV(H,2*N),1))/2; E2:=(H+L)/2;
H1:=(D1 AND NOT(D2 AND E1>=E2)) OR BARSTATUS OR BARSCOUNT(CLOSE)=1;
L1:=(D2 AND NOT(D1 AND E1<E2)); H2:=D1 AND NOT(D2 AND E1>=E2);
X1:=REF(BARSLAST(H1),1)+1; F1:=BACKSET(H1 AND COUNT(L1,X1)>0,LLVBARS(IF(L1,L,10000),X1));
G1:=F1>REF(F1,1); I1:=BACKSET(G1,2); LD:=I1>REF(I1,1);
L2:=LD OR BARSTATUS OR BARSCOUNT(CLOSE)=1;
X2:=REF(BARSLAST(L2),1)+1; F2:=BACKSET(L2 AND COUNT(H2,X2)>0,HHVBARS(IF(H2,H,0),X2));
G2:=F2>REF(F2,1); I2:=BACKSET(G2,2); HD:=I2>REF(I2,1);
YY:=BACKSET(BARSTATUS,BARSLAST(LD)+1);
VV:=YY>REF(YY,1);
WW:=BACKSET(VV,REF(BARSLAST(LD),1)+2);
XX:=WW>REF(WW,1);
YY2:=BACKSET(BARSTATUS,BARSLAST(HD)+1);
VV2:=YY2>REF(YY2,1);
WW2:=BACKSET(VV2,REF(BARSLAST(HD),1)+2);
XX2:=WW2>REF(WW2,1);
近低:REF(L,BARSLAST(VV)) COLOR0000FF DOTLINE;
前低:REF(L,BARSLAST(XX)) COLOR0000FF DOTLINE;

通达信峰谷趋势主图指标公式

 

相关文章