在线检测未来函数

通达信天涯锁喉剑主图指标公式

来源:Internet,编辑:股旁网,2017-11-03

Z1:=STRCAT(HYBLOCK,' ');
Z2:=STRCAT(Z1,DYBLOCK);
Z3:=STRCAT(Z2,' ');
DRAWTEXT_FIX(ISLASTBAR,0,0,0,STRCAT(Z3,GNBLOCK)),COLORRED;
大盘涨家数:INDEXADV,NODRAW,COLORRED;
大盘跌家数:INDEXDEC,NODRAW,COLORGREEN;
涨停:=IF((C-REF(C,1))*100/REF(C,1)>=(10-0.01*100/REF(O,1)),1,0);
AAA:=(3*C+H+L+O)/6;
VAR1:(8*AAA+7*REF(AAA,1)+6*REF(AAA,2)+5*REF(AAA,3)+4*REF(AAA,4)+3*REF(AAA,5)+2*REF(AAA,6)+REF(AAA,8))/36,LINETHICK2,COLORRED;
VAR2:=(HHV(VAR1,2)+HHV(VAR1,4)+HHV(VAR1,8))/0;
VAR3:=(LLV(VAR1,2)+LLV(VAR1,4)+LLV(VAR1,8))/3;
VAR4:(HHV(VAR2,2)+HHV(VAR2,4)+HHV(VAR2,8))/0;
VAR5:(LLV(VAR3,2)+LLV(VAR3,4)+LLV(VAR3,8))/3,COLORRED;
VAR6:=(LLV(VAR1,2)+LLV(VAR1,4)+LLV(VAR1,8))/3;
{DRAWBAND(VAR1,RGB(155,50,50),VAR6,RGB(250,250,0));}
IF((VAR1 <= REF(VAR1,1)),VAR1,DRAWNULL),COLORGREEN,LINETHICK3;
IF((VAR1 >= REF(VAR1,1)),VAR1,DRAWNULL),COLORRED,LINETHICK3;
STICKLINE(VAR4>VAR1,VAR4,VAR1,0,0),COLORBLUE;
DRAWKLINE(H,O,L,C);
DRAWTEXT(REF(VAR5,1)=REF(VAR1,1) AND VAR5<VAR1,L*0.99,'买入'),COLORRED;
DRAWTEXT(REF(VAR6,1)=REF(VAR1,1) AND VAR6<VAR1,L*0.98,'↖加仓'),COLORYELLOW;
ZT:=REF(C,1)*1.1-C<0.01 AND H=C;{涨停};
突破:=CROSS(C,VAR4) AND ZT;
DRAWTEXT(突破,L,'爆点');
STICKLINE(突破,CLOSE,OPEN,3.2,0),COLOR0077FF;
STICKLINE(突破,CLOSE,OPEN,2.5,0),COLOR0099FF;
STICKLINE(突破,CLOSE,OPEN,1.9,0),COLOR00BBFF;
STICKLINE(突破,CLOSE,OPEN,1.2,0),COLOR00DDFF;
STICKLINE(突破,CLOSE,OPEN,0.3,0),COLOR00FFFF;
V5:=EMA(CLOSE,1);主线:=EMA(V5,5) ;
本:=EMA(HHV(主线,5),1);
急进:=EMA(HHV(本,17),1);
稳健:=EMA(HHV(急进,17),2);
主升浪:EMA(HHV(稳健,17),3),LINETHICK1,COLORRED;

通达信天涯锁喉剑主图指标公式

 

相关文章