在线检测未来函数

通达信五分钟看盘主图指标公式

来源:Internet,编辑:股旁网,2017-11-15

T1:=IF(PERIOD=1,BARSLAST(TIME2=095000),DRAWNULL);
T2:=IF(PERIOD=1,BARSLAST(TIME2=094500),DRAWNULL);
T3:=IF(PERIOD=1,BARSLAST(TIME2=100000),DRAWNULL);
C2:=REF(C,T2);
C3:=REF(C,T3);
ZF:=(C3-C2)/C2*100;
XF:=REFX(ZF,2);
HH:=HHV(H,3);
LL:=LLV(L,3);
XH:=REFX(HH,2);
XL:=REFX(LL,2);
XC:=REFX(C,2);
DRAWLINE(T1=0 AND O<XC,XH,T3=0 AND C>REF(O,T1),HH,0),DOTLINE,COLORMAGENTA;
DRAWLINE(T1=0 AND O>XC,XH,T3=0 AND C<REF(O,T1),HH,0),DOTLINE,COLORGREEN;
DRAWLINE(T1=0 AND O=XC,XH,T3=0 AND C=REF(O,T1),HH,0),DOTLINE,COLORWHITE;
DRAWLINE(T1=0 AND O<XC,XL,T3=0 AND C>REF(O,T1),LL,0),DOTLINE,COLORMAGENTA;
DRAWLINE(T1=0 AND O>XC,XL,T3=0 AND C<REF(O,T1),LL,0),DOTLINE,COLORGREEN;
DRAWLINE(T1=0 AND O=XC,XL,T3=0 AND C=REF(O,T1),LL,0),DOTLINE,COLORWHITE;
STICKLINE(T1=0 AND O<XC,XH,XL,0,-1),COLORMAGENTA;
STICKLINE(T3=0 AND C>REF(O,T1),HH,LL,0,-1),COLORMAGENTA;
STICKLINE(T1=0 AND O>XC,XH,XL,0,-1),COLORGREEN;
STICKLINE(T3=0 AND C<REF(O,T1),HH,LL,0,-1),COLORGREEN;
STICKLINE(T1=0 AND O=XC,XH,XL,0,-1),COLORWHITE;
STICKLINE(T3=0 AND C=REF(O,T1),HH,LL,0,-1),COLORWHITE;
DRAWTEXT(T1=0,XH*1.005,VARCAT(VARCAT('三K涨跌幅:',VAR2STR(XF,2)),'%')),COLORWHITE;
DRAWTEXT_FIX(1,0.069,0.896,0,'1、研判条件:运用5分钟K线图。'),COLORYELLOW;
DRAWTEXT_FIX(1,0.069,0.931,0,'2、准确特性:预测大势高达90%,预测个股达80%左右。'),COLORLIBLUE;
DRAWTEXT_FIX(1,0.069,0.976,0,'3、基本原理:开盘半小时多空双方的较量,基本决定和影响全天多空双方的价位观点,从而决定一天的走势。'),COLORLIGREEN;
压:DRAWLINE(HIGH>=HHV(HIGH,10),HIGH,LOW<=LLV(LOW,3),HHV(HIGH,3),1),COLORYELLOW,DOTLINE;
DRAWTEXT(1 AND ISLASTBAR, LLV(压,1),' 压'),COLORCYAN;
A2:=REF(L,5)=LLV(L,2*5+1);
B2:=FILTER(A2,5);
C22:=BACKSET(B2,5+1);
D2:=FILTER(C22,5);
E2:=BACKSET(ISLASTBAR,BARSLAST(D2)+1);
F2:=E2>REF(E2,1);
支:DRAWLINE(D2,L,F2,L,1),COLORLIBLUE,DOTLINE;
DRAWTEXT(1 AND ISLASTBAR, LLV(支,1),' 支'),COLORMAGENTA;
STICKLINE(CURRBARSCOUNT=2,REF(L,1)*0.968,H#MONTH,0,-1),COLORMAGENTA;

通达信五分钟看盘主图指标公式

 

相关文章