在线检测未来函数

通达信反弹与趋势线指标公式

来源:Internet,编辑:股旁网,2018-06-26

DRAWGBK(O>C,RGB(40,40,40),RGB(0,0,40),0,'?',0);
能量线:=EMA(100*(C-LLV(L,40))/(HHV(H,40)-LLV(L,40)),3),LINETHICK1;
RSI:=SMA(MAX(CLOSE-REF(CLOSE,1),0),6,1)/SMA(ABS(CLOSE-REF(CLOSE,1)),6,1)*100,LINETHICK1;
RSV:=(CLOSE-LLV(LOW,5))/(HHV(HIGH,5)-LLV(LOW,5))*100,LINETHICK1;
K:=SMA(RSV,3,1);
D:=SMA(K,3,1);
J:=3*K-2*D,LINETHICK1;
威廉WR:=(HHV(HIGH,25)-CLOSE)/(HHV(HIGH,25)-LLV(LOW,25))*100,LINETHICK1;
TYP:=(HIGH + LOW + CLOSE)/3;
CCI:=(TYP-MA(TYP,14))/(0.015*AVEDEV(TYP,14)),LINETHICK1;
反弹:MA((能量线+RSI+J-威廉WR+CCI)/5,5);
趋势:MA((能量线+RSI+J-威廉WR+CCI)/5,13);
MA((能量线+RSI+J-威廉WR+CCI)/5,5),COLOR00FF00,LINETHICK1;
KC:=FORCAST(((2*C+H+L)/4*0.618+C*0.382),3);
AAX:=(KC-MA(KC,9))/MA(KC,9)*100;
VAR0:=MIN(EXIST(KC,55),9);
AAX1:=EMA(AAX,VAR0)*VAR0;
AAX2:=MA(AAX1,3);
AAX3:=MA(AAX1,5);
卖:=AAX3>3 AND AAX1<REF(AAX1,1) AND CROSS(AAX2,AAX1);
VBA:=FILTER(卖,5);
VB2:=EMA(EMA(C-REF(C,1),6),6)/EMA(EMA(ABS(C-REF(C,1)),6),6)*100;
VB3:=IF(LLV(VB2,3)=LLV(VB2,11) AND COUNT(VB2<0,2) AND CROSS(VB2,MA(VB2,2)),1,0);
VB4:=FILTER(VB3=1,5);
DRAWTEXT(VB4,反弹*0.97,'买入'),COLORYELLOW,COLOR00FFFF;
VB21:=EMA(EMA(REF(C,1)-C,6),6)/EMA(EMA(ABS(REF(C,1)-C),6),6)*100;
VB31:=IF(HHV(VB21,3)=HHV(VB21,11) AND COUNT(VB21<0,2) AND CROSS(VB21,MA(VB21,2)),1,0);
VB41:=FILTER(VB31=1,5);
DRAWTEXT(VB31,反弹*1.08,'卖出'),COLOR0044FF;

通达信反弹与趋势线指标公式

 

相关文章