在线检测未来函数

通达信18转笔主图指标公式

来源:Internet,编辑:股旁网,2018-12-13

HH:=REF(H,5)=HHV(H,11);
LL:=REF(L,5)=LLV(L,11);
FG01:=BACKSET(HH,6)>BACKSET(HH,5) ;
FD01:=BACKSET(LL,6)>BACKSET(LL,5) ;
FG0:=FG01 AND H=HHV(H,BARSLAST(FD01));
FD0:=FD01 AND L=LLV(L,BARSLAST(FG01));
J0:=(H+L)/2;
FGH:=REF(H,BARSLAST(FG0));
FGH1:=REF(H,BARSLAST(FG0)+1);
FGL1:=REF(L,BARSLAST(FG0)+1);
FGH2:=REF(H,BARSLAST(FG0)+2);
FGL2:=REF(L,BARSLAST(FG0)+2);
FGJ0:=REF(J0,BARSLAST(FG0));
FGL:=REF(L,BARSLAST(FG0));
FDH:=REF(H,BARSLAST(FD0));
FDL:=REF(L,BARSLAST(FD0));
FDH1:=REF(H,BARSLAST(FD0)+1);
FDL1:=REF(L,BARSLAST(FD0)+1);
FDH2:=REF(H,BARSLAST(FD0)+2);
FDL2:=REF(L,BARSLAST(FD0)+2);
FDJ0:=REF(J0,BARSLAST(FD0));
FGZH:=IF(FGL<FGL1,FGH2,FGH1);
FGZL:=IF(FGL<FGL1,FGL2,FGL1);
FDZH:=IF(FDH>FDH1,FDH2,FDH1);
FDZL:=IF(FDH>FDH1,FDL2,FDL1);
FG1:=IF(((FGL>FDH AND FGH>FDZH) OR (FGH>FDH1 AND FDH1>FDH AND FDH>FDH2)),FG0
,FG0 AND FGJ0>FDH AND FGH>FDZH);
FD1:=IF(((FDH<FGL AND FDL<FGZL) OR (FDL<FGL1 AND FGL1<FGL AND FDL<FGL2)),FD0
,FD0 AND FDJ0<FGL AND FDL<FGZL);
FG2:=FG1 AND H>=HHV(H,BARSLAST(FD1));
FD2:=FD1 AND L<=LLV(L,BARSLAST(FG1));
FG:=FG2 AND KDJ.K>40;FD:=FD2 AND KDJ.K<60;
BK:=IF((FGL1>=FGL AND FG0) OR (FDH1<=FDH AND FD0),4,3);
G1:=FG AND BARSLAST(FD)>BK;
D1:=FD AND BARSLAST(FG)>BK;
G2:=G1 AND H>=HHV(H,BARSLAST(D1));
D2:=D1 AND L<=LLV(L,BARSLAST(G1));
G3:=G2 OR (FG0 AND KDJ.J>100);
D3:=D2 OR (FD0 AND KDJ.J<0);
G4:=G3 OR (FG0 AND REF(H,BARSLAST(FG0))>REF(H,BARSLAST(G2)) AND BARSLAST(D2)>BARSLAST(G2));
D4:=D3 OR (FD0 AND REF(L,BARSLAST(FD0))<REF(L,BARSLAST(D2)) AND BARSLAST(G2)>BARSLAST(D2));
G5:=G4 AND H=HHV(H,BARSLAST(D4));
D5:=D4 AND L=LLV(L,BARSLAST(G4));
GPB:=IF(G4,H,DRAWNULL),CIRCLEDOT,COLORYELLOW;
DPB:=IF(D4,L,DRAWNULL),CIRCLEDOT,COLORYELLOW;
NN:=G5;UU:=D5;
DRAWLINE(UU,L,NN, H,0),COLORYELLOW;
DRAWLINE(NN,H,UU, L,0),COLORYELLOW;
生命线:=MA(CLOSE,22),LINETHICK2,COLORRED;
A:=(3*C+L+O+H)/6;
X:=(20*A+19*REF(A,1)+18*REF(A,2)+17*REF(A,3)+16*REF(A,4)+15*REF(A,5)+
14*REF(A,6)+13*REF(A,7)+12*REF(A,8)+11*REF(A,9)+10*REF(A,10)+9*REF(A,11)+8*REF(A,12)
+7*REF(A,13)+6*REF(A,14)+5*REF(A,15)+4*REF(A,16)+3*REF(A,17)+2*REF(A,18)+
REF(A,20))/210;
S2:=SMA(C,3,1);
S6:=SMA(C,5,1);
DK:=2*(S2-S6);
主力成本:=EMA(X,13),COLORFF00FF,LINETHICK0;
短期底部:=LLV(HIGH,30),LINETHICK2,COLORFFCC00;
MA5:=MA(C,5);
MA10:=MA(C,10);
MA30:=MA(C,30);
FA:=BARSLAST(CROSS(MA10,MA5)) AND CROSS(MA5,MA10);
FB:=FA AND MA5>MA30 AND MA10>MA30 AND MA10>REF(MA10,1);
V1:=EMA(CLOSE,5);
V2:=EMA(EMA(CLOSE,90)*1.01,10);
VAR1:=LLV(LOW,21);
VAR2:=HHV(HIGH,21);
AK1:=EMA((((CLOSE - VAR1) / (VAR2 - VAR1)) * 100),5);
AK:=EMA((((CLOSE - VAR1) / (VAR2 - VAR1)) * 50),13);
AB:=CROSS(AK1,AK);
AA1:=AMOUNT/V;
BB1:=L<AA1*0.9;
CC1:=(C-REF(C,1))/REF(C,1)*100>1.2;
DD1:=L<MA(C,5)*0.921;
EE1:=V<MA(V,5)*1.5;
VAR3AA:=IF((CLOSE>REF(CLOSE,1)),88,0);
VAR4AA:=IF(((CLOSE)/(REF(CLOSE,1))>1.05) AND ((HIGH)/(CLOSE)<1.01) AND (VAR3AA>0),91,0);
A1AA:=9;
A2AA:=(REF(CLOSE,A1AA+1)<CLOSE);
VAR6:=REF(C,1);
VAR7:=SMA(MAX(C-VAR6,0),6,1)/SMA(ABS(C-VAR6),6,1)*100;
DRAWTEXT(CROSS(82,VAR7),H*1.01,'抛'),COLORGREEN;
STICKLINE(C/REF(C,1)>1.07,C,O,2,0),COLORYELLOW;
HJ_1:=CLOSE>REF(CLOSE,4);
HJ_2:=BARSLASTCOUNT(HJ_1);
HJ_3:=HJ_2=9;
HJ_4:=HJ_2=13;
HJ_5:=HJ_2=18;
HJ_6:=ISLASTBAR AND BETWEEN(HJ_2,1,8);
HJ_7:=ISLASTBAR AND BETWEEN(HJ_2,10,12);
HJ_8:=ISLASTBAR AND BETWEEN(HJ_2,14,17);
HJ_9:=(BACKSET(HJ_4>0,13) OR BACKSET(HJ_3>0,9) OR BACKSET(HJ_5>0,18) OR BACKSET(HJ_6>0,HJ_2) OR BACKSET(HJ_7>0,HJ_2) OR BACKSET(HJ_8>0,HJ_2))*HJ_2;
DRAWTEXT(HJ_9>0 AND HJ_9<18,HIGH*1.01,VAR2STR(HJ_9,0)),COLORMAGENTA;
DRAWTEXT(HJ_9>0 AND (HJ_2=9 OR HJ_2=13 OR HJ_2=18),HIGH*1.01,VAR2STR(HJ_9,0)),COLORGREEN;
HJ_10:=CLOSE<REF(CLOSE,4);
HJ_11:=BARSLASTCOUNT(HJ_10);
HJ_12:=HJ_11=9;
HJ_13:=HJ_11=13;
HJ_14:=HJ_11=18;
HJ_15:=ISLASTBAR AND BETWEEN(HJ_11,1,8);
HJ_16:=ISLASTBAR AND BETWEEN(HJ_11,10,12);
HJ_17:=ISLASTBAR AND BETWEEN(HJ_11,14,17);
HJ_18:=(BACKSET(HJ_12>0,9) OR BACKSET(HJ_13>0,13) OR BACKSET(HJ_14>0,18) OR BACKSET(HJ_15>0,HJ_11) OR BACKSET(HJ_16>0,HJ_11) OR BACKSET(HJ_17>0,HJ_11))*HJ_11;
DRAWTEXT(HJ_18>0 AND HJ_18<18,LOW*0.99,VAR2STR(HJ_18,0)),COLORMAGENTA;
DRAWTEXT(HJ_18>0 AND (HJ_11=9 OR HJ_11=13 OR HJ_11=18),LOW*0.99,VAR2STR(HJ_18,0)),COLORGREEN;

通达信18转笔主图指标公式

 

相关文章