在线检测未来函数

通达信笑脸趋势通道及选股指标公式

来源:Internet,编辑:股旁网,2019-02-21

A1A:=EMA(CLOSE,9);
A1B:=((A1A-EMA(CLOSE,5))<0);
A1C:=((A1A-EMA(CLOSE,5))>0);
A1D:=BARSLAST(A1B);
A1E:=BARSLAST(A1C);
A1F:=IF((A1E>0),(CLOSE-REF(CLOSE,1))/REF(CLOSE,1)*100,0);
A20:=SUM(A1F,0);
A21:=IF((A1D>0),(0-2),0);
A22:=IF((A1E>0),SUM((CLOSE-REF(CLOSE,1))/REF(CLOSE,1)*100,A1E),0);
A23:=A22/A1E;
A25:=EMA(EMA(EMA(CLOSE,3),2),3);
上升通道:((A25-REF(A25,1))+A25),COLORRED;
反转通道:MA(上升通道,15),COLORGREEN;
买入:((REF(A21,1)=(0-2)) AND (A21=0)),NODRAW;
卖出:COUNT(上升通道<REF(上升通道,2),2)=1 AND 上升通道>反转通道 AND C<O,NODRAW;
STICKLINE((上升通道>反转通道),反转通道,上升通道,1,0),COLORMAGENTA;
STICKLINE((反转通道>上升通道),上升通道,反转通道,1,0),COLORFF0000;
DRAWICON(买入,上升通道*1.01,5);
DRAWICON((卖出 OR ((REF(A1E,1)>0) AND (A1E=0))),上升通道*1.01,6);

{
选股公式:

A1A:=EMA(CLOSE,9);
A1B:=((A1A-EMA(CLOSE,5))<0);
A1D:=BARSLAST(A1B);
A21:=IF((A1D>0),(0-2),0);
(REF(A21,1)=(0-2)) AND (A21=0);
}

通达信笑脸趋势通道及选股指标公式

 

相关文章