载入中...
在线检测未来函数
载入中...

通达信KDJ主升指标公式

来源:Internet,编辑:股旁网,2019-08-06

月N:=DAY;
月HIGH:=IF(DAY=月N,HHV(H,30),0);
月LOW:=IF(DAY=月N,LLV(L,30),0);
月CLOSE:=IF(DAY=月N,CLOSE,0);
月RSV:=(月CLOSE-LLV(月LOW,72))/(HHV(月HIGH,72)-LLV(月LOW,72))*100;
月K:SMA(月RSV,3,1),COLORWHITE ;
月D:SMA(月K,3,1),COLORYELLOW ;
月J:=3*月K-2*月D ;
DRAWBAND(月K,RGB(255,0,0),月D,RGB(0,100,200));
周N:=WEEKDAY;
周HIGH:=IF(WEEKDAY=周N,HHV(H,4),0);
周LOW:=IF(WEEKDAY=周N,LLV(L,4),0);
周CLOSE:=IF(WEEKDAY=周N,CLOSE,0);
周RSV:=(周CLOSE-LLV(周LOW,45))/(HHV(周HIGH,45)-LLV(周LOW,45))*100;
周K:SMA(周RSV,3,1),COLORWHITE ;
周D:SMA(周K,3,1),COLORYELLOW ;
周J:=3*周K-2*周D,COLORFFFFFF ;
DRAWBAND(周K,RGB(255,200,70),周D,RGB(70,100,50));
D1:=1;
80,POINTDOT,COLORFF0000;
RSV:=(CLOSE-LLV(LOW,9))/(HHV(HIGH,9)-LLV(LOW,9))*100;
K:=SMA(RSV,3,1);
D:=SMA(K,3,1);
J:=3*K-2*D,COLORWHITE,DOTLINE;
MA250:=MA(C,250);
B:=C-MA250;
{XG:=月K>=80 AND 月D>=80 AND 周K>=80 AND 周D>=80 AND B>=0.05*C AND B<=0.15*C;
IF(XG,25,0),COLORGREEN;}
RSV275:=(CLOSE-LLV(LOW,275))/(HHV(HIGH,275)-LLV(LOW,275))*100;
K275:=SMA(RSV275,3,1),COLOR5E5E5E;
{IF( K275>=50 AND K275<=80,K275,DRAWNULL),COLORFFFFFF,LINETHICK2;
IF( K275>=80,K275,DRAWNULL),COLORFF00FF,LINETHICK3;}
D275:=SMA(K275,3,1),POINTDOT ;
J275:3*K275-2*D275,DOTLINE;
DRAWICON(CROSS(J275,50) AND ABS(B)<=0.2*C,50,1);
50,POINTDOT;
超级主升:IF(月K>=80 AND 月D>=80 AND 周K>=80 AND 周D>=80 AND J275>=80 ,45,DRAWNULL),COLORMAGENTA,LINETHICK3;
强势区域:IF(月K>=60 AND 月D>=60 AND 周K>=50 AND 周D>=50 AND J275>=50,35,DRAWNULL),COLOR0000FF,LINETHICK3;
{DRAWTEXT(月K>=80 AND 月D>=80 AND 周K>=80 AND 周D>=80 AND J275>=80 AND J275>周K,45,'超级主升');}
周DIFF:=(EMA(CLOSE,60)-EMA(CLOSE,130)),NODRAW;
周DEA:=EMA(周DIFF,25),NODRAW;
DIF:=EMA(CLOSE,12)-EMA(CLOSE,26),COLORWHITE;
DEA:=EMA(DIF,9),COLORYELLOW;
MACD:=(DIF-DEA)*2,COLORSTICK;
{金叉1:IF(CROSS(DIF,DEA) AND DEA>=0 AND 周DIFF>周DEA,20,0);
金叉2:IF(CROSS(DIF,DEA) AND DEA>=0 AND 周DIFF>周DEA AND 周DIFF>0,10,0);
金叉3:IF(CROSS(DIF,DEA) AND DEA>=0 AND 周DIFF>周DEA AND 周DIFF>0 AND 周DEA>0,6,0),COLORFFFF00;}
成本乖离1:=(LOW - COST(20))/COST(20)*100;
K11:=SMA(成本乖离1,3,1);
D11:=SMA(K11,3,1);
J11:=3*K11-2*D11;
{DRAWICON(CROSS(J11,16),25,1);}
成本乖离:IF(J11>=16,25,DRAWNULL),COLORE7E7E7,LINETHICK3;

通达信KDJ主升指标公式

 

通达信KDJ主升指标公式的选股公式如下:

相关文章