在线检测未来函数

通达信急跌后妖股突破主图指标公式

来源:Internet,编辑:股旁网,2020-01-17

MA5:MA(CLOSE,5);
MA10:MA(CLOSE,10);
MA20:MA(CLOSE,20);
MA30:MA(CLOSE,30);
MA54:=MA(CLOSE,54);
MA60:MA(CLOSE,60);
MA120:MA(CLOSE,120);
STICKLINE(C/REF(C,1)>=1.096 AND H=C,O,C,2,0),COLORYELLOW;
涨停:=IF((C-REF(C,1))*100/REF(C,1)>=9.90,1,0);
缩量涨停:=EVERY(涨停,2);
DRAWTEXT(缩量涨停,H*1.03,'缩量涨停'),COLORGREEN;
UU:=3;
A88:=SUM(C*V,UU);
B88:=SUM(V,UU);
市场价值线:MA(A88/B88,7)COLORYELLOW,LINETHICK3;
VAR41:=REF(CLOSE,1);
VAR42:=((SMA(MAX((CLOSE - VAR41),0),7,1) / SMA(ABS((CLOSE - VAR41)),7,1)) * 100);
VAR43:=((SMA(MAX((CLOSE - VAR41),0),13,1) / SMA(ABS((CLOSE - VAR41)),13,1)) * 100);
VAR44:=((BARSLAST((VAR43 < 23)) <= 3) AND CROSS(VAR42,VAR43));
VAR45:=((((CLOSE - MA(CLOSE,23)) / MA(CLOSE,20)) * 100) < -12.5);
VAR46:=LLV(LOW,5);
VAR47:=HHV(HIGH,10);
VAR48:=EMA((((CLOSE - VAR46) / (VAR47 - VAR46)) * 100),4);
VAR49:=EMA(((0.667 * REF(VAR48,1)) + (0.333 * VAR48)),2);
VAR50:=1011131;
VAR51:=(IF((DATE <= VAR50),VAR45,0) OR IF((DATE <= VAR50),VAR41,0));
DRAWTEXT((((0 - (-1 * VAR44)) AND VAR45) AND CROSS(VAR48,VAR49)) AND (VAR48 <=25),LOW*1.008,'急跌后超级大黑马'),COLORMAGENTA;
DRAWICON((((0 - (-1 * VAR44)) AND VAR45) AND CROSS(VAR48,VAR49)) AND (VAR48 <=25),L-0.10,26);
DRAWICON((((0 - (-1 * VAR44)) AND VAR45) AND CROSS(VAR48,VAR49)) AND (VAR48 <=25),L-0.38,26);
持股线1:MA(CLOSE,15),COLORMAGENTA,LINETHICK5;
HJ_8:=(REF(CLOSE,3)-CLOSE)/REF(CLOSE,3)*100>5;
HJ_9:=FILTER(HJ_8,10);
HJ_10:=BARSLAST(HJ_9);
HJ_11:=REF(HIGH,HJ_10+2);
HJ_12:=REF(HIGH,HJ_10+1);
HJ_13:=REF(HIGH,HJ_10);
HJ_14:=MAX(HJ_11,HJ_12);
HJ_15:=MAX(HJ_14,HJ_13);
HJ_16:=(CLOSE-REF(CLOSE,1))/REF(CLOSE,1)*100>5;
HJ_17:=HJ_10<150;
HJ_18:=(OPEN-HJ_15)/HJ_15*100<30;
HJ_19:=(CLOSE-LLV(LOW,HJ_10))/LLV(LOW,HJ_10)*100<50;
HJ_20:=(CLOSE-REF(OPEN,5))/REF(OPEN,5)*100<30;
HJ_21:=VOL/MA(VOL,5)<3.5;
HJ_22:=(CLOSE-REF(CLOSE,89))/REF(CLOSE,89)*100<80;
HJ_25:=HJ_16 AND HJ_17 AND HJ_18 AND HJ_19 AND HJ_20 AND HJ_21 AND HJ_22;
暴利:=FILTER(HJ_25,15);
PL1:=(((CLOSE-MA54)/MA54)<0.1);
PL2:=(((CLOSE-MA10)/MA10)<0.3);
偏离率:=(((PL1=1) AND (PL2=1))*0.2);
平台突破:=((((偏离率=0) AND (REF(偏离率,1)=0.2)) AND (REF((COUNT((偏离率=0.2),10)=10),1)=1))*-0.1);
妖股突破:=平台突破=-0.1;
XDF:=(暴利 OR 妖股突破);
VARA:=DMA(AMOUNT/VOL/100,VOL/CAPITAL);
VARAA:=DYNAINFO(7)/(REF(CLOSE,1))>1.05 AND (DYNAINFO(7)/O>1.05);
FLIGA:=(VOL/REF(VOL,1)>1.2 AND COUNT(CLOSE>OPEN,1)) OR (LOW>REF(HIGH,1) AND COUNT(OPEN>CLOSE,1) AND VOL/REF(VOL,1)>1.2);
妖股:=XDF AND C/REF(C,1)>1.095 AND FLIGA AND VARAA;
DRAWICON(妖股,H*1.0395,7);
DRAWTEXT(XDF AND C/REF(C,1)>1.095 AND FLIGA AND VARAA,L*0.975,' 妖股'),COLORYELLOW;
DRAWTEXT(XDF AND C/REF(C,1)>1.095 AND FLIGA AND VARAA,L*0.995,' 妖股'),COLORRED;

通达信急跌后妖股突破主图指标公式

 

相关文章