载入中...
在线检测未来函数
载入中...

通达信乾坤三线主图指标公式

来源:Internet,编辑:股旁网,2020-03-10

{使用说明:1.股价高于平均线,视为强势;股价低于平均线,视为弱势;2.平均线向上涨升,具有助涨力道;平均线向下跌降,具有助跌力道;3.二条以上平均线向上交叉时,买进;4.二条以上平均线向下交叉时,卖出;5.移动平均线的信号经常落后股价,若以EXPMA 、VMA 辅助,可

所属地区:DRAWTEXT_FIX(1,0.00,0.05,0,'地区:'),COLORFFFF00;
DRAWTEXT_FIX(1,0.05,0.05,0,DYBLOCK),COLORFFFF00;
所属行业:DRAWTEXT_FIX(1,0,0.10,0,'行业:'),COLORFFFF00;
DRAWTEXT_FIX(1,0.05,0.10,0,HYBLOCK),COLORFFFF00;
所属概念:DRAWTEXT_FIX(1,0,0.15,0,'概念:'),COLORFFFF00;
DRAWTEXT_FIX(1,0.05,0.15,0,GNBLOCK),COLORFFFF00;
所属风格:DRAWTEXT_FIX(1,0,0.20,0,'风格:'),COLORFFFF00;
DRAWTEXT_FIX(1,0.05,0.20,0,FGBLOCK),COLORFFFF00;
上市日期:=CONST(DAYTODATE((DATETODAY(DATE)-FINANCE(42))))+19000000,NODRAW;
DRAWTEXT_FIX(1,0,0.25,0,'上市日期:'),COLORFFFF00;
DRAWNUMBER_FIX(1,0.05,0.25,0,上市日期),COLORFFFF00;
A1:MA(CLOSE,5);
A2:MA(CLOSE,6);
A3:MA(CLOSE,7);
B1:EMA(MEMA(CLOSE,13),13),COLORGREEN;
B2:EMA(MEMA(CLOSE,14),14),COLORGREEN;
B3:EMA(MEMA(CLOSE,15),15),COLORF00FF0;
KY1:EMA(MEMA(CLOSE,80),80),COLORFF9900;
KY2:EMA(MEMA(CLOSE,84),84),COLORRED,LINETHICK3;
IF(KY2<REF(KY2,1),KY2,DRAWNULL),COLORGREEN,LINETHICK3;
KY3:EMA(MEMA(CLOSE,88),88),COLORF00FF0;
X_1:=IF(NAMELIKE(1) OR NAMELIKE(2),0.05,0.1);
X_2:=CLOSE/REF(CLOSE,1)-1>=X_1-0.01/REF(CLOSE,1) AND CLOSE=HIGH AND PERIOD=5;
STICKLINE(X_2,CLOSE,OPEN,(-1),0),COLORFF00F5;
X_3:=REF(CLOSE,1)/CLOSE-1>=X_1-0.01/REF(CLOSE,1) AND LOW=CLOSE AND PERIOD=5;
STICKLINE(X_3,CLOSE,OPEN,(-1),0),COLORGREEN;
X_4:=HIGH/REF(CLOSE,1)-1>=X_1-0.01/REF(CLOSE,1) AND CLOSE<HIGH AND PERIOD=5;
STICKLINE(X_4,HIGH-(HIGH-MAX(OPEN,CLOSE)),HIGH,0,0),COLORFF00B5;
X_5:=REF(CLOSE,1)/LOW-1>=X_1-0.01/REF(CLOSE,1) AND LOW<CLOSE AND PERIOD=5;
STICKLINE(X_5,LOW+(MIN(OPEN,CLOSE)-LOW),LOW,0,0),COLOR00BB00;
X_6:=OPEN/REF(CLOSE,1)-1>=X_1-0.01/REF(CLOSE,1) AND OPEN=HIGH AND PERIOD=5;
STICKLINE(X_6,CLOSE+(OPEN-CLOSE)*0.9,OPEN,(-1),0),COLORFF00F5;
X_7:=REF(CLOSE,1)/OPEN-1>=X_1-0.01/REF(CLOSE,1) AND LOW=OPEN AND PERIOD=5;
STICKLINE(X_7,CLOSE-(CLOSE-OPEN)*0.9,OPEN,(-1),0),COLORGREEN;
MA5:=MA(CLOSE,5);
MA10:=MA(CLOSE,10);
MA13:=MA(CLOSE,13);
MA20:=MA(CLOSE,20);
MA30:=MA(CLOSE,30);
MA54:=MA(CLOSE,54);
MA60:=MA(CLOSE,60),COLOR00FF99,LINETHICK2;
MA120:=MA(CLOSE,120);
HJ_8:=(REF(CLOSE,3)-CLOSE)/REF(CLOSE,3)*100>5;
HJ_9:=FILTER(HJ_8,10);
HJ_10:=BARSLAST(HJ_9);
HJ_11:=REF(HIGH,HJ_10+2);
HJ_12:=REF(HIGH,HJ_10+1);
HJ_13:=REF(HIGH,HJ_10);
HJ_14:=MAX(HJ_11,HJ_12);
HJ_15:=MAX(HJ_14,HJ_13);
HJ_16:=(CLOSE-REF(CLOSE,1))/REF(CLOSE,1)*100>5;
HJ_17:=HJ_10<150;
HJ_18:=(OPEN-HJ_15)/HJ_15*100<30;
HJ_19:=(CLOSE-LLV(LOW,HJ_10))/LLV(LOW,HJ_10)*100<50;
HJ_20:=(CLOSE-REF(OPEN,5))/REF(OPEN,5)*100<30;
HJ_21:=VOL/MA(VOL,5)<3.5;
HJ_22:=(CLOSE-REF(CLOSE,89))/REF(CLOSE,89)*100<80;
HJ_25:=HJ_16 AND HJ_17 AND HJ_18 AND HJ_19 AND HJ_20 AND HJ_21 AND HJ_22;
暴利:=FILTER(HJ_25,15);
PL1:=(((CLOSE-MA54)/MA54)<0.1);
PL2:=(((CLOSE-MA10)/MA10)<0.3);
偏离率:=(((PL1=1) AND (PL2=1))*0.2);
平台突破:=((((偏离率=0) AND (REF(偏离率,1)=0.2)) AND (REF((COUNT((偏离率=0.2),10)=10),1)=1))*-0.1);
妖股突破:=平台突破=-0.1;
XDF:=(暴利 OR 妖股突破);
VARA:=DMA(AMOUNT/VOL/100,VOL/CAPITAL);
VARAA:=DYNAINFO(7)/(REF(CLOSE,1))>1.05 AND (DYNAINFO(7)/O>1.05);
FLIGA:=(VOL/REF(VOL,1)>1.2 AND COUNT(CLOSE>OPEN,1)) OR (LOW>REF(HIGH,1) AND COUNT(OPEN>CLOSE,1) AND VOL/REF(VOL,1)>1.2);
妖股:=XDF AND C/REF(C,1)>1.095 AND FLIGA AND VARAA,NODRAW;
工作线:=MA("KDJ.J#WEEK"(9,3,3),5);
建仓:=CROSS(工作线,5),NODRAW,COLORMAGENTA;
加仓:=CROSS(工作线,50),NODRAW,COLORYELLOW;
VAR1:=工作线,COLORRED;
持股:=IF(VAR1>REF(VAR1,1),VAR1,DRAWNULL),COLORRED;
{股海必买}
ZZAA1:=C<O; {昨天收阴线的}
ZZAA2:=C>O AND C<REF(C,1);{假阴真阳的}
ZZBB1:=REF(ZZAA1,1) AND C>REF(O,1);
ZZBB2:=REF(ZZAA2,1) AND C>REF(C,1);
BM:=ZZBB1 OR ZZBB2;
T:=BARSLAST(妖股);
必买:=T>=1 AND T<=20 AND BM ;
TJ1:=C/REF(C,1)*100-100;
TJ2:=TJ1>6;
TJ3:=MAX(C,O)/MIN(C,O)*100-100;
TJ4:=TJ3<5;
TJ5:=BARSLASTCOUNT(TJ4);
TJ6:=TJ5>=2 AND TJ5<=4;
TJ7:=REF(TJ6,1) AND TJ2;
TJ8:=REF(TJ2,1) AND TJ4;
TJ9:=BARSLAST(TJ8);
TJ10:=TJ9<8;
AA:=C/REF(C,1)>1.095 AND H=O AND L=H;
上升三法:=REF(TJ6,1) AND TJ1>2 AND TJ10 AND NOT(AA);
XG:必买 AND 上升三法 AND 持股<100 AND 持股;
{倍量}
BL:=VOL>=REF(V,1)*1.91 AND C>REF(C,1)*1.01;
获利比例:WINNER(C)*100,NODRAW,COLORRED;
DRAWICON(XG,L*0.99,25);
DRAWTEXT(XG,L*0.97.5,'全仓'),COLORGREEN;
A:=AMOUNT/V/100;
VARAB:=EMA((((A-EMA(A,13))/EMA(A,13))*(0-100)),5);
QQ:=EMA(((VARAB/10)+EMA(A,13)),0);
行情线:=MA(A,1);
重心:=(C+0.618*REF(C,1)+0.382*REF(C,1)+0.236*REF(C,3)+0.146*REF(C,4))/2.382;
【操盘线】:EMA(((SLOPE(C,22)*20)+C),55),COLORYELLOW,LINETHICK4;
【黄金线】:IF(重心>=【操盘线】,【操盘线】,DRAWNULL),COLORRED,LINETHICK2;
空仓线】:IF(重心<【操盘线】,【操盘线】,DRAWNULL),COLORCYAN,LINETHICK2;
DRAWTEXT(ISLASTBAR,【操盘线】,'【操盘线】'),COLORRED;

通达信乾坤三线主图指标公式

 

通达信乾坤三线主图指标公式的选股公式如下:

http://www.gupang.com/202003/50571.html

http://www.gupang.com/202003/50572.html

http://www.gupang.com/202003/50573.html

相关文章