载入中...
在线检测未来函数
载入中...

通达信波段天机界点主图指标公式

来源:Internet,编辑:股旁网,2020-03-11

N:=12;
MA5:MA(C,5);
MA6:=MA(C,6);
MA10:MA(C,10);
MA20:MA(C,20);
买线:=EMA(C,2);
卖线:=EMA(SLOPE(C,21)*20+C,42);
A2:=REF(MA20,1);
J1:=(MA20-A2)/A2*100;
MJ1:=MA(J1,3);
MA30:MA(C,30);
MA55:MA(C,60);
MA120:MA(C,120);
BU:=CROSS(买线,卖线);
SEL:=CROSS(卖线,买线);
DRAWICON(BU,L-0.1,1);
DRAWICON(SEL,H+0.1,2);
乖离2:=(MA20-MA30)/MA30*100;
VAR1:=IF(BETWEEN(乖离2,-2,5),2,0);
MAX1:=MAX(MA20,MA30);
MAX2:=MAX(MAX1,MA55);
MIN7:=MIN(MA20,MA30);
MIN2:=MIN(MIN7,MA55);
K1:=(MAX2/MIN2-1)*100;
STICKLINE(买线>=卖线,LOW,HIGH,0.0,1),COLORRED;
STICKLINE(买线>=卖线,CLOSE,OPEN,2,1),COLORRED;
STICKLINE(买线<卖线,LOW,HIGH,0.0,1),COLORGREEN;
STICKLINE(买线<卖线,CLOSE,OPEN,2,1),COLORGREEN;
STICKLINE(BU,OPEN,CLOSE,2,0),COLORYELLOW;
STICKLINE(SEL,OPEN,CLOSE,2,0),COLORBLUE;
VAR2:=IF(K1<=8,1,0);
上火车轨:=MA20>MA30 AND MA20>REF(MA20,1) AND MA30>REF(MA30,1) AND MA20-MA30>REF((MA20-MA30),1);
STICKLINE(上火车轨,MA20,MA30,0,0),COLORRED;
主力:EMA(CLOSE,10),COLORRED;
散户:EMA(CLOSE,5),COLORWHITE;
神枪手:=DRAWTEXT(FILTER(上火车轨 AND "MACD.DIF"<0.15 AND "MACD.DIF">REF("MACD.DIF",
1) AND MA(V,60)>REF(MA(V,60),1) AND MA(V,5)>MA(V,10) AND J1>REF(J1,1) AND
( L<=MA20 AND C>MA20 OR (CROSS(MA5,MA20)) ),5),L*0.98,'←神枪手');
神枪手选股:=FILTER(上火车轨 AND "MACD.DIF"<0.15 AND "MACD.DIF">REF("MACD.DIF",
1) AND MA(V,60)>REF(MA(V,60),1) AND MA(V,5)>MA(V,10) AND J1>REF(J1,1) AND
( L<=MA20 AND C>MA20 OR (CROSS(MA5,MA20)) ),5);
绿降:(46.18*EMA(CLOSE,10)-31.82*EMA(CLOSE,4))/14.36,COLORGREEN,LINETHICK1;
操盘:MA(CLOSE,9),COLORCYAN,LINETHICK2;
界点:MA(CLOSE,20),COLORMAGENTA;
短线暴涨:DRAWTEXT(FILTER( (VAR1 OR VAR2) AND MA10>REF(MA10,1) AND COUNT(MA30>REF(MA30,
1),3)=3 AND MA30>MA55 AND COUNT(CROSS(MA5,MA30),3) AND J1>MJ1 AND MA(V,5)>MA(V,
60) AND MA(V,60)>REF(MA(V,60),1),5),MA55*0.99,'短线暴涨'),COLORRED;
DRAWTEXT(CROSS("KDJ.K"(5,2,3),"KDJ.D"(5,2,3)) AND "KDJ.D"(5,2,
3)<30 AND J1>MJ1 AND MA55>REF(MA55,1) AND COUNT(J1<1,3)>=1,L*0.995,'←买入'),COLORYELLOW;
DRAWTEXT(CROSS("KDJ.D"(5,2,3),"KDJ.K"(5,2,3)) AND "KDJ.D"(5,2,
3)>65 AND J1<MJ1 AND COUNT(J1>1,3)>=1,H*1.005,'←卖出'),COLORGREEN;
DRAWTEXT(CROSS("KDJ.D"(18,9,6),"KDJ.K"(18,9,6)) AND "KDJ.D"(18,9,
6)>60 AND "KDJ.J"(45,15,15)>90,H*1.03,'←顶'),COLORRED;
DRAWTEXT(CROSS(MA5,MA6) AND "KDJ.K"(5,3,3)>=50 AND "KDJ.J"(5,
3,3)<31 ,L*0.92,'←再买'),COLORMAGENTA;
LC:=REF(CLOSE,1);
RSI:=((SMA(MAX((CLOSE - LC),0),3,1) / SMA(ABS((CLOSE - LC)),3,1)) * 100);
FF:=EMA(CLOSE,3);
MA15:=EMA(CLOSE,21);
XL1:=((LLV(LOW,3) = LLV(LOW,60)) AND ((CLOSE / REF(CLOSE,1)) >= 1.04));
XL2:=(((CLOSE - EMA(CLOSE,21)) / EMA(CLOSE,21)) * 100);
XL3:=CROSS(XL2,(0 - 20));
DRAWTEXT(CROSS(FF,MA15),(LOW * 0.99),'底背离'),COLOR0000FF;
AA:=(HHV(HIGH,20) - (2 * ATR));
BB:=CROSS(CLOSE,REF(HHV(HIGH,55),1));
SSS:=CROSS(MIN(MA(CLOSE,13),AA),CLOSE);
BBB:=BARSLAST(BB);
SSSB:=BARSLAST(SSS);
DRAWTEXT(FILTER(((XL1 > 0) AND LOW),5),(LOW - 0.4),'买点');
DRAWTEXT((XL3 > 0),(LOW - 0.2),'绝对底部');
B1:=((BBB = 0) AND (REF(SSSB,1) < REF(BBB,1)));
B1B:=BARSLAST(B1);
B2:=((((BB = 1) AND (B1B < SSSB)) AND (B1B > 0)) AND (COUNT(BB,SSSB) < 3));
B2B:=BARSLAST(B2);
B3:=((((BB = 1) AND (B2B < B1B)) AND (COUNT(BB,SSSB) < 4)) AND (COUNT(BB,SSSB) > 2));
X6:=REF(CLOSE,1);
X7:=((SMA(MAX((CLOSE - X6),0),7,1) / SMA(ABS((CLOSE - X6)),7,1)) * 100);
X8:=CROSS(79,X7);
X9:=FILTER(X8,4);
DRAWTEXT((B1 = 1),(LOW - 0.6),'跟进'),COLORYELLOW;
DRAWTEXT((B2 = 1),(LOW - 0.6),'加码'),COLORFFAAFF;
WWWGUPANGCOM:=(C-EMA(C,21))/EMA(C,21)*100;
DRAWTEXT(X9,(HIGH * 1.02),'出货'),COLOR9000F5;
STICKLINE(C>1.098*REF(C,1),C,O,0,0),COLORYELLOW;

通达信波段天机界点主图指标公式

 

通达信波段天机界点主图指标公式的选股公式如下:

http://www.gupang.com/202003/50594.html

http://www.gupang.com/202003/50595.html

http://www.gupang.com/202003/50596.html

http://www.gupang.com/202003/50597.html

http://www.gupang.com/202003/50598.html

http://www.gupang.com/202003/50599.html

http://www.gupang.com/202003/50600.html

http://www.gupang.com/202003/50601.html

http://www.gupang.com/202003/50602.html

相关文章