载入中...
在线检测未来函数
载入中...

通达信分时轨道主图指标公式

来源:Internet,编辑:股旁网,2020-03-23

均价:=SUM(V*C,0)/SUM(V,0);
顶价:=EMA(均价,50)/0.97;
中间:=(均价+顶价)/2;
DRAWBAND(顶价,RGB(100,30,0),中间,0);
DRAWBAND(中间,RGB(0,100,50),均价,0);
上轨:顶价,COLORGREEN,LINETHICK4;IF(顶价>REF(顶价,1),顶价,DRAWNULL),COLORRED,LINETHICK4;
中轨:中间,COLORYELLOW,LINETHICK4;
下轨:均价,COLORBLUE,LINETHICK4;
现价:C,COLORWHITE,LINETHICK3;
C1:=CONST(REF(C,480));
G1:=CONST(HHV(H,480));
M1:=CONST(LLV(L,480));
MA30:=EMA(CLOSE,30);
FSQR:=EMA(CLOSE,900);
H1:=MAX(C1,G1);
L1:=MIN(C1,M1);
P1:=H1-L1;
阻力:=L1+P1*7/8,COLORCYAN,LINETHICK2;
支撑:=L1+P1*0.5/8,COLORMAGENTA,LINETHICK2;
DRAWICON(LONGCROSS(支撑,CLOSE,2),CLOSE*0.995,5);
DRAWICON(LONGCROSS(CLOSE,阻力,2),CLOSE*1.005,19);
TT:=BARSCOUNT(C);
突破:=CROSS(C,REF(HHV(H,TT),1)) AND C/均价<1.09 AND TT>=1 AND TT<240;
扫盘:=COUNT(突破,13)>=3 AND CROSS(C,REF(HHV(H,TT),1));
全仓:=CROSS(C,REF(HHV(H,TT),1)) AND HHVBARS(VOL,TT)=0 AND C/均价<1.09 AND TT>1 AND TT<240 AND BARSLAST(扫盘)>=21;
DRAWTEXT(突破,下轨*0.99,'←突'),COLORRED;
DRAWTEXT(扫盘,下轨*0.99,'←扫'),COLORYELLOW;
DRAWTEXT(全仓,下轨*0.99,'←仓'),COLORBLUE;
VAR1:=EMA(EMA(C,13),13);
控盘:=(VAR1-REF(VAR1,1))/REF(VAR1,1)*1000;
JJ:=DYNAINFO(11);
能量:=(EMA(C,8)-EMA(C,55))*10;
空头:=EMA(能量,3);
BTJ11:=(C-JJ)/JJ<-0.03;
BTJ2:=控盘>REF(控盘,1) AND 控盘<-0.2;
BTJ3:=CROSS(能量,空头) AND 能量<-0.3;
BTJ811:=FILTER(BTJ11 AND BTJ2 AND BTJ3,13);
DRAWTEXT(BTJ811,C*0.999,'←庄'),COLORMAGENTA;
{分时独醉}
幅度:=DYNAINFO(14);
AX1:=IF(幅度>0,0.76,0.04);
BX1:=IF(幅度>0,0.86,0.12);
CX1:=IF(幅度>0,0.96,0.20);
A1:=(VOL/C)/2;
A2:=SUM(IF(A1>100 AND CLOSE>REF(C,1),A1,0),0);
A3:=SUM(IF(A1>100 AND CLOSE<REF(C,1),A1,0),0);
A4:=SUM(IF(A1<100 AND CLOSE>REF(C,1),A1,0),0);
A5:=SUM(IF(A1<100 AND CLOSE<REF(C,1),A1,0),0);
A6:=A2+A3+A4+A5;
AAA1:=STRCAT(STRCAT('机构买',CON2STR((100*A2)/A6,0)),'%');
AAA2:=STRCAT(STRCAT('机构卖',CON2STR((100*A3)/A6,0)),'%');
AAA3:=STRCAT(STRCAT('净买入',CON2STR((100*(A2-A3))/A6,0)),'%');
DRAWTEXT_FIX(C>0,0,AX1,0,AAA1),COLORRED;
DRAWTEXT_FIX(C>0,0,BX1,0,AAA2),COLORGREEN;
DRAWTEXT_FIX(C>0,0,CX1,0,AAA3),COLORYELLOW;
均:=MA(C,BARSCOUNT(C));
均价2:=SUM(C*V,240)/SUM(V,240);
涨幅:=C/REF(C,1)>1.02;
跌幅:=C/REF(C,1)<0.98;
横盘:=((HHV(C,BARSCOUNT(C))-LLV(C,BARSCOUNT(C)))/C)<0.05;
YY:=SMA(VOL,30,1);
放量:=(YY-LLV(LLV(YY,1),30))/(HHV(HHV(YY,1),30)-LLV(LLV(YY,1),30))>0.95;
涨跌幅:=涨幅 OR 跌幅;
横涨:=涨跌幅=0 AND 横盘 AND 放量 AND CROSS(均价2,均);
DRAWTEXT(FILTER(横涨,10),均价,'--突破'),COLORCYAN;
DRAWICON(FILTER(横涨,10),均价,1);

通达信分时轨道主图指标公式

 

通达信分时轨道主图指标公式的选股公式如下:

相关文章