载入中...
在线检测未来函数
载入中...

通达信五分钟分时主图指标公式

来源:Internet,编辑:股旁网,2020-04-24

T31:=BARSLAST(TIME2=093100);
T40:=BARSLAST(TIME2=093500);
T41:=BARSLAST(TIME2=093600);
T50:=BARSLAST(TIME2=094000);
T51:=BARSLAST(TIME2=094100);
T60:=BARSLAST(TIME2=094500);
C31:=REF(C,T40);
O31:=REF(C,T31);
C40:=REF(C,T50);
O40:=REF(C,T41);
C50:=REF(C,T60);
O50:=REF(C,T51);
A1:=C31>O31 AND C40>O40 AND C50>O50 AND O40>=C31 AND O50>=C40;
A2:=C31<O31 AND C40<O40 AND C50<O50 AND O40<=C31 AND O50<=C40;
A3:=C31>O31 AND C40>O40 AND C50<O50 AND C50<C40 AND O50/C50<C40/O40 AND O50/C50<C31/O31;
A4:=C31>O31 AND C40<O40 AND C50<O50 AND C40<C31 AND C50<C40 AND C31/O31<O40/C40 AND C31/O31<O50/C50;
A5:=C31<O31 AND C40<O40 AND C50>O50 AND C40<C31 AND O50>=C40;
A6:=C31<O31 AND C40>O40 AND C50>O50 AND C40>C31 AND C50>C40 AND O31/C31<C40/O40 AND O31/C31<C50/O50;
A7:=C31>O31 AND C40<O40 AND C50>O50 AND C31/O31>O40/C40 AND C50/O50>O40/C40;
A8:=C31<O31 AND C40>O40 AND C50<O50 AND C40/O40<O31/C31 AND C40/O40<O50/C50;
A9:=MAX(C31,O31)>=MAX(C40,O40) AND MAX(C31,O31)>=MAX(C50,O50);
A10:=MIN(C31,O31)<=MIN(C40,O40) AND MIN(C31,O31)<=MIN(C50,O50);
B1:='连续三上、三阳开泰、飚涨走势可能涨停、量大出货否则守仓、大阳、盯量';
B2:='连续三下、三只乌鸦、重挫走势可能跌停、只要反弹立即出货、大阴、随逃';
B3:='二上一下、二阳一小阴、震荡走势后势看好、逢高减磅逢低吸纳、中阳、阴须小';
B4:='一上二下、二只乌鸦、拉高出货后市看坏、逢高减磅后市下跌、中阴、阳线小';
B5:='二下一上、二阴一阳、急跌控底后市不明、逢高减磅观望为主、下影阴、阳大小';
B6:='一下二上、一阴二阳、震荡控底后市趋好、观望为主谨慎吸纳、下影阳、阴大小';
B7:='一上一下、二阳夹一阴、震荡走市后市看好、持股待涨逢低吸纳、中阳、阴须小再一上';
B8:='一下一上、二阴夹一阳、跌幅较大尾市杀跌、只要反弹立即出货、中阴、阳须小再一下';
B9:='三不创新高、可小阴小阳、三次不过短时顶部、层层阻力离场观望、上影阴阳、小K线';
B10:='三不创新低、可小阴小阳、三次不破短时底部、走势不强逢低少吸、下影阴阳、小K线';
DRAWTEXT_FIX( A1,0.005,0.005,0,B1),COLORRED;
DRAWTEXT_FIX( A2,0.005,0.005,0,B2),COLORGREEN;
DRAWTEXT_FIX( A3,0.005,0.005,0,B3),COLORMAGENTA;
DRAWTEXT_FIX( A4,0.005,0.005,0,B4),COLORCYAN;
DRAWTEXT_FIX( A5,0.005,0.005,0,B5),COLORBROWN;
DRAWTEXT_FIX( A6,0.005,0.005,0,B6),COLORBLUE;
DRAWTEXT_FIX( A7,0.005,0.005,0,B7),COLORYELLOW;
DRAWTEXT_FIX( A8,0.005,0.005,0,B8),COLORLIGREEN;
DRAWTEXT_FIX( A9,0.005,0.05,0,B9),COLORWHITE;
DRAWTEXT_FIX( A10,0.005,0.1,0,B10),COLORLIMAGENTA;
IF(BETWEEN(T40,0,4) AND C31>=O31,C31,DRAWNULL)COLORRED;
IF(BETWEEN(T40,0,4) AND C31<O31,C31,DRAWNULL)COLORCYAN;
IF(BETWEEN(T40,0,4) AND C31>=O31,O31,DRAWNULL)COLORRED;
IF(BETWEEN(T40,0,4) AND C31<O31,O31,DRAWNULL)COLORCYAN;
STICKLINE((T40=0 OR T40=4) AND C31>=O31,O31,C31,0,0)COLORRED;
STICKLINE((T40=0 OR T40=4) AND C31<O31,O31,C31,0,0)COLORCYAN;
IF(BETWEEN(T50,0,4) AND C40>=O40,C40,DRAWNULL)COLORRED;
IF(BETWEEN(T50,0,4) AND C40<O40,C40,DRAWNULL)COLORCYAN;
IF(BETWEEN(T50,0,4) AND C40>=O40,O40,DRAWNULL)COLORRED;
IF(BETWEEN(T50,0,4) AND C40<O40,O40,DRAWNULL)COLORCYAN;
STICKLINE((T50=0 OR T50=4) AND C40>=O40,O40,C40,0,0)COLORRED;
STICKLINE((T50=0 OR T50=4) AND C40<O40,O40,C40,0,0)COLORCYAN;
IF(BETWEEN(T60,0,4) AND C50>=O50,C50,DRAWNULL)COLORRED;
IF(BETWEEN(T60,0,4) AND C50<O50,C50,DRAWNULL)COLORCYAN;
IF(BETWEEN(T60,0,4) AND C50>=O50,O50,DRAWNULL)COLORRED;
IF(BETWEEN(T60,0,4) AND C50<O50,O50,DRAWNULL)COLORCYAN;
STICKLINE((T60=0 OR T60=4) AND C50>=O50,O50,C50,0,0)COLORRED;
STICKLINE((T60=0 OR T60=4) AND C50<O50,O50,C50,0,0)COLORCYAN;

通达信五分钟分时主图指标公式

 

通达信五分钟分时主图指标公式的选股公式如下:

相关文章