在线检测未来函数

通达信分时突破抓涨停主图指标公式

来源:Internet,编辑:股旁网,2020-07-20

{分时突破}
{MACD}
现价:C,COLORWHITE,LINETHICK2;
均价11:SUM(C*V,240)/SUM(V,240),COLORRED,LINETHICK2;
TT:=BARSCOUNT(C);
前高:=REF(HHV(H,TT),1);
突破:=CROSS(C,REF(HHV(H,TT),1)){ AND HHVBARS(VOL,TT)=0} AND C/均价11<1.09 AND TT>1 AND TT<240;
主力扫盘:=COUNT(突破,13)>=3 AND CROSS(C,REF(HHV(H,TT),1)){ AND HHVBARS(VOL,TT)=0};
DRAWTEXT(主力扫盘,前高, '←扫盘'),COLORYELLOW;
已主力扫盘:=BARSLAST(主力扫盘)<13;
全仓买进:=CROSS(C,REF(HHV(H,TT),1)) AND HHVBARS(VOL,TT)=0 AND C/均价11<1.09 AND TT>1 AND TT<240 AND BARSLAST(主力扫盘)>=20;
DRAWTEXT(全仓买进 ,前高, '←全仓'),COLORCYAN;
HJ_2:=DYNAINFO(4)>0 AND HHV(HIGH,2)/LLV(LOW,2)<1.25 AND REF(CLOSE,1)<LLV(LOW,3)+(HHV(HIGH,3)-LLV(LOW,3))*0.85;
HJ_9:=EMA(CLOSE,2);
HJ_10:=EMA(CLOSE,3);
HJ_11:=MAX(HJ_9,HJ_10);
X2:=CLOSE>HJ_11 AND HJ_2 AND (CLOSE>REF(HHV(HIGH,2),1) AND (CLOSE-REF(CLOSE,1))/REF(CLOSE,1)>0.015) AND (V/CAPITAL<=0.2) AND C/REF(C,1)<1.07;
{牛熊线}
NX:=MA(((SLOPE(C,20)*5)+C),10);
{中枢}
B1:=HOUR=09 AND MINUTE=45;
B20:=LLV(L,15);
B30:=BARSLAST(B1);
B4:=REF(B20,B30);
B5:CONST(B4),COLORFF80FF,CIRCLEDOT,LINETHICK2;
DRAWTEXT(CURRBARSCOUNT=20,B4,'分时支撑'),COLORYELLOW;
C1:=HOUR=09 AND MINUTE=45;
C2:=HHV(H,15);
C3:=BARSLAST(C1);
C4:=REF(C2,C3);
C5:CONST(C4),COLORFF80FF,CIRCLEDOT,LINETHICK2;
DRAWTEXT(CURRBARSCOUNT=20,C4,'分时突破'),COLORRED;
{DRAWBAND(C5,RGB(204,204,204),B5,RGB(204,204,204));}
{MACD}
DIF:=EMA(CLOSE,12)-EMA(CLOSE,26);
DEA:=EMA(DIF,9);
MACD10:=(DIF-DEA)*2;
AA0:=MACD10>00 AND DIF>0 AND DEA>0;
{捉牛信号}
A100:=HOUR=10 AND MINUTE=0;
A20:=HHV(H,30);
A30:=BARSLAST(A100);
A40:=REF(A20,A30);
A50:=CONST(A40);
A80:=CLOSE>A50 AND REF(C<=A50,1) AND CLOSE>NX;
AB:=FILTER(A80,100);
A90:=DYNAINFO(3);
AC:=CLOSE<=A90*1.04 AND CLOSE>A90;
量比:=V/REF(MA(V,5),1);
XG:=AA0 AND AB AND AC AND A40>A90 AND 量比>=1;
DRAWICON(XG,A50,23);
DRAWTEXT(FILTER(CROSS(C,REF(XG,1)),10) AND C>REF(XG,1),C*0.995,'突'),COLORYELLOW;
HJ_4:=CLOSE;
HJ_5:=(CLOSE-REF(CLOSE,5))/REF(CLOSE,5);
BAB1:=STICKLINE(HJ_5>0,DYNAINFO(3),DYNAINFO(3)*(1+HJ_5),0.1,0);
BAB2:=STICKLINE(HJ_5<0,DYNAINFO(3),DYNAINFO(3)*(1+HJ_5),0.1,0);
HJ_6:=CLOSE/DYNAINFO(3);
HJ_7:=FILTER(HJ_5>0.015 AND HJ_5>REF(HJ_5,1)*2 AND VOL>REF(VOL,1)*2 AND CLOSE>REF(CLOSE,1) OR HJ_5>0.025,240);
DRAWICON(HJ_7 AND HJ_6<1.06 AND CLOSE>DYNAINFO(3),C,23);{东风小图标}
DRAWICON(HJ_7 AND HJ_6<1.06 AND CLOSE>DYNAINFO(3),C,1);
DRAWTEXT(HJ_7 AND HJ_6<1.06 AND CLOSE>DYNAINFO(3),C,' 牛股启动')COLORGREEN;
H1:=MAX(DYNAINFO(3),DYNAINFO(5));
L1:=MIN(DYNAINFO(3),DYNAINFO(6));
P1:=H1-L1;
阻力:L1+P1*8/9,COLORLIRED,DOTLINE;
支撑:L1+P1*0.5/9,COLORGREEN,DOTLINE;
DRAWTEXT(LONGCROSS(支撑,C,2),C-0.01,' 买入'),COLOR0000FF;
WA1:=V*C/100;
WA2:=SUM((IF(((WA1/8>20) AND (CLOSE>(REF(CLOSE,1)))),WA1,0)),0);
WA3:=SUM((IF(((WA1/8>20) AND (CLOSE<(REF(CLOSE,1)))),WA1,0)),0);
WA4:=SUM((IF(((WA1/8<20) AND (CLOSE>(REF(CLOSE,1)))),WA1,0)),0);
WA5:=SUM((IF(((WA1/8<20) AND (CLOSE<(REF(CLOSE,1)))),WA1,0)),0);
机构买盘:=(WA2);
机构卖盘:=(WA3);
散户买盘:=(WA4);
散户卖盘:=(WA5);
DRAWTEXT_FIX(1,0.752,1-0.088,0,STRCAT(STRCAT('【机构买盘】',CON2STR(机构买盘,2)),' 万')),COLORRED;
DRAWTEXT_FIX(1,0.883,1-0.088,0,STRCAT(STRCAT('【机构卖盘】',CON2STR(机构卖盘,2)),' 万')),COLORGREEN;

通达信分时突破抓涨停主图指标公式

 

相关文章