在线检测未来函数

通达信超牛启程指标公式

来源:Internet,编辑:股旁网,2020-09-16

X_1:=REF(CLOSE,1)*1.1-CLOSE<0.01 AND HIGH=CLOSE;
X_2:=5;
X_3:=3;
X_4:=(EMA(CLOSE,5)*7+EMA(CLOSE,10)*3)/10;
X_5:=IF(YEAR>=2025,0,1);
X_6:=EMA(EMA(LOW,21)+6.8*STD(LOW,2),55);
X_7:=EMA(CLOSE/X_6*(1.88*CLOSE+LOW+OPEN)/2.75,3);
X_8:=(X_7-X_6)/X_6/2;
X_9:=EMA(X_7-X_8*X_7,5)*X_5;
X_10:=EMA(CLOSE,34)-3*STD(CLOSE,34);
X_11:=IF(X_4>X_9,X_4,X_9)*X_5;
X_12:=IF(X_9<X_4 AND X_9<CLOSE*0.15,EMA(CLOSE,34)-3*STD(CLOSE,34),X_9);
X_13:=BARSLASTCOUNT(X_11>X_12)=1;
X_14:=3*SMA((CLOSE-LLV(LOW,27))/(HHV(HIGH,27)-LLV(LOW,27))*100,5,1)-2*SMA(SMA((CLOSE-LLV(LOW,27))/(HHV(HIGH,27)-LLV(LOW,27))*100,5,1),3,1);
X_15:=(X_14-LLV(X_14,27))/(HHV(X_14,27)-LLV(X_14,27))*4*25;{股旁网 WWW.GUPANG.COM}
X_16:=(CLOSE-LLV(LOW,15))/(HHV(HIGH,15)-LLV(LOW,15))*100;
X_17:=SMA(X_16,10,1);
X_18:=SMA(X_17,5,1);
X_19:=INTPART(X_17);
X_20:=INTPART(X_18);
X_21:=X_19+X_20;
X_22:=MOD(X_21,10);
X_23:=(X_21-REF(X_21,1))*10;
X_24:=X_21+X_23;
X_25:=EMA(WINNER(CLOSE)*70,3);
X_26:=EMA((WINNER(CLOSE*1.1)-WINNER(CLOSE*0.9))*80,3);
X_27:=X_25/(X_25+X_26)*100;
X_28:=EMA(WINNER(CLOSE)*40,3);
X_29:=EMA((WINNER(CLOSE*1.1)-WINNER(CLOSE*0.9))*80,3);
X_30:=X_29/(X_28+X_29)*100;
X_31:=X_28/(X_28+X_29)*100;
X_32:=EMA(X_30,55);
X_33:=EMA(X_31,55);
X_34:=HHV((HIGH+LOW)/2,120);
X_35:=EMA((EMA(CLOSE,4)+EMA(CLOSE,6)+EMA(CLOSE,12)+EMA(CLOSE,24))/4,2);
X_36:=MA(CLOSE,27);
X_37:=VOL/FINANCE(7)*100;
X_38:=TMA(X_37,1-X_37,1);
X_39:=DMA((CLOSE+OPEN)/2,X_37/TMA(X_37,1-X_37,1));
X_40:=BARSLAST(CLOSE>X_39*POW(1.1,0.9));
X_41:=BARSLAST(CLOSE<X_39*POW(1.1,(-0.9)));
X_42:=CROSS(X_40,X_41) OR CROSS(X_41,X_40) OR BARSSINCE(X_40+1)=0 OR BARSSINCE(X_41+1)=0 OR BARSCOUNT(CLOSE)=0;
X_43:=REF(X_39,BARSLAST(X_42));
X_44:=LN(CLOSE/X_43)/LN(1.1)*10;
X_45:=VOL/CAPITAL*100;
X_46:=WINNER(CLOSE/1.1)*100;
X_47:=WINNER(CLOSE/1.2)*100;
X_48:=WINNER(CLOSE/1.25)*100;
X_49:=EMA(EMA(CLOSE,1),5);
X_50:=EMA(HHV(X_49,5),1);
X_51:=EMA(HHV(X_50,21),1);
X_52:=EMA(HHV(X_51,21),2);
X_53:=EMA(HHV(X_52,21),3);
X_54:=EMA(HHV(X_53,21),4);
X_55:=EMA(HHV(X_54,21),5);
X_56:=CLOSE;
X_57:=(3*HIGH+LOW+OPEN+2*CLOSE)/7;
X_58:=IF(CLOSE>200,CLOSE,DMA(X_57,VOL/CAPITAL))*1.1;
X_59:=EMA(HHV(X_55,21),6);
X_60:=IF(CLOSE>REF(CLOSE,1),VOL,-VOL);
X_61:=SUM(IF(CLOSE=REF(CLOSE,1),0,X_60),0);
X_62:=(HHV(HIGH,36)-CLOSE)/(HHV(HIGH,36)-LLV(LOW,36))*100;
X_63:=SMA(X_62,3,1);
X_64:=(CLOSE-LLV(LOW,9))/(HHV(HIGH,9)-LLV(LOW,9))*100;
X_65:=SMA(X_64,5,1)-8;
X_66:=X_65-X_63;
X_67:=(HIGH+OPEN+LOW+3*CLOSE)/6;
X_68:=EMA(100-100/(1+SUM(IF(X_67>REF(X_67,1),X_67*VOL,0),14)/SUM(IF(X_67<REF(X_67,1),X_67*VOL,0),14)),5);
X_69:=CROSS(X_56,X_59);
X_70:=2*CLOSE+OPEN+HIGH+LOW;
X_71:=(X_70/EMA(X_70,4)-1)*100;
X_72:=X_71*5;
X_73:=X_23;
X_74:=ATAN((X_68/REF(X_68,1)-1)*100)*180/3.1416;
X_75:=ATAN((X_72/REF(X_72,1)-1)*100)*180/3.1416;
X_76:=(X_72-REF(X_72,1))*100/REF(X_72,1);
X_77:=(CLOSE-REF(CLOSE,1))*100/REF(CLOSE,1);
X_78:=SUM((CLOSE-REF(CLOSE,1))/REF(CLOSE,1)*100,15);
X_79:=DYNAINFO(4)=0;
X_80:=IF(X_35>X_36 AND X_29<X_28 AND (X_15>50 OR X_15>REF(X_15,1)),(-40),0);
X_81:=IF(COUNT(X_69,20) AND X_28>X_29 AND X_31>X_33 AND X_48>30 AND X_15>X_31 AND X_15>60 AND X_77>=0.5 AND MAX(CLOSE,X_35) AND COUNT(CLOSE>X_35,10),18,0);
X_82:=IF(X_81>10 AND X_77>=0.5 AND X_80=(-40),88,0);
X_83:=MA(100*(CLOSE-LLV(CLOSE,34))/(HHV(HIGH,34)-LLV(LOW,34)),5)-20;
X_84:=EMA((CLOSE-REF(CLOSE,21))/REF(CLOSE,21)*100,4)*2;
X_85:=MA(CLOSE,1);
X_86:=SMA(SMA(SMA(X_85,2,1),2,1),2,1);
X_87:=HHV(MA(X_86,1),13);
X_88:=IF(X_44>0 AND X_44<150 AND X_15>50 AND CLOSE>X_58 AND X_56>X_59 AND X_45<20 AND X_76>10 AND X_74>2 AND X_28>X_29,208,0);
X_89:=3*SMA((CLOSE-LLV(LOW,480))/(HHV(HIGH,480)-LLV(LOW,480))*100,5,1)-2*SMA(SMA((CLOSE-LLV(LOW,480))/(HHV(HIGH,480)-LLV(LOW,480))*100,180,1),15,1);
X_90:=EMA(X_89,5);
X_91:=X_90-100;
X_92:=EMA(CLOSE,5);
X_93:=(EMA(CLOSE,1)+EMA(CLOSE,5)+EMA(CLOSE,10)+EMA(CLOSE,15)+EMA(CLOSE,20)+EMA(CLOSE,25)+EMA(CLOSE,30)+EMA(CLOSE,35)+EMA(CLOSE,40)+EMA(CLOSE,45)+EMA(CLOSE,50)+EMA(CLOSE,55)+EMA(CLOSE,60)+EMA(CLOSE,65)+EMA(CLOSE,70)+EMA(CLOSE,75)+EMA(CLOSE,80)+EMA(CLOSE,85)+EMA(CLOSE,90)+EMA(CLOSE,95)+EMA(CLOSE,100)+EMA(CLOSE,105)+EMA(CLOSE,110)+EMA(CLOSE,115)+EMA(CLOSE,120)+EMA(CLOSE,125)+EMA(CLOSE,130)+EMA(CLOSE,135)+EMA(CLOSE,140)+EMA(CLOSE,150))/30;
X_94:=X_92/X_93*100;
X_95:=X_94-110;
X_96:=(HIGH+LOW+2*CLOSE)/4;
X_97:=(X_96-REF(X_96,3))/3+X_96;
X_98:=EMA(X_97,7);
X_99:=EMA(HHV(X_97,20),60);
X_100:=EMA(COST(80),30);
X_101:=EMA(1.4*EMA(FORCAST(X_97,20),40),20);
X_102:=(X_99+X_100+X_101)/3;
X_103:=EMA(EMA(CLOSE*1.38,50),50);
X_104:=SMA(HIGH,21,2)*1.05;
X_105:=SMA(LOW,21,2)*0.95;
X_106:=(X_104+X_105)/2;
X_107:=X_106+2*STD(X_106,20);
X_108:=REF(X_107,0);
X_109:=ABS((2*CLOSE+HIGH+LOW)/4-MA(X_97,20))/MA(X_97,20);
X_110:=DMA(CLOSE,X_109);
X_111:=(1+9/100)*X_110;
X_112:=(1-7/100)*X_110;
X_113:=(REF((X_102+X_103+EMA(X_107*1.04,40)+X_111)/4,10)+MA(CLOSE,20)*1.04)/2;
X_114:=HIGH*VOL;
X_115:=EMA((EXPMA(X_114,180)/EXPMA(VOL,180)+EXPMA(X_114,360)/EXPMA(VOL,360)+EXPMA(X_114,720)/EXPMA(VOL,720)+EXPMA(X_114,1440)/EXPMA(VOL,1440))/4,34);
X_116:=1.06*X_115;
X_117:=X_115*0.94;
X_118:=EMA((EXPMA(X_114,27)/EXPMA(VOL,27)+EXPMA(X_114,54)/EXPMA(VOL,54)+EXPMA(X_114,108)/EXPMA(VOL,108)+EXPMA(X_114,316)/EXPMA(VOL,316))/4,34);
X_119:=1.06*X_118;
X_120:=X_118*0.94;
X_121:=EMA((EXPMA(X_114,5)/EXPMA(VOL,5)+EXPMA(X_114,10)/EXPMA(VOL,10)+EXPMA(X_114,20)/EXPMA(VOL,20)+EXPMA(X_114,40)/EXPMA(VOL,40))/4,34);
X_122:=1.06*X_121;
X_123:=X_121*0.94;
X_124:=(X_116+X_122+X_119)/3*1.05;
X_125:=(X_98*2/(X_113+X_124)-1)*100;
X_126:=MA(COST(80),20);
X_127:=(X_98/X_126-1)*100;
X_128:=(HHV(HIGH,42)-LLV(LOW,42))/2+LLV(LOW,42);
X_129:=ABS(HHV(HIGH,40)-LLV(LOW,40)-LLV(LOW,40))+X_128*0.5;
X_130:=(X_128/X_129-1)*100;
X_131:=EMA(EMA(CLOSE*1.14,55),20);
X_132:=(X_98/X_131-1)*100;
X_133:=(EMA(HHV(HIGH,60),60)+EMA(X_128,453)*1.62)/2;
X_134:=(X_98/X_133-1)*100;
X_135:=(X_91+X_95+X_125+X_127+X_130+X_132+X_134)/2;
X_136:=DMA((HIGH+LOW+CLOSE*2)/4,0.9);
X_137:=VOL*100/CAPITAL;
X_138:=MA(X_137,4);
X_139:=MA(X_137,9);
X_140:=MA(X_137,17);
X_141:=MA(X_137,34);
X_142:=(X_138+X_139+X_140+X_141)/4;
X_143:=VOL;
X_144:=X_138-X_142;
X_145:=X_139-X_142;
X_146:=IF(X_80<0 AND REF(X_144,1)>0 AND (CLOSE/REF(CLOSE,4)-1)*100<15 AND X_56>X_59 AND X_56>X_34 AND X_77>0 AND X_144>REF(X_144,1)*1.5 AND X_145>REF(X_145,1) AND X_144>0 AND X_15>X_31,80,0);
X_147:=MA(CLOSE,7);
X_148:=MA(CLOSE,14);
X_149:=MA(CLOSE,21);
X_150:=MA(CLOSE,34);
X_151:=MA(CLOSE,55);
X_152:=CROSS(X_147,X_150);
X_153:=X_147>X_148>X_149>X_150;
X_154:=MA(VOL,5);
X_155:=MA(VOL,10);
X_156:=CROSS(X_154,X_155);
X_157:=EMA(CLOSE,12)-EMA(CLOSE,26);
X_158:=EMA(X_157,9);
X_159:=(X_157-X_158)*2;
X_160:=CROSS(X_157,X_158);
X_161:=X_152 AND X_156 AND X_160;
X_162:=3*SMA((CLOSE-LLV(LOW,180))/(HHV(HIGH,180)-LLV(LOW,180))*100,5,1)-2*SMA(SMA((CLOSE-LLV(LOW,180))/(HHV(HIGH,180)-LLV(LOW,180))*100,180,1),15,1);
X_163:=BARSLASTCOUNT(100*(HHV(HIGH,20)-LLV(LOW,20))/LLV(LOW,20)<30 AND MA(CLOSE,5)>REF(MA(CLOSE,5),1) AND MA(CLOSE,10)>REF(MA(CLOSE,10),1) AND MA(CLOSE,20)>REF(MA(CLOSE,20),1))>=5 AND BARSLASTCOUNT(100*(HHV(HIGH,14)-LLV(LOW,20))/LLV(LOW,20)<15 AND MA(CLOSE,5)>REF(MA(CLOSE,5),1) AND MA(CLOSE,10)>REF(MA(CLOSE,10),1) AND MA(CLOSE,20)>REF(MA(CLOSE,20),1))<=30;
X_164:=COUNT(REF(X_163,1)<=0.25 AND CLOSE>OPEN AND CLOSE>=REF(HHV(CLOSE,15),1) AND (CLOSE-REF(CLOSE,1))/REF(CLOSE,1)>=0.04,15)=1;
X_165:=IF(X_164 AND X_48>30 AND (CLOSE-REF(CLOSE,1))/REF(CLOSE,1)>=0.04 AND CLOSE>=X_59 AND (CLOSE-REF(CLOSE,20))/REF(CLOSE,20)>0 AND (CLOSE-REF(CLOSE,20))/REF(CLOSE,20)<0.25,218,0);
X_166:=(CLOSE-REF(CLOSE,1))*100/REF(CLOSE,1);
X_167:=(REF(CLOSE,1)-REF(CLOSE,5))*100/REF(CLOSE,5);
X_168:=(REF(CLOSE,1)-REF(CLOSE,10))*100/REF(CLOSE,10);
X_169:=(-EMA(X_162,5))/4;
X_170:=(CLOSE-REF(CLOSE,20))*100/REF(CLOSE,20);
X_171:=IF(X_82>18 AND X_88>10 AND X_168<10,218,0);
X_172:=IF(COUNT(X_135>X_169,5)>=1 AND X_167>1 AND X_80<0 AND X_86=X_87 AND X_56>X_59*0.95 AND X_166>=3 AND X_168<20 OR (X_165>18 AND COUNT(CROSS(X_135,X_169),5)=1) OR (X_146>18 AND X_168<20) OR X_171>8,18,0);
X_173:=COUNT(CROSS(X_135,X_169),5)=1 AND X_170>4 AND X_86=X_87 AND X_168<20 AND X_56>X_59*1.05;
X_174:=FILTER(X_173,30);
X_175:=HIGH=HHV(X_135,10);
X_176:=(HIGH-LOW)/REF(CLOSE,1)*100;
X_177:=HHV(X_176,15);
X_178:=(REF(CLOSE,1)-REF(CLOSE,2))/REF(CLOSE,2)*100;
X_179:=(REF(CLOSE,2)-REF(CLOSE,3))/REF(CLOSE,3)*100;
X_180:=(CLOSE-REF(CLOSE,50))/REF(CLOSE,50)*100;
X_181:=(CLOSE-OPEN)/OPEN*100;
X_182:=(REF(CLOSE,1)-CLOSE)/REF(CLOSE,1)*100;
X_183:=OPEN>REF(HIGH,1) AND LOW>REF(HIGH,1) AND CLOSE>OPEN AND (OPEN-REF(CLOSE,1))/REF(CLOSE,1)*100>1.5;
X_184:=(OPEN-REF(CLOSE,1))/REF(CLOSE,1)*100>2;
X_185:=COUNT(OPEN>REF(CLOSE,1),2)>=2;
X_186:=COUNT(OPEN>REF(HIGH,1) AND LOW>REF(HIGH,1),10);
X_187:=COUNT(OPEN>REF(CLOSE,1) AND LOW>REF(CLOSE,1),10) AND LOW<OPEN;
X_188:=COUNT(OPEN>REF(CLOSE,1) AND (OPEN-REF(CLOSE,1))/REF(CLOSE,1)*100>0.1 AND CLOSE>REF(HIGH,1),10);
X_189:=SMA(ABS(HIGH-X_62),13,1)/SMA(MIN(HIGH-X_62,0),10,1);
X_190:=EMA(X_189,10);
X_191:=HHV(HIGH,33);
X_192:=EMA(IF(HIGH>=X_191,X_190,0),3);
X_193:=(CLOSE/REF(CLOSE,1)-1)*100;
X_194:=RANGE(X_193,1.07,1.1) OR CLOSE=HIGH;
X_195:=REF(X_194,2);
X_196:=REF(CLOSE,1)<REF(OPEN,1);
X_197:=CLOSE>(REF(CLOSE,1)+REF(CLOSE,1))/1.9;
X_198:=CLOSE*FINANCE(7)/100000000<60;
X_199:=IF(X_195 AND X_196 AND X_197 AND X_198,18,0);
X_200:=IF(X_192<REF(X_192,1) AND X_182<3,18,0);
X_201:=(REF(CLOSE,1)-OPEN)/REF(CLOSE,1)*100>2.5 AND (CLOSE-OPEN)/OPEN*100>2 AND X_167<30 AND X_168<40 AND X_135>=REF(X_135,1);
X_202:=FILTER(X_166>5 AND X_178>5 AND (X_135>=REF(X_135,1) AND CLOSE>X_59 AND X_168<40 AND X_135>=REF(X_135,10)),3);
X_203:=REF(X_166>5,1) AND REF(X_178,1) AND X_181<2 AND X_166<2 AND X_18<2 AND X_168<28 AND X_87=X_86;
X_204:=COUNT(X_184,10)=1 AND X_185 OR X_199 OR (X_177<20 AND X_188 AND COUNT(MA(CLOSE,34)>=LLV(MA(CLOSE,34),30),15)>1) AND X_166>5 AND X_178<5 AND X_170<20 AND X_180<40 AND X_87=X_86 AND X_151>=REF(X_151,1) AND BARSCOUNT(CLOSE)>20 AND X_135>=REF(X_135,1);
X_205:=IF(X_73>0 AND X_86>=X_87,28,0);
X_206:=IF(EXIST(X_73>0,3) AND X_27>=50,28,0);
X_207:=X_13 AND (REF(X_166,1)>5 OR X_166>1 OR X_199);
X_208:=IF(X_1 AND X_166>7 AND CROSS(X_56,X_11),18,0);
小试牛刀:FILTER(X_27>REF(X_27,5) AND X_170<30 AND X_27>=HHV(X_27,50) AND (X_205>5 OR X_206>5 AND X_170<30) AND (COUNT(CROSS(X_86,X_59),10)=1 AND X_170<30 AND (X_27>REF(X_27,10) AND X_27>=HHV(X_27,50))) OR (X_86<X_59 AND X_170<30 AND X_166>1.5 AND X_27>REF(X_27,10) AND X_170<30 AND X_56>X_59) AND X_48>20 OR (X_202 AND X_170<30) OR (X_204 AND X_170<50) OR X_207 AND X_200>0 AND X_151>=REF(X_151,1),6),COLORMAGENTA,LINETHICK2;
小牛启程:FILTER(X_172>5 AND X_15>X_31 OR X_174 AND X_144>0 AND X_48>20 OR X_170<30 AND X_204 OR X_202 OR X_207 OR X_199 OR (COUNT(CROSS(X_208,0.8),5)=1 AND X_166>1.5) AND X_200>0 AND X_151>=REF(X_151,1),6),COLORFF0080,LINETHICK2;
X_209:=IF(COUNT(X_13,5)=1 AND X_166>0.5 AND X_48>30 AND X_87=X_86 AND X_168<50 AND X_73>=REF(X_73,1),18,0);
X_210:=IF(COUNT(CROSS(小牛启程,0.8),6)=1 AND 小试牛刀>0 OR (COUNT(CROSS(小试牛刀,0.8),6)=1 AND 小牛启程>0) OR (COUNT(CROSS(X_209,0.8),6)=1 AND 小牛启程>0) OR (COUNT(CROSS(小牛启程,0.8),6)=1 AND X_209>0) OR (COUNT(CROSS(小试牛刀,0.8),6)=1 AND X_209>0) OR (COUNT(CROSS(X_209,0.8),6)=1 AND 小试牛刀>0) AND X_200>0 AND BARSCOUNT(CLOSE)>20 AND X_151>=REF(X_151,1),18,0);
X_211:=IF(X_210>5 OR X_199>5,6,0);
X_212:=IF(COUNT(CROSS(X_211,0.8),6)=1 AND (X_13 AND (REF(X_166,1)>5 OR X_166>1)) OR (COUNT(X_13,6)=1 AND X_211 AND (REF(X_166,1)>5 OR X_166>1)),8,0);
重点自选:FILTER(X_209>1,20),COLORRED,LINETHICK2;
共振乾坤:FILTER(X_210>5 OR X_199>5 OR X_209>5,6),COLORCYAN,LINETHICK2;
超牛全仓出击:FILTER(X_209>1,20),COLORYELLOW,LINETHICK2;
STICKLINE(重点自选,0,118,0.18,0),COLORRED,LINETHICK3;
STICKLINE(超牛全仓出击,0,88,3,0),COLORYELLOW,LINETHICK3;
STICKLINE(小牛启程,0,68,3,0),COLORFF0080,LINETHICK3;
STICKLINE(小试牛刀,0,48,6,0),COLORMAGENTA,LINETHICK3;
STICKLINE(共振乾坤,0,28,10,0),COLORCYAN,LINETHICK3;

通达信超牛启程指标公式

 

相关文章