在线检测未来函数

通达信行情监测指标公式

来源:Internet,编辑:股旁网,2020-10-15

本文指标含有选股公式如下:

http://www.gupang.com/202010/53214.html

AA := REF(CLOSE,1);
BBB:=SMA(MAX(CLOSE-AA,0),34,1)/SMA(ABS(CLOSE-AA),34,1)*1000;
HHH:=BBB-LLV(BBB,36);
短期:=(MA(HHH,2)*3+HHH*13)/16;
中期:=MA(HHH,10);
差值:短期-中期,NODRAW;
CCC:=LLV(BBB,36)-BBB;
短期二:=(MA(CCC,2)*3+CCC*13)/16;
中期二:=MA(CCC,10);
VB:=2*(短期-中期),NODRAW;
乖离率6:=(CLOSE-MA(CLOSE,6))/MA(CLOSE,6)*100;
乖离率12:=(CLOSE-MA(CLOSE,12))/MA(CLOSE,12)*100;
乖离率24:=(CLOSE-MA(CLOSE,24))/MA(CLOSE,24)*100;
ZP:=乖离率6<-6 AND 乖离率12<-10 AND 乖离率24<-16;
DRAWICON(ZP,-50,26);
STICKLINE(VB>=0 AND VB>REF(VB,1),0,VB,2.5,0),COLORRED;
STICKLINE(VB>=0 AND VB<REF(VB,1),0,VB,1.5,1),COLORRED;
STICKLINE(VB<0 AND 中期>REF(中期,1),0,VB,1,1),COLORRED;
STICKLINE(VB<0 AND VB<REF(VB,1),0,VB,2.5,0),COLORGREEN;
STICKLINE(VB<0 AND VB>REF(VB,1),0,VB,1.5,1),COLORGREEN;
STICKLINE(VB<0 AND 中期>REF(中期,1),0,VB,2,-1),COLORRED;
STICKLINE(VB>=0 AND 中期<REF(中期,1),0,VB,2,-1),COLORGREEN;
STICKLINE(短期<3,VB,0,2,0),COLORYELLOW;
准备买:IF(短期<3,8,0),COLORYELLOW,NODRAW;
STICKLINE(短期=0,VB,0,1,0),COLORMAGENTA;
买入:IF(短期=0,8,0),COLORMAGENTA,NODRAW;
DRAWICON(MA(短期,3)=0,VB,1);
加仓:IF(MA(短期,3)=0,8,0),COLORRED,NODRAW;
STICKLINE(差值>60 AND VB>0 AND 中期>50,VB,0,1,0),COLORBLUE;
准备卖:IF(差值>60 AND VB>0 AND 中期>50,4,0),COLORBLUE;
STICKLINE(差值>60 AND VB>0 AND 中期>100,VB,0,1,0),COLORCYAN;
卖出:IF(差值>60 AND VB>0 AND 中期>100,4,0),COLORCYAN;
坚决卖:IF(EVERY(差值>60 AND VB>0 AND 中期>100,2),2,0),COLORGREEN;
DRAWICON(EVERY(差值>60 AND VB>0 AND 中期>100,2),VB,2);
STICKLINE(VB>100,100,VB,2,0),COLORBROWN;
STICKLINE(VB>200,200,VB,1,0),COLORLIRED;
100,DOTLINE,COLORGRAY;
DRAWTEXT_FIX(ISLASTBAR,0,0,0,'准备买~黄色'),COLORYELLOW;
DRAWTEXT_FIX(ISLASTBAR,0.12,0,0,'买入~洋红色'),COLORMAGENTA;
DRAWTEXT_FIX(ISLASTBAR,0.24,0,0,'加仓~红箭头'),COLORRED;
DRAWTEXT_FIX(ISLASTBAR,0.36,0,0,'准备卖~蓝色'),COLORBLUE;
DRAWTEXT_FIX(ISLASTBAR,0.48,0,0,'卖出~青色'),COLORCYAN;
DRAWTEXT_FIX(ISLASTBAR,0.60,0,0,'坚决卖~绿箭头'),COLORGREEN;
DRAWTEXT_FIX(ISLASTBAR,0,0.12,0,'红柱~买入'),COLORRED;
DRAWTEXT_FIX(ISLASTBAR,0,0.24,0,'绿柱~卖出'),COLORGREEN;
N1:=5;
MTM:=C-REF(C,1);
趋势线:100*EMA(EMA(MTM,N1),N1)/EMA(EMA(ABS(MTM),N1),N1),COLORWHITE,LINETHICK2;

通达信行情监测指标公式

 

相关文章