在线检测未来函数

通达信追踪金牛波段指标公式

来源:Internet,编辑:股旁网,2021-03-19

MID:=(CLOSE+LOW+OPEN+HIGH)/4;
主力:(20*MID+19*REF(MID,1)+18*REF(MID,2)+17*REF(MID,3)+
16*REF(MID,4)+15*REF(MID,5)+14*REF(MID,6)+
13*REF(MID,7)+12*REF(MID,8)+11*REF(MID,9)+MID)/2,COLORRED;
主力买:IF(主力>REF(主力,2),主力,DRAWNULL),COLORRED,LINETHICK2;
主力卖:IF(主力<REF(主力,2),主力,DRAWNULL),COLORGREEN,LINETHICK2;
BIAS1:=(C-EMA(C,10))/EMA(C,10);
BIAS2:=(C-EMA(C,20))/EMA(C,20);
BIAS3:=(C-EMA(C,55))/EMA(C,55);
乖离1:=(BIAS1+5*BIAS2+10*BIAS3);
乖离2:EMA(主力+乖离1,5),NODRAW ;
乖离3:EMA(主力+乖离1+乖离2,15)/2,NODRAW ;
乖离买:IF(乖离2>REF(乖离2,2),乖离2,DRAWNULL),COLORRED,LINETHICK2,NODRAW ;
乖离卖:IF(乖离2<REF(乖离2,2),乖离2,DRAWNULL),COLORGREEN,NODRAW ;
连续乖离:=乖离2>REF(乖离2,1) AND REF(乖离2,1)>REF(乖离2,2) AND
REF(乖离2,2)>REF(乖离2,3) AND CROSS(乖离1,0);
主力买1:=IF(乖离2>REF(乖离2,3),乖离2,DRAWNULL),COLORRED;
主力买2:=IF(乖离2<REF(乖离2,2),乖离2,DRAWNULL),COLORGREEN;
STICKLINE(主力买1,乖离2,乖离3,3,0),COLORRED;
STICKLINE(主力买2,乖离2,乖离3,3,0),COLORGREEN;
{换手Z:VOL/FINANCE(46)*10000,NODRAW,COLORRED;}
IF(主力买>=REF(乖离3,2),主力买,DRAWNULL),COLORRED,LINETHICK3;
IF(主力买<=REF(乖离2,1),主力买,DRAWNULL),COLORGREEN,LINETHICK2;
DRAWTEXT(CROSS(主力买,乖离2) AND CROSS(C,MA(C,10)),乖离2,'初显'),COLORFFFFA6;
DRAWTEXT(CROSS(主力买,乖离2) AND CROSS(C,MA(C,60)),乖离3,'牛妖'),COLOR51E3E8;

通达信追踪金牛波段指标公式

 

相关文章