在线检测未来函数

通达信爬山涉水过草地指标公式

来源:Internet,编辑:股旁网,2015-11-17

P1:=5;P2:=13;P3:=34;
DRAWGBK(O>C,RGB(0,0,150),RGB(80,0,80),0,'01',0);
TJ:=IF(DYNAINFO(8)>0.01,0.01*DYNAINFO(10)/DYNAINFO(8),DYNAINFO(3));
TD:=(DYNAINFO(5)<0.01 || DYNAINFO(6)<0.01);
JT:=IF(TD,1,(TJ<(DYNAINFO(5)+0.01) && TJ>(DYNAINFO(6)-0.01)));
cyc1:=IF(JT,0.01*Ema(AMOUNT,P1)/EMA(vol,P1),EMA((HIGH+LOW+CLOSE)/3,P1));
CYC2:=IF(JT,0.01*EMA(AMOUNT,P2)/EMA(VOL,P2),EMA((HIGH+LOW+CLOSE)/3,P2));
CYC3:=IF(JT,0.01*EMA(AMOUNT,P3)/EMA(VOL,P3),EMA((HIGH+LOW+CLOSE)/3,P3));
CYC∞:=IF(JT,DMA(AMOUNT/(100*VOL),100*VOL/FINANCE(7)),EMA((HIGH+LOW+CLOSE)/3,120));
stICKLINE(CYC1<CYC2,CYC2,CYC∞,4,0)COLORGREEN;
DRAWBAND(CYC1,RGB(80,30,0),CYC∞,RGB(0,50,150));
DRAWICON(CYC1>CYC∞ AND CYC2>CYC3 AND REF(C,1)<REF(O,1) AND C>REF(H,1) AND O<REF(C,1) AND MA(C,5)>REF(MA(C,5),1),CYC1,15);
倍量:=V>=2*REF(V,1);
DRAWICON(CYC1>CYC∞ AND CYC2>CYC3 AND 倍量 ,CYC1*0.9,28);
DRAWTEXT(CYC1>CYC∞ AND CYC2>CYC3 AND 倍量,CYC∞*0.9,'倍量'),COLORLIGRAY;
X:=CONST(DATE);
Y:=IF(DATE<X, 240, FROMOPEN);
总交易日:=BARSCOUNT(CLOSE);
DRAWICON((VOL/Y*240)=CONST(LLV(VOL,总交易日)),CYC1,11);
DRAWTEXT((VOL/Y*240)=CONST(LLV(VOL,60)) AND (VOL/Y*240)>CONST(LLV(VOL,总交易日)),CYC1,'地量'),COLORYELLOW;
DRAWICON((VOL/Y*240)=CONST(LLV(VOL,60)),CYC∞*1.8,14);

通达信爬山涉水过草地指标公式

相关文章