在线检测未来函数

通达信阴线捉妖主图指标公式

来源:Internet,编辑:股旁网,2020-10-12

ZTT:=Abs(REF(C,1)*1.1-C)<=0.01,LINETHICK3;
WAA:=REF(C,1)*1.0714;
AR:DRAWLINE(ZTT,WAA,REF(ZTT,1),REF(WAA,1),1),LINETHICK1,COLORYELLOW;
kstAR:=(C-O)/(H-L)<0.1 AND H/L>1.03 AND (O-L)/(H-L)>0.4;
SA:=(ABS(C-O))/O<0.003;
SB:=REF(O,1)>REF(C,1);
SD:=REF(C,2)>REF(C,1)*1.03;
百分之三:=SA AND SB AND SD;
MX:=maX(C,O);
MI:=MIN(C,O);
SY:=H-MX;
XY:=MI-L;
Pst:=100*(MX-MI)/MI;
十字星:=SY+XY>0 AND IF(MAX(SY,XY)>ABS(C-O),PST<1.25,PST<=1);
F:=100*(C-REF(C,1))/REF(C,1);
P1:=IF(C<REF(O,1) AND F<0,1,0);
P2:=IF(C<REF(O,2) AND F<0,1,0);
TT3:=P1=0 AND REF(P1,1)=1 AND P2=0 AND REF(P2,1)=1 ;
M13:=zig(3,13);
A:=IF(crOSS(M13,REF(M13,1))AND REF(M13,1)<=M13, M13*1.2,ZIG(3,10)),COLOR00FF00,LINETHICK3;
VAR1:=ZIG(3,30);
VAR2:=REF(VAR1,1);
VAR4:=CROSS(VAR1,VAR2);
LC:=REF(C,1);
rsi:=((SMA(MAX((C - LC),0),3,1) / SMA(ABS((C - LC)),3,1)) * 100);
VAR4R:=(RSI>85);
VAR6:=(CLOSE-LLV(LOW,9))/(HHV(HIGH,9)-LLV(LOW,9))*100;
K:=SMA(VAR6,3,1);
D:=SMA(K,3,1);
J:=(3*K-2*D);
股价趋势:=ZIG(3,5);
当心变盘:=IF((股价趋势=M13 AND 股价趋势>REF(股价趋势,1) AND M13>REF(M13,1)) OR J>95 OR VAR4R,A*1.3,A);
阴线十字星:=CROSS(C,AR) AND (小十字星 OR 百分之三);
T11:=C>REF(C,1);
T21:=O>REF(C,1);
T31:=O>C;
阴线买:EVERY(阴线十字星,TT3 AND 当心变盘 AND T11 AND T21 AND T31),NODRAW;
DRAWTEXT(阴线买,LOW*0.98 ,'阴' ) ,COLORYELLOW;
DRAWTEXT(阴线买,LOW*0.96 ,'线' ) ,COLORYELLOW;
DRAWTEXT(阴线买,LOW*0.94 ,'买' ) ,COLORYELLOW;
STICKLINE(阴线买,CLOSE,OPEN,5,0),COLORBLUE;
STICKLINE(阴线买,CLOSE,OPEN,4,0),COLORWHITE;
STICKLINE(阴线买,CLOSE,OPEN,2.5,0),COLORRED;

通达信阴线捉妖主图指标公式

相关文章