在线检测未来函数

通达信涨停压力标注主图指标公式

来源:Internet,编辑:股旁网,2020-12-16

本文指标含有选股公式如下:

涨停压力标注主图之B选股指标公式

S:=2;
D:=72;
涨停:=BETWEEN(CLOSE/REF(CLOSE,1),1.0984,1.110) AND C=H AND C>O;
ma5:=expma(C,5),COLORWHITE;
MA13:=EXPMA(C,13),COLOR00C0C0;
MA28:=EXPMA(C,28),COLORMAGENTA;
R1:=(C>REF(C,1) AND C>REF(C,2));
R2:=(REF(R1,1) AND C<=REF(C,1) AND C>=REF(C,2));
R3:=(REF(R2,1) AND C>=REF(C,1) AND C<=REF(C,2));
R4:=(REF(R3,1) AND C<=REF(C,1) AND C>=REF(C,2));
R5:=(REF(R4,1) AND C>=REF(C,1) AND C<=REF(C,2));
R6:=(REF(R5,1) AND C<=REF(C,1) AND C>=REF(C,2));
R7:=(REF(R6,1) AND C>=REF(C,1) AND C<=REF(C,2));
R8:=(REF(R7,1) AND C<=REF(C,1) AND C>=REF(C,2));
R9:=(REF(R8,1) AND C>=REF(C,1) AND C<=REF(C,2));
RA:=(REF(R9,1) AND C<=REF(C,1) AND C>=REF(C,2));
RB:=(REF(RA,1) AND C>=REF(C,1) AND C<=REF(C,2));
RC:=(REF(RB,1) AND C<=REF(C,1) AND C>=REF(C,2));
RD:=(C<REF(C,1) AND C<REF(C,2));
RE:=(REF(RD,1) AND C>=REF(C,1) AND C<=REF(C,2));
RF:=(REF(RE,1) AND C<=REF(C,1) AND C>=REF(C,2));
R10:=(REF(RF,1) AND C>=REF(C,1) AND C<=REF(C,2));
R11:=(REF(R10,1) AND C<=REF(C,1) AND C>=REF(C,2));
R12:=(REF(R11,1) AND C>=REF(C,1) AND C<=REF(C,2));
R13:=(REF(R12,1) AND C<=REF(C,1) AND C>=REF(C,2));
R14:=(REF(R13,1) AND C>=REF(C,1) AND C<=REF(C,2));
R15:=(REF(R14,1) AND C<=REF(C,1) AND C>=REF(C,2));
R16:=(REF(R15,1) AND C>=REF(C,1) AND C<=REF(C,2));
R17:=(REF(R16,1) AND C<=REF(C,1) AND C>=REF(C,2));
R18:=(REF(R17,1) AND C>=REF(C,1) AND C<=REF(C,2));
R19:=((REF(RD OR RE OR RF OR R10 OR R11 OR R12 OR R13 OR R14 OR R15 OR R16 OR R17 OR R18,1)) AND R1);
R1A:=((REF(R1 OR R2 OR R3 OR R4 OR R5 OR R6 OR R7 OR R8 OR R9 OR RA OR RB OR RC,1)) AND RD);
蓝心板:=REF(RD OR RE OR RF OR R10 OR R11 OR R12 OR R13 OR R14 OR R15 OR R16 OR R17 OR R18,1);
RSV9:=(C-LLV(LOW,9))/(HHV(HIGH,9)-LLV(LOW,9))*100;
K1:=SMA(RSV9,3,1);
DK1:=K1-REF(K1,1);
出手就赢:=IF(DK1>7 AND REF(DK1,1)<0 AND (DK1-REF(DK1,1))>9,50,0);
绿心板:=(出手就赢=50 OR REF("kdj.J",1)<0) AND "kdJ.J">0;
红心板:=蓝心板 AND 绿心板;
红色持股:=R1 OR R2 OR R3 OR R4 OR R5 OR R6 OR R7 OR R8 OR R9 OR RA OR RB OR RC;
短进:=R19;
青色观望:=RD OR RE OR RF OR R10 OR R11 OR R12 OR R13 OR R14 OR R15 OR R16 OR R17 OR R18;
急速超跌:=(C-MA(C,34))/MA(C,34)*100<-14;
品红离场:=R1A;
stICKLINE(C>=O,L,H,0,0),COLOR0000CC;
STICKLINE(C<O,L,H,0,0),COLOR999900;
STICKLINE(1,C,O,3.5,0),COLOR858500;
STICKLINE(C>=O,C,O,3.5,0),COLOR0000E5;
STICKLINE(红色持股,C,O,2.8,0),COLOR000055;
STICKLINE(红色持股,C,O,2,0),COLOR000088;
STICKLINE(红色持股,C,O,1.5,0),COLOR0000AA;
STICKLINE(红色持股,C,O,1,0),COLOR0000CC;
STICKLINE(红色持股,C,O,0.5,0),COLOR0000EE;
STICKLINE(青色观望,C,O,2.8,0),COLOR555500;
STICKLINE(青色观望,C,O,2,0),COLOR888800;
STICKLINE(青色观望,C,O,1.5,0),COLORAAAA00;
STICKLINE(青色观望,C,O,1,0),COLORCCCC00;
STICKLINE(青色观望,C,O,0.5,0),COLOREEEE00;CO:=(C-O);
绿心过滤:=IF((蓝心板),DRAWNULL,绿心板);
蓝心过滤:=IF((绿心板),DRAWNULL,蓝心板);
STICKLINE(急速超跌,O,C-CO/2,2.8,0),COLOR555555;
STICKLINE(急速超跌,O,C-CO/2,2,0),COLOR888888;
STICKLINE(急速超跌,O,C-CO/2,1.5,0),COLORAAAAAA;
STICKLINE(急速超跌,O,C-CO/2,1,0),COLORCCCCCC;
STICKLINE(急速超跌,O,C-CO/2,0.5,0),COLOREEEEEE;
STICKLINE(短进,O,O+CO/3,2.8,0),COLOR335555;
STICKLINE(短进,O,O+CO/3,2,0),COLOR338888;
STICKLINE(短进,O,O+CO/3,1.5,0),COLOR33AAAA;
STICKLINE(短进,O,O+CO/3,1,0),COLOR33CCCC;
STICKLINE(品红离场,O,O+CO/3,2.8,0),COLOR550055;
STICKLINE(品红离场,O,O+CO/3,2,0),COLOR880088;
STICKLINE(品红离场,O,O+CO/3,1.5,0),COLORAA00AA;
STICKLINE(品红离场,O,O+CO/3,1,0),COLORCC00CC;
STICKLINE(品红离场,O,O+CO/3,0.5,0),COLOREE00EE;
STICKLINE(涨停,O,C,3.6,1),COLORYELLOW;
STICKLINE(涨停 AND 蓝心过滤,O,C,0.4,0),COLORBLUE;
STICKLINE(涨停 AND 绿心过滤,O,C,0.4,0),COLORGREEN;
STICKLINE(涨停 AND 红心板,O,C,0.4,0),COLORRED;
{绿心板:中继板,继续上涨中出现;红心板:吸货板,短线比较稳定空心板:疯板,要么暴涨,要么止损;蓝心板:自救板,回调中出现。}
DRAWTEXT_FIX(1,0.28,0.995,1,'绿心板:中继板,继续上涨中出现'),COLORRED;
DRAWTEXT_FIX(1,0.69,0.995,1,'空心板:疯板,要么暴涨,要么止损;蓝心板:自救板,回调中出现。'),COLORYELLOW;
DRAWTEXT_FIX(1,0.86,0.995,1,'红心板:吸货板,短线比较稳定'),COLORRED;
DI:=ema(C,12)-EMA(C,13);
DE:=EMA(DI,3);
RSV:=(C-LLV(L,9))/(HHV(H,9)-LLV(L,9))*100;
DRAWTEXT(crOSS(DE,DI),H*1.03,'S'),COLOR00FF00;
DRAWTEXT(CROSS(DI,DE),L*0.94,'B'),COLORFF33FF;
K8:=BArslAST(EMA(C,5)>=EMA(C,20));
K9:=BARSLAST(EMA(C,5)<=EMA(C,20));
K110:=IF(EMA(C,5)>=EMA(C,20),(EMA(C,5)+EMA(C,20))/2,DRAWNULL);
K115:=IF(EMA(C,5)>=EMA(C,20),EMA(C,5),DRAWNULL);
K120:=IF(EMA(C,5)>=EMA(C,20),EMA(C,20),DRAWNULL);
线5:IF(CURRBARSCOUNT<CONST(K9+2),K115,DRAWNULL)COLORWHITE;
线10:IF(CURRBARSCOUNT<CONST(K9+2),K110,DRAWNULL),COLORYELLOW,LINETHICK2;
线20:IF(CURRBARSCOUNT<CONST(K9+2),K120,DRAWNULL),COLORMAGENTA,LINETHICK4;
AAA2:=SUM(IF( CLOSE>REF(CLOSE,1),vol*C,0),0);
AAA3:=SUM(IF( CLOSE<REF(CLOSE,1),VOL*C,0),0);
AAA4:=SUM(IF( CLOSE=REF(CLOSE,1),VOL*C,0),0);
BB1:=0;
B1万元:=DVOL*DCLOSE/100;
B1差:=B1万元-REF(B1万元,1);
B2万元:=DVOL*DCLOSE/100;
B2比:=B2万元/REF(B2万元,1);
净流入万元:=(AAA2-AAA3-0.5*AAA4);
PM:=MA(净流入万元,1);
PMA:=PM/REF(PM,1)>1;
PMB:=REF(PMA,1)<1 AND PMA;
密码:=(EMA(MA(B1万元,2),2))/100000,COLORYELLOW,NODRAW;
二日比:=密码/REF(密码,1);
选股:=PMB AND 密码>REF(密码,1) AND 二日比>1,COLORRED,NODRAW;
DRAWNUMBER(选股=1 ,L,密码),COLORYELLOW;
日1:=50;昨前1:=3;
高1:=REF(HHV(H,日1),昨前1);
低1:=REF(LLV(L,日1),昨前1);
H4:=高1-(高1-低1)*0.618;
H5:=高1-(高1-低1)*0.809;
支撑八十点九:REFDATE(H5,DATE),COLORRED;
支撑六十一点八:REFDATE(H4,DATE),COLORGREEN,LINETHICK1;
STICKLINE(CURRBARSCOUNT=1,支撑八十点九,支撑八十点九,1000,-1),COLORGREEN;
STICKLINE(CURRBARSCOUNT=1,支撑六十一点八,支撑六十一点八,1000,-1),COLORRED;
DRAWTEXT(CURRBARSCOUNT=30 AND 支撑六十一点八,支撑六十一点八,'线上买持股, 线下卖持币');
DRAWTEXT(CURRBARSCOUNT=1 AND 支撑六十一点八,支撑六十一点八,'---------------命运转折线'),COLORYELLOW;
AA17:=EMA(C,14)COLORWHITE,LINETHICK1;
A17X:=(AA17-REF(AA17,1))/REF(AA17,1)*100,NODRAW;
参考线试买:IF(A17X>=0,REF(EMA(C,14),BARSLAST(CROSS(A17X,0))+1),DRAWNULL)COLORRED,LINETHICK2;
DRAWTEXT(ISLASTBAR,参考线试买,'----参考线试买------'),COLORYELLOW,LINETHICK4;
Y:=(H+L)/2;
ao:=MA(Y ,5 )-MA(Y ,34 );
DU0:=CROSS(AO,0);
UD0:=CROSS(0,AO);
TDU0:=BARSLAST(DU0);
TUD0:=BARSLAST(UD0);
DU3:=REF(DU0,1);
UD3:=REF(UD0,1);
TDU3:=BARSLAST(DU3);
TUD3:=BARSLAST(UD3);
年:=YEAR,NODRAW;
月:=MONTH,NODRAW;
星期:=WEEKDAY,NODRAW;
日:=DATETODAY(DATE);
上市日:=REF(DATE,TOTALBARSCOUNT-CURRBARSCOUNT);
自然日:=日-DATETODAY(上市日)+1;
ZB:=(自然日-REF(自然日,1))!=星期-REF(星期,1)
OR TOTALBARSCOUNT-CURRBARSCOUNT=0;
本周第几天:=BARSLAST(ZB)+1;
本月第几天:=BARSLAST(年*100+月!=REF(年*100+月,1))+1;
MA11:=REF(C,本周第几天);
MA22:=REF(MA11,本周第几天);
MA33:=REF(MA22,本周第几天);
MA44:=REF(MA33,本周第几天);
MA55:=REF(MA44,本周第几天);
MA66:=REF(MA55,本周第几天);
MA77:=REF(MA66,本周第几天);
MA88:=REF(MA77,本周第几天);
MA99:=REF(MA88,本周第几天);
十周价:=(C+MA11+MA22+MA33+MA44+MA55+MA66+MA77+MA88+MA99)/10;
出击突破:REFDATE(十周价,DATE),COLORFF0080,DOTLINE;
DRAWTEXT(ISLASTBAR,出击突破,'------------------- 出击突破'),COLORFF0080;
DMLJ:=HHV(H,120);
E:=(H+L+O+2*C)/5;
CRTP:=E+(H-L);
CRZL:=2*E-L;
CRZC:=2*E-H;
CRFZ:=E-(H-L);
CRXL:=(E+CRTP+CRZL+CRZC+CRFZ)/5;
高:=CONST(CRTP),COLORRED;
阻:=CONST(CRZL),COLORC7C9FF;
支:=CONST(CRZC),COLOR7C9CFF;
反:=CONST(CRFZ),COLORDD00DD;
心理:=CONST(CRXL);
高压:DRAWLINE(S>1&&CURRBARSCOUNT=5+1,高,ISLASTBAR,高,1),COLOR0000FF;
阻力:DRAWLINE(S>1&&CURRBARSCOUNT=5+1,阻,ISLASTBAR,阻,1),COLOR0099FF;
支撑:DRAWLINE(S>1&&CURRBARSCOUNT=5+1,支,ISLASTBAR,支,1),COLORGREEN;
反转价:DRAWLINE(S>1&&CURRBARSCOUNT=5+1,反,ISLASTBAR,反,1),COLORDD00DD;
次日心理价:DRAWLINE(S>1&&CURRBARSCOUNT=5+1,心理,ISLASTBAR,心理,1),COLORFFFFFF;
DRAWTEXT(ISLASTBAR,反,'------------ ----------------少量买'),LINETHICK1,COLORDD00DD;
DRAWTEXT(ISLASTBAR,支,' 支 撑'),LINETHICK1,COLOR00FF00;
DRAWTEXT(ISLASTBAR,阻,' 阻 力'),LINETHICK1,COLOR0099FF;
DRAWTEXT(ISLASTBAR,高,' 高 压'),LINETHICK1,COLOR0000FF;
【0】:=MA(L+(H-L)/2,5),CIRCLEDOT,COLORMAGENTA;
【1】:=DRAWLINE(CURRBARSCOUNT=3,【0】,CURRBARSCOUNT=2,【0】,0),COLORYELLOW,LINETHICK2;
【2】:=DRAWLINE(CURRBARSCOUNT=2,【0】,CURRBARSCOUNT=1,【0】,0),COLORRED,LINETHICK2;
【3】:=DRAWLINE(CURRBARSCOUNT=3,【0】,CURRBARSCOUNT=1,【0】,0),COLORRED,LINETHICK2;
DRAWBAND(【1】,RGB(155,50,50),【3】,RGB(250,250,0));
DRAWBAND(【2】,RGB(100,50,50),【3】,RGB(250,100,0));
【4】:=REF(【0】,1);【5】:=REF(【0】,2);
DRAWTEXT(【0】>【4】 AND 【0】<【5】,【2】,'转强'),COLOR33FFCC;
DRAWTEXT(【0】>【4】 AND 【0】>【5】,【2】,'强市'),COLOR33FFCC;
DRAWTEXT(【0】<【4】 AND 【0】>【5】,【2】,'转弱'),COLOR33FFCC;
DRAWTEXT(【0】<【4】 AND 【0】<【5】,【2】,'弱市'),COLOR33FFCC;
PH:=TROUGHBARS(2,5,1);
LL:=HHV(H,PH);
TJ11:=LL=HIGH AND LL<REF(LL,1);{//=1}
TS:=SUMBARS(TJ11,2);
TJ:=PEAKBARS(2,5,1)=1 AND TS>=PH;
DRAWICON(TJ,HIGH*1.01+0.02,2);
PL:=BARSLAST(TJ);
HLCO:=(C+H+L+O)/4;
MAHC:=MA((CLOSE*2+H)/3,5),COLOR0000FF;
MAHO:=MA((O*2+H)/3,5),COLOR00FF00;
MALC:=MA((C+L*2)/3,5),COLORFFFFFF;
MALO:=MA((O+L*2)/3,5),COLOR00FFFF;
CO1:=O+(C-O)/2;
STICKLINE(MAHC<MAHO AND (CROSS(C,MALO) OR CROSS(HLCO,MALO)),C,O,2.8,0),COLORWHITE;
DRAWTEXT_FIX(CURRBARSCOUNT=1,0.00,0.12,0,'--------------------白K关注,黄K买入,红K持股');
A1:=(CLOSE+HIGH+LOW)/3;
A2:=EMA(A1,3);
A3:=REF(A2,1);
A4:=IF(A2>A3,A2,DRAWNULL);
A5:=IF(A2<=A3,A2,DRAWNULL);
STICKLINE(CROSS(C,REF(A5,1)),REF(A5,1)*1.002,REF(A5,1),20,0),COLORRED;
DRAWTEXT(CROSS(REF(A4,1),C) AND A4,H,'↓开跌'),COLORGREEN;
QW1:=(H+L+C*2)/4;
QW3:=EMA(QW1,10);
QW4:=STD(QW1,10);
QW5:=(QW1-QW3)*100/QW4;
QW6:=EMA(QW5,5);
RK7:=EMA(QW6,10);
Z:=EMA(QW6,10)+100/2-5;
DRAWTEXT(CURRBARSCOUNT=1,(MIN(C,O)+L)/2*0.995,EXTERNSTR(0,9997)); { 涨停原因};

通达信涨停压力标注主图指标公式

相关文章