在线检测未来函数

通达信筹码一线天指标公式

来源:Internet,编辑:股旁网,2021-05-20

五十成本集中:=(COST(75)-COST(25))/(COST(75)+COST(25))*100;
成本价1:=COST(五十成本集中),COLORGREEN;
五十成本集中1:=100-五十成本集中;
成本价2:=COST(五十成本集中1),COLORBLUE;
单峰密集价:成本价2/成本价1-1,STICK;
红:=REF(单峰密集价,1)<单峰密集价 AND 成本价2>REF(成本价2,1) ;
绿:=REF(单峰密集价,1)>单峰密集价;
主力筹码:=单峰密集价<=0.25;
底部:=(COST(95)-COST(5))/(COST(95)+COST(5))*100;
底部成本价:=COST(底部),COLORYELLOW;
顶部:=100-底部;
顶部成本价:=COST(顶部),COLORGREEN;
均值:=(底部+顶部)/2;
均值成本:=COST(均值),COLORLICYAN,DOTLINE;
STICKLINE(红,单峰密集价,0,2.8,0),COLOR000055;
STICKLINE(红,单峰密集价,0,2,0),COLOR000088;
STICKLINE(红,单峰密集价,0,1.5,0),COLOR0000AA;
STICKLINE(红,单峰密集价,0,1,0),COLOR0000CC;
STICKLINE(红,单峰密集价,0,0.5,0),COLOR0000EE;
STICKLINE(红,单峰密集价,0,0,0),COLORFFFFFF;
底:=REF(单峰密集价,2)<REF(单峰密集价,1) AND 单峰密集价<REF(单峰密集价,1) AND 均值成本<REF(均值成本,1);
STICKLINE(底,单峰密集价,0,0,0),COLORGREEN;
STICKLINE(底,单峰密集价,0,2.8,0),COLOR009900;
STICKLINE(底,单峰密集价,0,2,0),COLOR00BB00;
STICKLINE(底,单峰密集价,0,1.5,0),COLOR00DD00;
STICKLINE(底,单峰密集价,0,0.5,0),COLOR00FF00;
顶:=REF(单峰密集价,2)<REF(单峰密集价,1) AND 单峰密集价<REF(单峰密集价,1) AND 均值成本>REF(均值成本,1);
STICKLINE(顶,单峰密集价,0,2,0),COLORYELLOW;
N:=30;
N1:=20;
V1:=REF(((HHV(H,N)-LLV(L,N))/LLV(L,N)),1)<=(N1/100) AND C>=REF(HHV(H,N),1) AND BARSCOUNT(C)>N;
一线天:IF(V1,1,0);
A30:=EMA(C,34)>REF(EMA(C,34),1);
A50:=COST(50),COLORRED,LINETHICK2;
A70:=WINNER(C)*100>50;
A90:=CROSS(C,A50);
突破密集:A30 AND A50 AND A70 AND A90;
DRAWICON(突破密集,1,1);
AJB:=IF(CAPITAL>20000000,CAPITAL*33/100,IF(CAPITAL>12000000,CAPITAL*27/100,CAPITAL*22/100));
AJ1:=(COST(85)+COST(15))/2;AJ2:=(COST(75)+COST(25))/2;AJ3:=(COST(65)+COST(35))/2;AJ4:=(COST(55)+COST(45))/2;AJ5:=(COST(95)+COST(5))/2;
AJ:=(AJ1+AJ2+AJ3+AJ4+AJ5)/5;
BJ1:=(COST(90)+COST(10))/2;BJ2:=(COST(80)+COST(20))/2;BJ3:=(COST(70)+COST(30))/2;BJ4:=(COST(60)+COST(40))/2;BJ5:=(COST(50));
BJ:=(BJ1+BJ2+BJ3+BJ4+BJ5)/5;
筹码峰值:MA((AJ+BJ)/2,3),NODRAW;
筹码中枢:(COST(65)-COST(15))/(COST(25))*100,NODRAW;
日集中度:(AMOUNT/筹码峰值)/(CAPITAL-AJB)*2,NODRAW;
五日集中度:SUM(AMOUNT/筹码峰值,5)/(CAPITAL-AJB)/100*100,NODRAW;
{集中:日集中度>10;
DRAWICON(集中,1.3,2);}
五日集中:五日集中度>30,COLORCYAN;
DRAWTEXT_FIX(1,0.0,0.02,0,'1.低位绿K底 高位黄色K线小心顶 红K拉升'),COLORYELLOW;

通达信筹码一线天指标公式

 

相关文章