在线检测未来函数

通达信抢筹力度指标公式

来源:Internet,编辑:股旁网,2021-06-11

ZLCM:=EMA(WINNER(CLOSE)*70,3);
{//主力筹码估算}
SHCM:=EMA((WINNER(CLOSE*1.1)-WINNER(CLOSE*0.9))*80,3);
{//小筹码估算}
ZSHTL:=SHCM/(ZLCM+SHCM)*100;
{//小股民套牢筹码比率}
ZZLKP:=ZLCM/(ZLCM+SHCM)*100;
{//主力控盘筹码比}
ZCMZL:=MA(ZLCM+SHCM,13);
{//市场筹码总量}
ZZNTS:=BARSLAST(ZSHTL<90 AND REF(ZSHTL,1)>90);
{//走牛天数}
ZSHJJ:=EMA(ZSHTL,89);
{//小股民警戒}
ZZLJJ:=EMA(ZZLKP,89);
{//主力警戒}
ZJLRQD:=INTPART(ZZLKP-ZZLJJ);
{//资金流入强度}
BB:=MA(C,1);
持币阶段:=SMA(SMA(SMA(BB,2,1),2,1),2,1);
主升持股波段:=HHV(MA(持币阶段,1),13);
SH8:=EMA(ZSHTL,8);
DKB:=IF(ZZLKP-REF(ZZLKP,1)>ZSHTL-REF(ZSHTL,1),1,0);
{神秘黑洞}
{☆精确风险}
{【参数定义】}
RSV:=(CLOSE-LLV(LOW,15))/(HHV(HIGH,15)-LLV(LOW,15))*100;
K1:=SMA(RSV,10,1);
D1:=SMA(K1,5,1);
KK:=INTPART(K1);
DD:=INTPART(D1);
TFXXS:=KK+DD;
{//变异KD风险系数}
TGLD:=MOD(TFXXS,10);
{//踏浪涨停概率点}
TGLXS:=(TFXXS-REF(TFXXS,1))*10;
{//变异KD乖离系数}
TYCFX:=TFXXS+TGLXS;
{//变异KD预测风险}
乖离系数:=TGLXS,NODRAW,COLORRED;
ER:=V/FINANCE(7)*100;
A0:=TMA(ER,(1-ER),1);
MAXCYC:=DMA((C+O)/2,ER/TMA(ER,(1-ER),1));
T1:=BARSLAST(C>MAXCYC*POW(1.1,0.9));
T2:=BARSLAST(C<MAXCYC*POW(1.1,-0.9));
T3:=CROSS(T1,T2) OR CROSS(T2,T1) OR BARSSINCE(T1+1)=0 OR BARSSINCE(T2+1)=0 OR BARSCOUNT(C)=0;
T4:=REF(MAXCYC,BARSLAST(T3));
VAR11:=3*SMA((C-LLV(L,480))/(HHV(H,480)-LLV(L,480))*100,5,1)
-2*SMA(SMA((C-LLV(L,480))/(HHV(H,480)-LLV(L,480))*100,180,1),15,1);
SMA2:=MA(持币阶段,3);
V1:=(C*2+H+L)/4*10;
V2:=EMA(V1,13)-EMA(V1,21);
V3:=EMA(V2,5);
V4:=2*(V2-V3)*100,COLORRED,LINETHICK2;
筹码进:=IF(V4>=0,V4,0);
双线合一关注:=主升持股波段,COLOR4169E1,LINETHICK4;
涨幅1:=(REF(C,1)-REF(C,2))/REF(C,2)*100;
涨幅2:=(REF(C,2)-REF(C,3))/REF(C,3)*100;
涨幅:=(C-REF(C,1))/REF(C,1)*100;
涨幅20:=(REF(C,1)-REF(C,21))/REF(C,21)*100;
涨幅50:=(REF(C,1)-REF(C,50))/REF(C,50)*100;
涨幅10:=(REF(C,1)-REF(C,11))/REF(C,11)*100;
振幅5:=HHV(CLOSE,5)/LLV(CLOSE,5);
跌幅:=(REF(C,1)-C)/REF(C,1)*100;
VAR1:=REF((LOW+OPEN+CLOSE+HIGH)/4,1);
VAR21:=SMA(ABS(HIGH-VAR1),13,1)/SMA(MIN(HIGH-VAR1,0),10,1);
VAR31:=EMA(VAR21,10);
VAR41:=HHV(HIGH,33);
VAR51:=EMA(IF(HIGH>=VAR41,VAR31,0),3);
主力抬轿:=IF(VAR51<REF(VAR51,1)AND(跌幅<3),筹码进,0);
VAR1D:=EMA(CLOSE,2)-EMA(CLOSE,89);
VAR1E:=EMA(VAR1D,30);
VAR1F:=2*(VAR1D-VAR1E)*10;
VAR20:=POW(VAR1F,3)*0.1+POW(VAR1F,2);
VAR25:=IF(YEAR<2008 AND VAR1F>0.015,VAR20,0)/45;
VAR26:=EMA(CLOSE,2)-EMA(CLOSE,150);
VAR27:=EMA(VAR26,100);
VAR28:=2*(VAR26-VAR27);
VAR29:=POW(VAR28,3)*0.1+POW(VAR28,1);
AA:=IF( VAR28>0.1 AND 持币阶段=双线合一关注 AND 涨幅>0,VAR29,0)*3;
主力抢筹力度:AA;

通达信抢筹力度指标公式

 

相关文章