在线检测未来函数

通达信升降主图指标公式

来源:Internet,编辑:股旁网,2021-10-12

VAR1:ma(CLOSE,5);
VAR2:MA(CLOSE,10);
VAR3:MA(CLOSE,20);
VAR60:MA(CLOSE,60)COLORYELLOW,LINETHICK2;
IF(C>VAR60 AND VAR60>REF(VAR60,1),VAR60,DRAWNULL),COLOR0000FF,LINETHICK3;
IF(C<VAR60 AND VAR60<REF(VAR60,1),VAR60,DRAWNULL),COLORGREEN,LINETHICK3;
VAR120:MA(CLOSE,120);
VAR4:=OPEN<VAR1 OR OPEN<VAR2 OR OPEN<VAR3;
VAR5:=CLOSE>MAX(VAR1,MAX(VAR2,MAX(VAR3,VAR60)));
VAR6:=vol/MA(VOL,30)>1.2;
VAR7:=CLOSE/REF(CLOSE,1)>1.049;
VAR8:=VAR4 AND VAR5 AND VAR6 AND VAR7;
C2:=REF(C,1);
涨停:=IF((C-C2)*100/C2>=(10-0.01*100/C2),1,0);stICKLINE(涨停,OPEN,CLOSE,2,0),COLORYELLOW;
A00:=SUM(IF((C> REF(C,1)),VOL,IF((C<REF(C,1)),(0-V),0)),0);
A01:=SUMBARS(V,CAPITAL);
A02:=IF((C>LLV(C,A01)),1,(0-1))*IF((A00 >LLV(A00,A01)),1,(0-1));
A03:=(COUNT((IF((A02=(0-1)),1,0)=1),8)>2);
A04:=((C-dma((((3 * H + L)+O)+2 * C)/7.000,V/SUM(AMOUNT,13)/
AMOUNT/V/100/100))/DMA((((3*H+L)+O)+2*C)/7,V/SUM(AMOUNT,13)/
AMOUNT/V/100/100)*100<(0-18));
A05:=((C-MIN(REF(C,5)*0.865,REF(C,21)*0.772))/C<0.009);
A06:=((A03 AND A04) AND A05);
A07:=((((O < ema(C,5)) AND (C/O>=1.05)) AND (V/CAPITAL>=0.019)) AND (V/CAPITAL<=0.2));
A08:=(A07 AND (COUNT(A07,5)=1));
A0901:=MA(C,3)>REF(MA(C,3),1);
A0902:=MA(C,5)>REF(MA(C,5),1);
A0903:=MA(C,10)>REF(MA(C,10),1);
A0904:=V/240>REF(V,30)*1.200/240.000*1.500;
A0905:=C>L*1.059;
A0906:=C>REF(MA(C,3),1);
A0907:=A0901 AND A0902 AND A0903 AND A0904 AND A0905 AND A0906;
A0908:=A0907 AND REF(C,1);
A0909:=MA(C,20)>REF(MA(C,20),1);
A0910:=MA(V,5)>REF(MA(V,5),1);
A0911:=MA(C,5)-MA(C,10);
A0912:=A0911<= 0.579;
A09:=A0908 AND A0902 AND A0903 AND A0909 AND A0910 AND A0912;
A0A:=FILTER(A09,5.000);
FL4:=V=HHV(V,250);
FL3:=V=HHV(V,120) AND V!=HHV(V,250);
FL2:=V=HHV(V,60) AND V!=HHV(V,120) AND V!=HHV(V,250);
TJ1:=IF(H=HHV(H,3),10,0);
TJ2:=COUNT(C>REF(C,1),9)*5;
TJ3:=IF(H=HHV(H,5),15,0);
TJ4:=IF(H=HHV(H,10),20,0);
TJ5:=IF(C>REF(C,1),10,0);
DF:=TJ1+TJ2+TJ3+TJ4+TJ5;
VBB:=(A06 OR A07) AND A0A AND (FL2 OR FL3 OR FL4) AND DF>=60;
VAR3AA:=IF((CLOSE>REF(CLOSE,1)),88,0);
VAR4AA:=IF(((CLOSE)/(REF(CLOSE,1))>1.05) AND ((HIGH)/(CLOSE)<1.01) AND (VAR3AA>0),91,0);
VAR9:=VAR8 AND (REF(BArslAST(VAR8),1)>60 OR BARSSINCE(VAR8)=0) AND FILTER((VAR4AA>90),45) AND FILTER((VAR4AA>90),35) AND VBB;
买线:=EMA(C,2);
卖线:=EMA(SLOPE(C,21)*20+C,42);
STICKLINE(买线>=卖线,REFDATE(HHV(H,130),DATE),REFDATE(LLV(L,130),DATE),5,0),COLOR000055;
STICKLINE(买线<卖线,REFDATE(HHV(H,130),DATE),REFDATE(LLV(L,130),DATE),5,0),COLOR663300;
mtm:=C-REF(C,1);
DX:=100*EMA(EMA(MTM,7),7)/EMA(EMA(Abs(MTM),7),7);
买:=LLV(DX,3)=LLV(DX,8) AND COUNT(DX<0,2) AND crOSS(DX,MA(DX,2));
DRAWTEXT(FILTER(买=1,5) AND FILTER((VAR4AA>90),35) AND FILTER((VAR4AA>90),45),LOW,'★买'),COLORRED;
HJ_8:=(REF(CLOSE,3)-CLOSE)/REF(CLOSE,3)*100>5;
HJ_9:=FILTER(HJ_8,10);
HJ_10:=BARSLAST(HJ_9);
HJ_11:=REF(HIGH,HJ_10+2);
HJ_12:=REF(HIGH,HJ_10+1);
HJ_13:=REF(HIGH,HJ_10);
HJ_14:=MAX(HJ_11,HJ_12);
HJ_15:=MAX(HJ_14,HJ_13);
HJ_16:=(CLOSE-REF(CLOSE,1))/REF(CLOSE,1)*100>5;
HJ_17:=HJ_10<150;
HJ_18:=(OPEN-HJ_15)/HJ_15*100<30;
HJ_19:=(CLOSE-LLV(LOW,HJ_10))/LLV(LOW,HJ_10)*100<50;
HJ_20:=(CLOSE-REF(OPEN,5))/REF(OPEN,5)*100<30;
HJ_21:=VOL/MA(VOL,5)<3.5;
HJ_22:=(CLOSE-REF(CLOSE,89))/REF(CLOSE,89)*100<80;
HJ_25:=HJ_16 AND HJ_17 AND HJ_18 AND HJ_19 AND HJ_20 AND HJ_21 AND HJ_22;
暴利:=FILTER(HJ_25,15);
PL1:=(((CLOSE-MA(CLOSE,54))/MA(CLOSE,54))<0.1);
PL2:=(((CLOSE-MA(CLOSE,10))/MA(CLOSE,10))<0.3);
偏离率:=(((PL1=1) AND (PL2=1))*0.2);
平台突破:=((((偏离率=0) AND (REF(偏离率,1)=0.2)) AND (REF((COUNT((偏离率=0.2),10)=10),1)=1))*-0.1);
妖股突破:=平台突破=-0.1;
XDF:=(暴利 OR 妖股突破);
VARA:=DMA(AMOUNT/VOL/100,VOL/CAPITAL);
VARAA:=DYNAINFO(7)/(REF(CLOSE,1))>1.05 AND (DYNAINFO(7)/O>1.05);
FLIGA:=(VOL/REF(VOL,1)>1.2 AND COUNT(CLOSE>OPEN,1)) OR (LOW>REF(HIGH,1) AND COUNT(OPEN>CLOSE,1) AND VOL/REF(VOL,1)>1.2);
妖股:XDF AND C/REF(C,1)>1.095 AND FLIGA AND VARAA,NODRAW;
ZTTJ:=(CLOSE>=ZTPRICE(REF(CLOSE,1),0.1));
DRAWICON(妖股 AND NOT(REF(ZTTJ,1)),LOW,7);
DRAWTEXT(妖股 AND NOT(REF(ZTTJ,1)),LOW,'突妖'),COLORYELLOW;
DRAWTEXT_FIX(1,0.0,0.00,0,EXTERNSTR(0,1))COLOR0077FF;
N8:=STRCAT(CON2STR(YEAR,0),' 年 ');
Y8:=STRCAT(CON2STR(MONTH,0),' 月 ');
R8:=STRCAT(CON2STR(DAY,0),' 日 ');
DRAWNUMBER(ISLASTBAR ,C,C),COLORMAGENTA;
VARQ1:=(100 - ((90 * (HHV(HIGH,14) - CLOSE)) / (HHV(HIGH,14) - LLV(LOW,14))));
VARQ2:=(100 - ((90 * (HHV(HIGH,14) - CLOSE)) / (HHV(HIGH,14) - LLV(LOW,14))));
VARQ3:=(100 - MA(((100 * (HHV(HIGH,6) - CLOSE)) / (HHV(HIGH,6) - LLV(LOW,6))),34));
SJTJ:=DATE<15903019;
XQ1:=(C+L+H)/3;
XQ2:=EMA(XQ1,6);
XQ3:=EMA(XQ2,5);
SJ8:=STRCAT(STRCAT(N8,Y8), R8);
STICKLINE(XQ2>=XQ3 AND SJTJ,LOW,HIGH,0,1),COLORRED;
STICKLINE(XQ2>=XQ3 AND SJTJ,CLOSE,OPEN,3.2,2),COLORRED;
STICKLINE(XQ2<XQ3 AND SJTJ,LOW,HIGH,0,1),COLORCYAN;
STICKLINE(XQ2<XQ3 AND SJTJ,CLOSE,OPEN,3.2,2),COLORCYAN;
STICKLINE(CROSS(XQ3,XQ2) AND SJTJ,OPEN,CLOSE,3.2,0),COLORCYAN;
STICKLINE(CROSS(XQ2,XQ3) AND SJTJ,OPEN,CLOSE,3.2,0),COLORRED;
STICKLINE((CLOSE>OPEN) AND (XQ2<XQ3) AND SJTJ,CLOSE,OPEN,3.2,2)COLORCYAN;
STICKLINE((CLOSE>OPEN) AND (XQ2>=XQ3) AND SJTJ,CLOSE,OPEN,3.2,2)COLORRED;
STICKLINE((CLOSE<OPEN) AND (XQ2<XQ3) AND SJTJ,CLOSE,OPEN,3.2,0)COLORCYAN;
STICKLINE((CLOSE<OPEN) AND (XQ2>=XQ3) AND SJTJ,CLOSE,OPEN,3.2,0)COLORRED;
做空:IF(SAR(10,2,20)>=H,SAR(10,2,20),DRAWNULL),CIRCLEDOT,COLORBLUE;
做多:IF(SAR(10,2,20)<=L,SAR(10,2,20),DRAWNULL),CIRCLEDOT,COLORRED;
操盘线:=EMA(EMA(EMA(CLOSE,2),2),2);
趋势线:(MA(操盘线,5)),COLORCYAN,LINETHICK2;
IF(趋势线>REF(趋势线,1),趋势线,DRAWNULL),COLORRED,LINETHICK2;
IF(趋势线<REF(趋势线,1),趋势线,DRAWNULL),COLORGREEN,LINETHICK2;
最新价:IF(SJTJ, C,DRAWNULL),LINETHICK0,COLORYELLOW;
DRAWTEXT_FIX(C>0,0.5,0,0,SJ8),COLOR00FFFF;

2[1].jpg

 

相关文章