在线检测未来函数

通达信价格趋势指标公式

来源:Internet,编辑:股旁网,2021-10-22

VAR1:=(H+L+O+C*2)/5;
VAR2:=ema(VAR1,21);
VAR3:=stD(VAR1,23);
VAR4:=Ema(VAR1,2);
VARA:=(VAR1-VAR2)*100/VAR3;
RSV9:=(CLOSE-LLV(LOW,9))/(HHV(HIGH,9)-LLV(LOW,9))*100;
VAR22:=REF(LOW,1);
VAR33:=SMA(Abs(LOW-VAR22),3,1)/SMA(MAX(LOW-VAR22,0),3,1)*100;
VAR44:=EMA(IF(CLOSE*1.3,VAR33*10,VAR33/10),3);
VAR55:=LLV(LOW,13);
VAR66:=HHV(VAR44,13);
VAR77:=IF(MA(CLOSE,34),1,0);
VAR888:=EMA(IF(LOW<=VAR55,(VAR44+VAR66*2)/2,0),3)/618*VAR77;
VAR999:=IF(VAR888>100,100,VAR888);
bias20:=(CLOSE-MA(CLOSE,5))/MA(CLOSE,5)*100*vol;
BIAS21:=(CLOSE-MA(CLOSE,5))/MA(CLOSE,5)*100*C;
N:=9;M:=3;P:=2;
RAV:=(CLOSE-LLV(LOW,N));
RAV1:=(HHV(HIGH,N)-LLV(LOW,N));
RAV2:=RAV/RAV1;
RAV3 := (HIGH + LOW + CLOSE+REF(C,1)+O)/5;
RAV4:=RAV2*100;
RAV5:=SMA(RAV4,M,1);
RAV6:=SMA(RAV5,M,1);
RAV7:=SUM(IF(RAV3>REF(RAV3,1),RAV3*VOL,0),N)/SUM(IF(RAV3<REF(RAV3,1),RAV3*VOL,0),N);
STICKLINE(VAR999>-120,0,VAR999,2,10),COLORFF00FF;
价格:(M*RAV5-P*RAV6)*1.1,colorwhite,LINETHICK1;价格1:=(M*RAV4-P*RAV5)*1.1,colorwhite,LINETHICK1;
RSV:=(CLOSE-LLV(LOW,7))/(HHV(HIGH,7)-LLV(LOW,7))*100;
短多:SMA(RSV,3,1),colorred,LINETHICK1;
短空:SMA(短多,3,1),coloryellow,LINETHICK1;
RSV1:=(CLOSE-LLV(LOW,38))/(HHV(HIGH,38)-LLV(LOW,38))*100;
中多:SMA(RSV1,5,1),COLORFF00FF,LINETHICK1;
中空:SMA(中多,10,1),colorgreen,LINETHICK1;
多方:80,colorblue;
空方:20,colorwhite;
STICKLINE(中多>中空,中多,中空,1,0),COLORFF00FF;
STICKLINE(中多<=中空,中多,中空,1,0),colorgreen;
STICKLINE(短多>短空,短多,短空,1,0),colorred;
STICKLINE(短多<=短空,短多,短空,1,0),coloryellow;
VARF:=100-3*SMA((CLOSE-LLV(LOW,65))/(HHV(HIGH,80)-LLV(LOW,65))*100,20,1)+2*SMA(SMA((CLOSE-LLV(LOW,65))/(HHV(HIGH,80)-LLV(LOW,65))*100,20,1),15,1);
VAR19:=100-3*SMA((OPEN-LLV(LOW,65))/(HHV(HIGH,80)-LLV(LOW,65))*100,20,1)+2*SMA(SMA((OPEN-LLV(LOW,65))/(HHV(HIGH,80)-LLV(LOW,65))*100,20,1),15,1);
VAR20:=VARF<REF(VAR19,1) AND VOL>REF(VOL,1) AND CLOSE>REF(CLOSE,1);

通达信价格趋势指标公式

相关文章