在线检测未来函数

通达信趋势反转选股指标公式

来源:Internet,编辑:股旁网,2021-10-27

N:=22;
X_1:=COUNT(CLOSE>=MA(CLOSE,N),9);
X_2:=CLOSE/REF(CLOSE,3)<=0.86 AND REF(X_1,1)>=9;
X_3:=CLOSE/REF(CLOSE,1)<=0.916 AND REF(X_1,1)>=9;
X_4:=CLOSE/HIGH<=0.93 AND vol>=REF(HHV(VOL,21),1)*1.5 AND REF(X_1,1)>=9;
X_5:=COUNT(X_2>=1 OR X_3>=1 OR X_4>=1,17);
X_6:=CLOSE>=HHV(CLOSE,N) AND CLOSE>=MA(CLOSE,63) AND X_5<=0;
X_7:=CLOSE<MA(CLOSE,N) AND CLOSE<REF(CLOSE,N) AND CLOSE<MA(CLOSE,63) OR X_2>=1 OR X_4>=1;
X_8:=CLOSE<MA(CLOSE,10) AND CLOSE<REF(CLOSE,10) AND CLOSE<MA(CLOSE,10) OR X_2>=1 OR X_3>=1 OR X_4>=1;
X_9:=BArslAst(X_6>=1);
X_10:=BARSLAST(CLOSE<MA(CLOSE,63));
X_11:=BARSLAST(X_8>=1 AND REF(X_8,1)<1);
X_12:=MIN(X_10,REF(X_11,1));
X_13:=IF(COUNT(CLOSE/MA(CLOSE,63)>=1.4,MAX(X_9,X_12)+1)>=1,X_8,X_7);
X_14:=BARSLAST(X_13>=1);
多头:IF(X_9<X_14,1,(-1));

通达信趋势反转选股指标公式

相关文章