在线检测未来函数

通达信筹码轨迹指标公式

来源:Internet,编辑:股旁网,2021-11-08

本文指标含有选股公式如下:
股旁网此处内容已被隐藏,请输入验证码查看内容。
验证码:
请关注本站微信公众号,回复“1002”,获取验证码。
提示:在微信里搜索“股旁网”或者微信扫描右侧二维码。

{出击与阻力}
A1A:=(CLOSE-LLV(LOW,55))/(HHV(HIGH,55)-LLV(LOW,55))*100;
A2A:=SMA(A1A,13,1);
A3A:=SMA(A2A,13,1);
出击:(3*A2A-2*A3A),COLORRED,LINETHICK3;
阻力:(3*A3A-2*A2A),COLORGREEN,LINETHICK2;
{主流资金与非主流资金}
主流资金:EMA(100*(C-LLV(LOW,34))/(HHV(H,34)-LLV(LOW,34)),3), COLORRED,DOTLINE,LINETHICK1;
非主流资金:EMA(100*(INDEXC-LLV(INDEXL,34))/(HHV(INDEXH,34)-LLV(INDEXL,34)),3),COLORGREEN,DOTLINE,LINETHICK1;
20,POINTDOT,COLORF00FF0;
50,POINTDOT,COLORGREEN;
80,DOTLINE,COLORRED,LINETHICK1;
{主力筹码比}
获利筹码百分比:WINNER(CLOSE)*100,NODRAW,COLORLIBLUE;
平均成本¥:COst(50),NODRAW;
STICKLINE(获利筹码百分比>0,获利筹码百分比,0,1,-1),COLOR8080FF;
STICKLINE(获利筹码百分比>6,获利筹码百分比,6,1,-1),COLOR00FF00;
STICKLINE(获利筹码百分比>20,获利筹码百分比,20,1,-1),COLORFFF500;
STICKLINE(获利筹码百分比>50,获利筹码百分比,50,1,-1),COLORA76AEE;
STICKLINE(获利筹码百分比>80,获利筹码百分比,80,1,-1),COLOR0000FF;
100,COLORGREEN,LINETHICK2;
0,COLORYELLOW,LINETHICK2;
中线:15,COLORLIRED,LINETHICK2;
VAR1:=1;
VAR2:=1/WINNER(CLOSE);
VAR3:=MA(CLOSE,13);
VAR4:=100-Abs((CLOSE-VAR3)/VAR3*100);
VAR5:=LLV(LOW,75);
VAR6:=HHV(HIGH,75);
VAR7:=(VAR6-VAR5)/100;
VAR8:=SMA((CLOSE-VAR5)/VAR7,20,1);
VAR9:=SMA((OPEN-VAR5)/VAR7,20,1);
VARA:=3*VAR8-2*SMA(VAR8,15,1);
VARB:=3*VAR9-2*SMA(VAR9,15,1);
VARC:=100-VARB;
主力:=(100-VARA)*VAR1,COLORRED,LINETHICK0;
散户:MA(WINNER(CLOSE*0.95)*100,3)*VAR1,COLORWHITE,LINETHICK5;{长线筹码轨迹}
新庄: (99-IF(VAR2>5,IF(VAR2<100,VAR2,VAR4-10),0))*VAR1,COLORGREEN,LINETHICK1,POINTDOT ;
VARD:=散户>VAR4;
VARE:=REF(LOW,1)*0.9;
VARF:=LOW*0.9;
VAR10:=(VARF*vol+VARE*(CAPITAL-VOL))/CAPITAL;
VAR11:=EMA(VAR10,30);
VAR12:=CLOSE-REF(CLOSE,1);
VAR13:=MAX(VAR12,0);
VAR14:=ABS(VAR12);
VAR15:=SMA(VAR13,7,1)/SMA(VAR14,7,1)*100;
VAR16:=SMA(VAR13,13,1)/SMA(VAR14,13,1)*100;
VAR17:=BARSCOUNT(CLOSE);
VAR18:=SMA(MAX(VAR12,0),6,1)/SMA(ABS(VAR12),6,1)*100;
VAR19:=(-200)*(HHV(HIGH,60)-CLOSE)/(HHV(HIGH,60)-LLV(LOW,60))+100;
VAR1A:=(CLOSE-LLV(LOW,15))/(HHV(HIGH,15)-LLV(LOW,15))*100;
VAR1B:=SMA((SMA(VAR1A,4,1)-50)*2,3,1);
VAR1C:=(INDEXC-LLV(INDEXL,14))/(HHV(INDEXH,14)-LLV(INDEXL,14))*100;
VAR1D:=SMA(VAR1C,4,1);
VAR1E:=SMA(VAR1D,3,1);
VAR1F:=(HHV(HIGH,30)-CLOSE)/CLOSE*100;
VAR20:=VAR18<=25 AND VAR19<-95 AND VAR1F>20 AND VAR1B<-30 AND VAR1E<30 AND VAR11-CLOSE>=-0.25 AND VAR15<22 AND VAR16<28 AND VAR17>50;
STICKLINE(VARD,VAR4,散户,1,0),COLORWHITE;
STICKLINE(1,新庄,100,1,0),COLORGREEN;
STICKLINE(VAR20,0,33,5,0),COLORYELLOW,LINETHICK3 ;
DRAWTEXT(VAR20 AND NOT(REF(VAR20,1)),42,'跟庄买'),COLORYELLOW;

通达信筹码轨迹指标公式

相关文章