在线检测未来函数

通达信手到擒来主图指标公式

来源:Internet,编辑:股旁网,2021-11-09

本文指标含有选股公式如下:
股旁网此处内容已被隐藏,请输入验证码查看内容。
验证码:
请关注本站微信公众号,回复“1002”,获取验证码。
提示:在微信里搜索“股旁网”或者微信扫描右侧二维码。

流通市值:(FINANCE(40)/100000000),NODRAW,COLORYELLOW;
庄压:=HHV(MA(H,13),13),COLORYELLOW;
赢在龙头:=(L+H+C*4)/6;
工作:=EMA(赢在龙头,12),COLOR00FF00;
度假:=EMA(赢在龙头,19);
赢在:=(工作-REF(工作,1))/REF(工作,1)*100;
龙头:=(度假-REF(度假,1))/REF(度假,1)*100;
G:=BArslAst(crOSS(赢在,0));
雪:REF(赢在龙头,G)*1,COLORAacC66,LINETHICK2;
B2:=SMA(SMA(SMA(C,2,1),2,1),2,1);
SMA2:=MA(B2,3);
停损下限:=IF(LLV(MA(B2,8),3)<B2,LLV(MA(B2,8),3),B2);
米:IF(B2>SMA2,B2,DRAWNULL),COLORRED,LINETHICK3;
饼干:HHV(MA(B2,1),13),COLOR00AAFF,LINETHICK1;
VAR1A:=(2*CLOSE+HIGH+LOW)/4;
VAR2A:=MA(VAR1A,7);
VAR3A:=VAR2A-MA(VAR1A,7/2)<0;
VAR4A:=VAR2A-MA(VAR1A,7/2)>0;
VAR5A:=BARSLAST(VAR3A);
VAR6A:=0-BARSLAST(VAR4A);
VAR7A:=IF(VAR3A<=0,VAR5A,VAR6A);
STICKLINE(饼干>B2 AND B2>SMA2,饼干,B2,0,-1),COLORBLUE,LINETHICK4;
STICKLINE(饼干>SMA2 AND B2<SMA2,饼干,SMA2,0,-1),COLORBLUE,LINETHICK4;
突破:=REF(EMA(C,14),1)COLORMAGENTA,LINETHICK1;
A1X:=(EMA(C,14)-突破)/突破*100,NODRAW;
出击:=IF(A1X>=0,REF(EMA(C,14),BARSLAST(CROSS(A1X,0))+1),DRAWNULL)COLORRED,LINETHICK1;
休假:=IF(A1X<0,REF(EMA(C,14),BARSLAST(CROSS(0,A1X))+1),DRAWNULL)COLORGREEN,LINETHICK2;
STICKLINE(A1X>=0,出击,突破,0,-1)COLORRED;
DRAWTEXT_FIX(C>O,0.01,0.9,0,''),COLORRED;
VAR177:=(2*CLOSE+HIGH+LOW)/4;
VAR277:=LLV(LOW,5);
VAR377:=HHV(HIGH,5);
VAR477:=EMA((VAR177-VAR277)/(VAR377-VAR277)*100,5);
MA177:=MA(VAR477,2);
XXX:=STICKLINE(FILTER(VAR477>MA177 AND REF(VAR477,1)<30,5),O,C,3,1),COLORWHITE;
DRAWTEXT_FIX(1,0.980,20,1,''),COLOR666666;
{大机构进场}
A0:=(3*C+L+O+H)/6;
X:=(20*A0+19*REF(A0,1)+18*REF(A0,2)+17*REF(A0,3)+16*REF(A0,4)+15*REF(A0,5)+
14*REF(A0,6)+13*REF(A0,7)+12*REF(A0,8)+11*REF(A0,9)+10*REF(A0,10)+9*REF(A0,11)+8*REF(A0,12)
+7*REF(A0,13)+6*REF(A0,14)+5*REF(A0,15)+4*REF(A0,16)+3*REF(A0,17)+2*REF(A0,18)+
REF(A0,20))/210;
mtm:=C-REF(C,1);
DX:=100*EMA(EMA(MTM,6),6)/EMA(EMA(Abs(MTM),6),6);
CB2:=EMA(X,13);
卖:=IF(HHV(DX,2)=HHV(DX,7) AND COUNT(DX>50,2) AND CROSS(MA(DX,2),DX),1,0);
DRAWTEXT(FILTER(卖=1,1),HIGH*1.02,'跑'),COLORWHITE;
买1:=IF(LLV(DX,2)=LLV(DX,7) AND COUNT(DX<0,2) AND CROSS(DX,MA(DX,2)),1,0);
DRAWTEXT(FILTER(买1=1,5),LOW*0.97,'★'),COLORYELLOW;
STICKLINE(C<0.905*REF(C,1),C,O,2.5,0),COLORGREEN;
DRAWICON(FILTER(VAR477>MA177 AND REF(VAR477,1)<30,5),L,9);
LC20:=REF(CLOSE,1);
rsi20:=SMA(MAX(CLOSE-LC20,0),4.1,1)/SMA(ABS(CLOSE-LC20),4.1,1)*100,NODRAW;
DRAWTEXT(CROSS(RSI20,11)*1,
L*0.99,'超跌'),COLORGREEN;
散户:= EMA(((2*CLOSE+HIGH+LOW)/4-LLV(LOW,5))/(HHV(HIGH,4)-LLV(LOW,5))*100,4);
庄家:= EMA(0.667*REF(散户,1)+0.333*散户,2);
DRAWTEXT(CROSS("kdj.J"(27,3,3),0.0001),L*0.989, ' 可以买'),COLOR00FFEE;
{彩色k线}
F33:=100*(C-REF(C,1))/REF(C,1);
今小昨:=IF(C<REF(O,1) AND F33<0,1,0);
P133:=今小昨;
今小前:=IF(C<REF(O,2) AND F33<0,1,0);
P233:=今小前;
STICKLINE(P133=0 AND REF(P133,1)=1 AND P233=0 AND REF(P233,1)=1,O,C,2.5,00),COLORYELLOW;
AA:=REF(CLOSE,1);
BBB:=SMA(MAX(CLOSE-AA,0),5,1)/SMA(ABS(CLOSE-AA),5,1)*1000;
HHH:=BBB-LLV(BBB,10);
SS:=(MA(HHH,2)*3+HHH*13)/16;
M18:=5;
M28:=10;
M38:=20;
M48:=60;
DRAWGBK(C>0,RGB(0,10,10),RGB(88,0,0),0,'0',0);
DRAWGBK(C>0,RGB(40,120,20),RGB(00,00,00),0,'0',1);
DRAWGBK(C>0,RGB(80,100,120),RGB(00,00,00),0,'0',1);
MA18:MA(CLOSE,M18);
MA28:MA(CLOSE,M28);
MA38:MA(CLOSE,M38);
MA48:MA(CLOSE,M48);
BM:=EMA(C,2);
SM:=EMA(SLOPE(C,21)*20+C,42);
BU:=CROSS(BM,SM);
SEL:=CROSS(SM,BM);
DRAWICON(BU,L-0.05,1);
DRAWICON(SEL,H+0.03,2);
STICKLINE(BM>=SM,LOW,HIGH,0,1),COLORRED;
STICKLINE(BM>=SM,CLOSE,OPEN,3,1),COLORRED;
STICKLINE(BM<SM,LOW,HIGH,0,1),COLORCYAN;
STICKLINE(BM<SM,CLOSE,OPEN,3,1),COLORCYAN;
Z1:=STRCAT(HYBLOCK,' ');
Z2:=STRCAT(Z1,DYBLOCK);
Z3:=STRCAT(Z2,' ');
所属板块:=STRCAT('【所属板块】',STRCAT(STRCAT(STRCAT('【行业】',HYBLOCK),STRCAT('【地区】',DYBLOCK)),STRCAT('【概念】',GNBLOCK)));
DRAWTEXT_FIX(ISLASTBAR,0.00,0.0,0,所属板块),COLORYELLOW;
筹码盈利:=STRCAT(STRCAT('筹码盈利:',CON2STR(WINNER(DYNAINFO(7))*100,1)),'%');
DRAWTEXT_FIX(1,0,0.16,0,筹码盈利),COLORYELLOW;
ZT:=C>REF(C,1)*1.090 AND C<REF(C,1)*1.105;
DT:=C<REF(C,1)*0.901 AND C>REF(C,1)*0.898;
STICKLINE(ZT,C,O,4,0),COLORYELLOW;
STICKLINE(DT,C,O,4,0),COLORGREEN;
{有庄控盘}
VAW1:=EMA(EMA(CLOSE,13),13);
控盘:=(VAW1-REF(VAW1,1))/REF(VAW1,1)*1000;
无庄控盘:=控盘<0;
有庄控盘:=控盘>REF(控盘,1) AND 控盘>0;
{分时价格原码}
JJ:=DYNAINFO(11);
{波段买卖原码}
P:=21;S:=8;M1:=3;
财:=(EMA(CLOSE,S)-EMA(CLOSE,P))*50;
神:=EMA(财,M1);
{股价均线偏离买卖条件}
BTJ1:=(C-JJ)/JJ<-0.03;
BTJ11:=(C-JJ)/JJ<-0.03;
BTJ12:=LAST(JJ>=REF(JJ,1),5,1) AND (C-JJ)/JJ<0.005;
STJ1:=(C-JJ)/JJ>0.005;
{控盘买卖条件}
STJ01:=控盘<REF(控盘,1) AND 控盘>0.5;
STJ02:=控盘>0;
BTJ2:=控盘>REF(控盘,1) AND 控盘<-0.2;
BTJ22:=控盘>REF(控盘,1) AND 控盘<0 ;
{波段买卖条件}
BTJ3:=CROSS(财,神) AND 财<-0.3;
BTJ32:=CROSS(财,神) AND 财<-0.1;
STJ31:=CROSS(神,财);
STJ32:=CROSS(神,财) AND 财>1.618;
{以下为信号};
BTJ81:=FILTER(BTJ1 AND BTJ2 AND BTJ3,13);
BTJ811:=FILTER(BTJ11 AND BTJ2 AND BTJ3,13);
BTJ82:=FILTER(BTJ12 AND BTJ22 AND BTJ32,13);
STJ81:=FILTER(STJ1 AND STJ01 AND STJ31,13);
STJ82:=FILTER(STJ02 AND STJ32 ,13);
STJ83:=STJ81 AND STJ82;
DRAWTEXT(STJ83,H*1.002,'↓快跑'),COLORGREEN;
DRAWICON(STJ83,H+0.003,24);
庄:= BTJ11 AND BTJ2 AND BTJ3;
有庄:=FILTER(庄,30);
DRAWTEXT(有庄,L-0.0011,'↖庄进'),COLORYELLOW;
DRAWICON(有庄,L*0.999,23);
MA5:MA(CLOSE,5),COLORWHITE;
MA10:MA(CLOSE,10),COLORYELLOW;
MA20:MA(CLOSE,20),COLORMAGENTA,LINETHICK2;
MA30:MA(CLOSE,30),COLORGREEN;
MA60:MA(CLOSE,60),COLORLIGRAY;
AA1:=(C-REF(C,1))/REF(C,1)>=0.058  AND (C-REF(C,1))/REF(C,1)<0.095 ;
AA2:=(C-REF(C,1))/REF(C,1)>=0.098 ;
{STICKLINE(AA1,O,C,0,1 ),COLOR9B37FF;
STICKLINE(AA1,OPEN,CLOSE,3,0 ),COLOR6300C6;
STICKLINE(AA1,OPEN,CLOSE,2.7,0 ),COLOR6D00DB;
STICKLINE(AA1,OPEN,CLOSE,2.1,0 ),COLOR7800F0;
STICKLINE(AA1,OPEN,CLOSE,1.5,0 ),COLOR8000FF;
STICKLINE(AA1,OPEN,CLOSE,0.9,0 ),COLOR8F20FF;
STICKLINE(AA1,OPEN,CLOSE,0.3,0 ),COLOR9B37FF;
STICKLINE(AA2,C,O,3,0 ),COLOR00AAFF;
STICKLINE(AA2,C,O,2.1,0 ),COLOR00BBFF;
STICKLINE(AA2,C,O,1.5,0 ),COLOR00CCFF;
STICKLINE(AA2,C,O,1,0 ),COLOR00ddfF;
STICKLINE(AA2,C,O,0.6,0 ),COLOR00EEFF;
STICKLINE(AA2,C,O,0.2,0 ),COLOR00FFFF;
DRAWICON( AA2,L*0.98,1);}
{MA(CLOSE,5),COLORWHITE;
MA(CLOSE,10),COLORYELLOW;
MA(CLOSE,20),COLORRED;
MA(CLOSE,60),COLORBLUE;}
MA54:=MA(CLOSE,54);
MA120:MA(CLOSE,120),COLORBLUE;
STICKLINE(C/REF(C,1)>=1.096 AND H=C,O,C,2,0),COLORYELLOW;
HJ_8:=(REF(CLOSE,3)-CLOSE)/REF(CLOSE,3)*100>5;
HJ_9:=FILTER(HJ_8,10);
HJ_10:=BARSLAST(HJ_9);
HJ_11:=REF(HIGH,HJ_10+2);
HJ_12:=REF(HIGH,HJ_10+1);
HJ_13:=REF(HIGH,HJ_10);
HJ_14:=MAX(HJ_11,HJ_12);
HJ_15:=MAX(HJ_14,HJ_13);
HJ_16:=(CLOSE-REF(CLOSE,1))/REF(CLOSE,1)*100>5;
HJ_17:=HJ_10<150;
HJ_18:=(OPEN-HJ_15)/HJ_15*100<30;
HJ_19:=(CLOSE-LLV(LOW,HJ_10))/LLV(LOW,HJ_10)*100<50;
HJ_20:=(CLOSE-REF(OPEN,5))/REF(OPEN,5)*100<30;
HJ_21:=vol/MA(VOL,5)<3.5;
HJ_22:=(CLOSE-REF(CLOSE,89))/REF(CLOSE,89)*100<80;
HJ_25:=HJ_16 AND HJ_17 AND HJ_18 AND HJ_19 AND HJ_20 AND HJ_21 AND HJ_22;
暴利:=FILTER(HJ_25,15);
PL1:=(((CLOSE-MA54)/MA54)<0.1);
PL2:=(((CLOSE-MA10)/MA10)<0.3);
偏离率:=(((PL1=1) AND (PL2=1))*0.2);
平台突破:=((((偏离率=0) AND (REF(偏离率,1)=0.2)) AND (REF((COUNT((偏离率=0.2),10)=10),1)=1))*-0.1);
妖股突破:=平台突破=-0.1;
XDF:=(暴利 OR 妖股突破);
VARA:=DMA(AMOUNT/VOL/100,VOL/CAPITAL);
VARAA:=DYNAINFO(7)/(REF(CLOSE,1))>1.05 AND (DYNAINFO(7)/O>1.05);
FLIGA:=(VOL/REF(VOL,1)>1.2 AND COUNT(CLOSE>OPEN,1)) OR (LOW>REF(HIGH,1) AND COUNT(OPEN>CLOSE,1) AND VOL/REF(VOL,1)>1.2);
妖股:=XDF AND C/REF(C,1)>1.095 AND FLIGA AND VARAA,NODRAW;
DRAWICON(妖股,LOW*0.995,7);
DRAWTEXT(妖股,LOW*0.975,' 妖股'),COLORYELLOW;
{龙头主图}
AA8:=((CLOSE/REF(CLOSE,1))>=1.099);
CB:=(VOL/REF(VOL,1));
关注:=IF((((CLOSE/REF(CLOSE,1))>=1.07) AND (CB<1)),1,0),LINETHICK0,NODRAW;
龙头第一买点:=IF((AA8 AND (CB<1)),1,0);
龙头第二买点:=IF((((CLOSE/REF(CLOSE,1))>=1.07)AND (CB<1)),1,0);
DRAWTEXT((龙头第二买点=1),(REF(LOW,1)*1.1),'↖龙头'),COLOR00FFFF;
{伏击涨停}
{T1:=MA(C,21)>REF(MA(C,21),1);
T2:=EXIST(C>REF(C,1)*1.093,21);
T3:=C<O AND C<REF(C,1) AND EVERY(MA(C,5)<REF(MA(C,5),1),3);
T5:=EVERY(V<REF(V,1),2) AND EVERY(V<MA(V,5),2);
T6:=MA(C,5)>MA(C,21);
DRAWTEXT(T1 AND T2 AND T3 AND T5 AND T6,L,'↖伏击涨停');}
走强线:EMA(COST(99),181),COLORYELLOW,LINETHICK2;

通达信手到擒来主图指标公式

相关文章