在线检测未来函数

通达信量价转强启动指标公式

来源:Internet,编辑:股旁网,2021-11-24

{买入启动牛股}
AA05:=ma(C,5),COLOR0099CC;五日乖离率:=(C-AA05)/AA05*100;
BB05:=ATAN((AA05/REF(AA05,1)-1)*100)*180/3.1416;
速度5:=SMA(ema((AA05-REF(AA05,1))/REF(AA05,1),3)*100,3,1);
加速度5:=EMA((速度5-REF(速度5,1)),3);
AA10:=MA(C,10),COLOR00FF00;AA20:=MA(C,20);BB10:=ATAN((AA10/REF(AA10,1)-1)*100)*180/3.1416;
AA30:=MA(C,30);
三拾日乖离率:=(C-AA30)/AA30*100;
{VAR1:=(AA20-AA30)>REF((AA20-AA30),1) AND AA20>REF(AA20,1) AND AA30>REF(AA30,1);
VAR2:=(AA30-AA20)<REF((AA30-AA20),1) AND AA20<REF(AA20,1) AND AA30<REF(AA30,1);}
BB30:=ATAN((AA30/REF(AA30,1)-1)*100)*180/3.1416;
强势狙击:=FILTER(BB30>30 AND BB10>45 AND crOSS(BB05,60),10);
加仓:=FILTER(COUNT(CROSS(BB05,30),5)>=1 AND AA05>REF(AA05,1) AND 三拾日乖离率>REF(三拾日乖离率,1) AND AA10>REF(AA10,1) AND 加速度5>REF(加速度5,1) AND 速度5>REF(速度5,1) ,10) ;
清仓:=FILTER(COUNT(CROSS(30,BB05),5)>=1 AND (C>AA30 OR O>AA30) AND AA05<REF(AA05,1) AND 三拾日乖离率<REF(三拾日乖离率,1) AND AA10<REF(AA10,1),10);
JC:=CROSS(0,五日乖离率) AND 三拾日乖离率<REF(三拾日乖离率,1) AND AA10>REF(AA10,1) ;
减仓:=FILTER(JC,10);
MR:=COUNT(CROSS(五日乖离率,0),3)>=1 AND 三拾日乖离率>REF(三拾日乖离率,1) AND AA05>REF(AA05,1) AND (C/REF(C,1)-1)*100>5 AND REF(C,1)<AA30;
买入:=FILTER(MR,10);
{DRAWTEXT(减仓,HIGH*1.02,'←减仓'),COLORCYAN;
DRAWTEXT(清仓 ,HIGH*1.02,'←清仓'),COLORGREEN;}
{量能}
volUME:=VOL,VOLstICK;
AA:=VOL>REF(V,1)*1.9;{倍量}
{AA1:=VOL<REF(LLV(VOL,13),1);}
AA1:=V/REF(V,1)<=0.6;{缩倍量}
{STICKLINE(AA,0,VOLUME,2,0),COLORYELLOW;
STICKLINE(AA1,0,VOLUME,2,0),COLOR1D7300;}
TOTAL:=IF(PERIOD=1,5,IF(PERIOD=2,15,IF(PERIOD=3,30,IF(PERIOD=4,60,IF(PERIOD=5,TOTALFZNUM,1)))));
MTIME:=MOD(FROMOPEN,TOTAL);
CTIME:=IF(MTIME<0.5。,TOTAL,MTIME);
VVOL:=IF(CURRBARSCOUNT=1,AMOUNT/100000000*TOTAL/CTIME,DRAWNULL),NODRAW;
额:=AMOUNT/100000000,VOLSTICK;{COLORFF00FF}
MAVOL1:=EMA((EMA(额,2)+EMA(额,3))/2,1);
MAVOL2:=EMA(EMA(额,8),1);
AMO135:=MA(AMO/100000000,135),COLORGREEN;
VAR1:=AMOUNT/((HIGH-LOW)*2-Abs(CLOSE-OPEN));
流入亿:=IF(CLOSE>OPEN,VAR1*(HIGH-LOW),IF(CLOSE<OPEN,VAR1*((HIGH-OPEN)+(CLOSE-LOW)),AMOUNT/2))/100000000,COLORRED,NODRAW;
流出亿:=IF(CLOSE>OPEN,0-VAR1*((HIGH-CLOSE)+(OPEN- LOW)),IF(CLOSE<OPEN,0-VAR1*(HIGH-LOW),0-AMOUNT/2))/100000000,COLORMAGENTA,NODRAW;
差亿:=流入亿+流出亿,COLORRED,NODRAW;
净:=EMA(EMA(差亿,2),2),COLOR00FFFF,NODRAW;
净1:=EMA((EMA(净,2)+EMA(净,3))/2,1);{EMA(净,2);}
流:=EMA(净1,8);
净流:=EMA(净1+流,3)*1.23,COLORLIRED;{原3*/1.23*}
GJJ:=EMA(净流,8);
LLJX:=EMA((EMA(净流,2)+EMA(净流,3))/2,1);
流量基线:=GJJ,COLORYELLOW,LINETHICK2;
流量:=LLJX,COLORWHITE,LINETHICK2;
净流量:=净流,COLORMAGENTA,LINETHICK2;
流量上穿:=BETWEEN(BArslASTCOUNT(流量>流量基线),1,2);
资金净流上穿:=BETWEEN(BARSLASTCOUNT(净流量>流量),1,2);
成交量上穿:=BETWEEN(BARSLASTCOUNT(MAVOL1>MAVOL2),1,2);
{主力监控 筹码}
EEDDS5:=EMA(EMA(CLOSE,9),9);
主力监控:=(EEDDS5-REF(EEDDS5,1))/REF(EEDDS5,1);
选股:=CROSS(主力监控,0);
EEDDS1:=IF(好选股,1,0),LINETHICK1,COLORRED;
EEDDS2:=IF(主力监控>REF(主力监控,1) AND 主力监控>0,主力监控,0),COLORRED,NODRAW;
EEDDS4:=100*WINNER(CLOSE*0.95);
{STICKLINE(EEDDS4>50 AND COST(85)<CLOSE AND 主力监控>0,主力监控,0,1,0),COLORMAGENTA;
EEDDS3:IF(EEDDS4>50 AND COST(85)<CLOSE AND 主力监控>0,主力监控,0),COLORFF00FF,NODRAW;}
变强:=主力监控>REF(主力监控,1) AND 主力监控>0;
集中:=EEDDS4>50 AND COST(85)<CLOSE AND 主力监控>0;
M:=macd.MacD(12,26,9),NODRAW;
B:=C/REF(C,1)>1.098;
A:=V/REF(V,1)>2 AND V/MA(V,60)>2;
启动:=CROSS(M,0) AND B AND A,COLORRED;
J:=REF(H,BARSLAST(启动)),NODRAW;
选股:=CROSS(C,J);
转强:((加仓 OR 强势狙击) AND 变强)*2,COLORYELLOW;
筹码强势:((加仓 OR 强势狙击) AND 集中)*2,COLORMAGENTA;
量能确立:((加仓 OR 强势狙击) AND (资金净流上穿 AND 成交量上穿))*3,COLORRED;
量价启动:((启动 OR 选股) AND (变强 OR 集中))*4,COLORLIMAGENTA;
XG买入牛股:加仓 AND (资金净流上穿 OR 成交量上穿 OR 流量上穿);
XG再次启动:强势狙击 AND (资金净流上穿 OR 成交量上穿 OR 流量上穿);

通达信量价转强启动指标公式

相关文章