在线检测未来函数

通达信KDJ超牛预判指标公式

来源:Internet,编辑:股旁网,2022-01-14

本文指标含有选股公式如下:
股旁网此处内容已被隐藏,请输入验证码查看内容。
验证码:
请关注本站微信公众号,回复“1002”,获取验证码。
提示:在微信里搜索“股旁网”或者微信扫描右侧二维码。

N:=9;
P1:=3;
P2:=3;
RSV:=(CLOSE-LLV(LOW,N))/(HHV(HIGH,N)-LLV(LOW,N))*100;
K:SMA(RSV,P1,1),COLORCYAN;
D:SMA(K,P2,1),COLOR00DD00;
J:3*K-2*D,COLORRED;
周K:="kdj.K#WEEK"(9,3,2);
周D:="kdJ.D#WEEK"(9,3,2);
周J:="KDJ.J#WEEK"(9,3,2);
周金叉:=crOSS(周K,周D);
金叉:=FILTER(CROSS(K,D) AND K<20,4);
DRAWTEXT(周金叉,D,'★'),COLORYELLOW;
DRAWTEXT(周金叉,D*0.93,'周金叉'),COLORYELLOW;
DRAWTEXT(CROSS(周D,周K),D*0.95,'周死叉'),COLOR00DDBB;
DRAWICON(日金叉,K,1);
DRAWTEXT(日金叉,D,'低金'),COLOR00CCCC;
KDB:=BArslAst(REF(CROSS(K,D),1));
KDDB:=REF(CLOSE,KDB+1)>CLOSE AND REF(K,KDB+1)<K AND CROSS(K,D);
K底背:=IF(FILTER(KDDB>0,5),1,0);
DRAWTEXT(K底背=1,D*0.98,'底背'),COLORRED;
KDD:=BARSLAST(REF(CROSS(D,K),1));
K顶背:=REF(CLOSE,KDD+1)<CLOSE AND REF(K,KDD+1)>K AND CROSS(D,K);
DRAWTEXT(FILTER(K顶背>0,5),D+8,'顶背'),COLORFFAA22;
T1:=REF(J,1)-REF(J,2)<0 AND J>REF(J,1)-0.7 AND J-REF(J,1)>REF(J,1)-REF(J,2);
T2:=REF(J,1)-REF(J,2)>0 AND J>REF(J,1);
T:=T1 OR T2;
IF(T=1,J,DRAWNULL),COLORMAGENTA,LINETHICK2;
IF(T=0,J,DRAWNULL),COLORWHITE,LINETHICK2;
K预判:((KDJ.K)*(2/3))+((CLOSE-LLV(LOW,9))/(HHV(HIGH,9)-LLV(LOW,9))*100)*(1/3),COLORRED,NODRAW;
D预判:((KDJ.D)*(2/3))+(SMA(RSV,3,1))*(1/3),COLORRED,NODRAW;
JC1:=CROSS(D,K),NODRAW;JC2:=CROSS(K,D),NODRAW;
交叉天数:SUMBARS(JC1 OR JC2,1),NODRAW;
DRAWICON(CROSS(K,D),K,1);
DRAWICON(CROSS(D,K),K,2);
DRAWICON(CROSS(D,K),K*1,2);
DRAWICON(CROSS(K,D),K*1,1);
KD的开口:IF(K-D<>0,K-D,0),NODRAW,COLORRED;
月的乖离:(CLOSE-MA(CLOSE,20))/MA(CLOSE,20)*100,COLORRED,NODRAW;
季的乖离:(CLOSE-MA(CLOSE,60))/MA(CLOSE,60)*100,COLORRED,NODRAW;
量比:V/REF(MA(V,5),1),NODRAW,COLORRED;
换手:vol/CAPITAL*100,NODRAW,COLORLIRED;
wr:100*(HHV(HIGH,42)-CLOSE)/(HHV(HIGH,42)-LLV(LOW,42))LINETHICK2,COLOR333333;
50,DOTLINE;

通达信KDJ超牛预判指标公式

相关文章