在线检测未来函数

通达信博弈成交量指标公式

来源:Internet,编辑:股旁网,2022-04-26

{使用说明:1.成交量大于三线持股;2.成交量大于中长线,小于短线,且短线向下,小心;3.成交量小于三线持币。}

万:vol/10000,LINETHICK0;
AA:=IF(CURRBARSCOUNT=1 AND PERIOD=5,VOL*240/FROMOPEN,DRAWNULL);
预测:AA/10000;
BB:=VOL/((HIGH-LOW)*2-Abs(CLOSE-OPEN));
主动买:=IF(CLOSE>OPEN,BB*(HIGH-LOW),IF(CLOSE<OPEN,BB*((HIGH-OPEN)+(CLOSE-LOW)),VOL/2));
主买:主动买/10000,COLORRED;
主动卖:=IF(CLOSE>OPEN,0-BB*((HIGH-CLOSE)+(OPEN-LOW)),IF(CLOSE<OPEN,0-BB*(HIGH-LOW),0-VOL/2));
主卖:-主动卖/10000,COLORLIBLUE;
主力净买:(主动买+主动卖)/10000,COLORmaGENTA;
持币:IF(SAR(10,2,20)>=H,sar(10,2,20),DRAWNULL),CIRCLEDOT,COLORBLUE;
持股:IF(SAR(10,2,20)<=L,SAR(10,2,20),DRAWNULL),CIRCLEDOT,COLORRED;
上涨家:INDEXADV,COLOR0080FF,NODRAW;
下跌家:INDEXDEC,COLORGREEN,NODRAW;
涨停:DYNAINFO(3)*1.1,COLORRED,NODRAW;
跌停:DYNAINFO(3)*0.9,COLORGREEN,NODRAW;
stICKLINE(CLOSE=REF(CLOSE,1),0,VOL,3.5,0),COLORWHITE;
STICKLINE(CLOSE>REF(CLOSE,1),0,VOL,3.5,0),COLORRED;
STICKLINE(CLOSE<REF(CLOSE,1),0,VOL,3.5,0),COLORGREEN;
STICKLINE(CURRBARSCOUNT=1 AND PERIOD=5,AA,1 , 3.5 , 0 ) , COLOR00FFFF ;
STICKLINE(CURRBARSCOUNT=1 AND PERIOD=5,AA,1 , 3.2 , 0 ) , COLOR007777 ;
STICKLINE(CURRBARSCOUNT=1 AND PERIOD=5,AA,1 , 2.7 , 0 ) , COLOR009999 ;
STICKLINE(CURRBARSCOUNT=1 AND PERIOD=5,AA,1 , 2.1 , 0 ) , COLOR00BBBB ;
STICKLINE(CURRBARSCOUNT=1 AND PERIOD=5,AA,1 , 1.5 , 0 ) , COLOR00ddeE ;
STICKLINE(CURRBARSCOUNT=1 AND PERIOD=5,AA,1 , 0.9 , 0 ) , COLOR66FFFF ;
STICKLINE(CURRBARSCOUNT=1 AND PERIOD=5,AA,1 , 0.2 , 0 ) , COLORFFFFFF ;
STICKLINE(主动买>=0,VOL,-主动卖,3.2,0),COLOR000033;
STICKLINE(主动买>=0,VOL,-主动卖,2.7,0),COLOR000066;
STICKLINE(主动买>=0,VOL,-主动卖,2.1,0),COLOR000099;
STICKLINE(主动买>=0,VOL,-主动卖,1.5,0),COLOR0000CC;
STICKLINE(主动买>=0,VOL,-主动卖,0.9,0),COLOR0000FF;
STICKLINE(主动买>=0,VOL,-主动卖,0.2,0),COLORCC66FF;
STICKLINE(主动卖<=0,0,-主动卖,3.2,0),COLOR990000;
STICKLINE(主动卖<=0,0,-主动卖,2.7,0),COLORCC0000;
STICKLINE(主动卖<=0,0,-主动卖,2.1,0),COLORFF4400;
STICKLINE(主动卖<=0,0,-主动卖,1.5,0),COLORFF8800;
STICKLINE(主动卖<=0,0,-主动卖,0.9,0),COLORFFCC00;
STICKLINE(主动卖<=0,0,-主动卖,0.2,0),COLORCYAN;
AA01:=VOL>REF(V,1)*1.9;
STICKLINE(AA01,0,V,0.5,0),COLORYELLOW;
五日:=MA(V,5),COLOR40FF00,LINETHICK2;
三五日:= MA(V,35),COLORYELLOW;
一三五日:=MA(V,135),COLOR0080FF;
NOTEXT强:=IF(五日>MA(五日,2),五日,DRAWNULL),COLORRED,LINETHICK2;
N:=IF(TOTALBARSCOUNT>=120,120,TOTALBARSCOUNT);
HH0:=HHV(H,N);
LL0:=LLV(L,N);
MM0:=CONST((HH0+LL0)*0.5);
S01:=CONST(IF(REF(C,N-15)>MM0,1.00,-0.08));
S02:=CONST(IF(REF(C,N-15)>MM0,-1,1));
S1:=IF(FINDSTR(EXTERNSTR(0,13),'万元'),S01+(0.08*S02),S01),NODRAW;
S2:=IF(FINDSTR(EXTERNSTR(0,12),'。'),S1+(0.08*S02),S1),NODRAW;
S3:=IF(FINDSTR(EXTERNSTR(0,8),'公告'),S2+(0.08*S02),S2),NODRAW;
S4:=IF(FINDSTR(EXTERNSTR(0,10),','),S3+(0.08*S02),S3);
S5:=IF(FINDSTR(EXTERNSTR(0,15),'-'),S4+(0.08*S02),S4);
S6:=IF(FINDSTR(EXTERNSTR(0,1),','),S5+(0.08*S02),S5);
S7:=IF(FINDSTR(EXTERNSTR(0,14),'-'),S6+(0.08*S02),S6);
S8:=IF(FINDSTR(EXTERNSTR(0,11),'-'),S7+(0.08*S02),S7);
S9:=IF(FINDSTR(EXTERNSTR(0,9),'-'),S8+(0.08*S02),S8);
K:=IF(S1<=0,0.05,IF(S1>=0,-0.05,0));
量_价:=1;
CTKG:=1;
W:=量_价;
EPSL:=0.0001;
ZZ:=(C+H+L)/3;
TJA:=ZZ>=MAX(C,O) AND CTKG=1;
TJB:=ZZ<=MIN(C,O) AND CTKG=1;
ZF:=IF(TJA,1,IF(TJB,-1,0));
TJ0:=TJA OR TJB;
TJ1:=H=L AND C>REF(C,1);
TJ2:=H=L AND C<REF(C,1);
TJ3:=H=L AND C=REF(C,1);
量_价:=IF(W=1,VOL,AMOUNT),STICK,COLOREEFFEE;
EE:=IF(TJ1,EPSL,IF(TJ2,-EPSL,0));
ZL:=2*(H-L)+ABS(C-O)+3*IF(TJ3,EPSL,ABS(EE));
JGL_DX:=(IF(TJ0,2/3*(2*C-H-L)+ZF*ABS(C-O),(C-O))+EE)/ZL;
买卖差:=JGL_DX*量_价,COLOR13AADD,NODRAW;
DX%:JGL_DX*100,NODRAW,COLORGREEN,LINETHICK0;
DX连红:BArslASTCOUNT(DX%>0),COLORRED,NODRAW,LINETHICK0;
买盘:=量_价*(1+JGL_DX)/2,COLOR1133AA,NODRAW;
卖盘:=量_价*(1-JGL_DX)/2,COLORFFFF00,NODRAW;
VAR11:=VOL/((HIGH-LOW)*2-ABS(CLOSE-OPEN));
ddx:=买盘-卖盘;
MADDX:=MA(DDX,5)*15;
DDX1:SMA(MADDX,3,1),COLORRED,LINETHICK1;
DDX2:SMA(DDX1,3,1),COLORGREEN,LINETHICK1;
DDX3:SMA(DDX2,3,1),COLORYELLOW,LINETHICK1;

通达信博弈成交量指标公式

相关文章