在线检测未来函数

通达信版面简洁操盘主图指标公式

来源:Internet,编辑:股旁网,2022-07-21

本文指标含有选股公式如下:
股旁网此处内容已被隐藏,请输入验证码查看内容。
验证码:
请关注本站微信公众号,回复“1009”,获取验证码。
提示:在微信里搜索“股旁网”或者微信扫描右侧二维码。

ma1:EMA(CLOSE,5),COLORWHITE,NODRAW;
MA2:(EMA(CLOSE,18)+EMA(CLOSE,21)+EMA(CLOSE,24))/3,COLORFF00FF;
MA3:(EMA(CLOSE,80)+EMA(CLOSE,90)+EMA(CLOSE,100))/3,COLORGREEN;
散户成本线:IF(PERIOD=5,(COst(30)+COST(40)+COST(50)+COST(60)+COST(70))/5,DRAWNULL),COLORYELLOW,DOTLINE;
乖离5:(C-MA(C,5))/C*100,COLORWHITE,NODRAW;
乖离10:(C-MA(C,10))/C*100,COLORYELLOW,NODRAW;
乖离20:(C-MA(C,20))/C*100,COLORFF00FF,NODRAW;
近10天最大涨10:HHV((H/LLV(L,10)-1)*100,10),COLORYELLOW,NODRAW;
近10天最大跌10:LLV((L/REF(HHV(H,10),1)-1)*100,10),COLORGREEN,NODRAW;
近一年涨停数:COUNT((C/REF(C,1))>=1.0985 AND C=H,250),COLORYELLOW,NODRAW;
年初至今涨幅:(C/REF(C,BArslAST(YEAR>REF(YEAR,1))+1)-1)*100,COLORRED, NODRAW;
LC:=REF(CLOSE,1);
TR1:=MAX((HIGH - LOW),MAX((HIGH - LC),(LC - LOW)));
ATR:=SMA(TR1,20,1);
ATR1:=ATR+STD(TR1,20)*1.1;
波幅率:=ATR/C*100,COLORRED,NODRAW;
当日涨停板:=(((C/REF(C,1))>=1.0985 AND (H/REF(C,1))<=1.105 AND C=H) OR ((C/REF(C,1))>=1.1975 AND C=H));
当日跌停板:=(((C/REF(C,1))<=0.9015 AND (L/REF(C,1))>=0.895 AND C=L) OR ((C/REF(C,1))<=0.8025 AND C=L));
RSV:=(CLOSE-LLV(LOW,9))/(HHV(HIGH,9)-LLV(LOW,9))*100;
K:=SMA(RSV,3,1),COLORWHITE,NODRAW;
D:=SMA(K,3,1),COLORYELLOW;
J:=3*K-2*D,COLORFF00FF;
DIF:=(EMA(CLOSE,12) - EMA(CLOSE,26));
DEA:=EMA(DIF,9);
macd:=2*(DIF-DEA);
均振:=MA(H/L-1,10)*100,COLORYELLOW,NODRAW;
均涨:=MA(Abs(1-C/REF(C,1)),10)*100,COLORFF00FF,NODRAW;
市值:=STRCAT(STRCAT('总市值: ',CON2STR(FINANCE(1)*C/100000000,0)),'亿元');
DRAWTEXT_FIX(ISLASTBAR AND PERIOD>=5,0.1,1,0,总市值),,COLORYELLOW;
VARA:=REF(H,10)=HHV(H,2*10+1);
VARB:=FILTER(VARA,10);
VARC:=BacKSET(VARB,10+1);
VARD:=FILTER(VARC,10);
VARA1:=REF(L,10)=LLV(L,2*10+1);
VARB1:=FILTER(VARA1,10);
VARC1:=BACKSET(VARB1,10+1);
VARD1:=FILTER(VARC1,10);
前期高点:REF(H,BARSLAST(VARD)),COLORYELLOW,NODRAW;
前期低点:REF(L,BARSLAST(VARD1)),COLORFF00FF,NODRAW;
VAR高点:=VAR2STR(前期高点,2);
DRAWTEXT(VARD,0.002*波幅率*前期高点+前期高点,VAR高点),COLORYELLOW;
VAR低点:=VAR2STR(前期低点,2);
DRAWTEXT(VARD1,前期低点-0.002*波幅率*前期低点,VAR低点),COLORCYAN;
STICKLINE(C>=O,H,L,0,1), COLORRED;
STICKLINE(C>=O,C,O,3,1), COLORRED;
STICKLINE(C< O,H,L,0,0), COLORFFFF00;
STICKLINE(C< O,C,O,3,0),COLORFFFF00;
当天曾涨停:((H/REF(C,1))>=1.0982 AND (H/REF(C,1))<=1.105 AND C<H) OR (H/REF(C,1)>=1.1975 AND C<H),COLORRED,NODRAW;
当天曾跌停:((L/REF(C,1))<=0.9015 AND (L/REF(C,1))>=0.895 AND C>L) OR ((L/REF(C,1))<=0.8025 AND C>L),COLORGREEN,NODRAW;
STICKLINE((当天曾涨停 OR 当天曾涨停) AND PERIOD=5,IF(当天曾涨停,C,O),IF(当天曾涨停,H,L),0,0),COLORGREEN;
AAA1:=STRCAT('涨家数:',CON2STR(DYNAINFO(60),0));
AAA2:=STRCAT('跌家数:',CON2STR(DYNAINFO(61),0));
AAA3:=STRCAT('涨占比:',CON2STR(DYNAINFO(60)/(DYNAINFO(60)+DYNAINFO(61))*100,0));
DRAWTEXT_FIX(1 AND PERIOD=5,0.4,0,0,AAA1),COLORRED;
DRAWTEXT_FIX(1 AND PERIOD=5,0.48,0,0,AAA2),COLORGREEN;
DRAWTEXT_FIX(1 AND PERIOD=5,0.56,0,0,AAA3),COLORYELLOW;
DRAWTEXT_FIX(1 AND PERIOD=5,0.40,0.05,0,'涨停数:'),COLORRED;
DRAWTEXT_FIX(1 AND PERIOD=5,0.48,0.05,0,'跌停数:'),COLORGREEN;
{DRAWTEXT_FIX(PERIOD=5,0.465,0.05,1,CON2STR("【量】.涨停#DAY",0)), COLOR0000FF;
DRAWTEXT_FIX(PERIOD=5,0.545,0.05,1,CON2STR("【量】.跌停#DAY",0)), COLOR00FF00;}
DRAWTEXT_FIX(PERIOD=5,0.465,0.05,1,CON2STR("880006$C",0)), COLOR0000FF;
DRAWTEXT_FIX(PERIOD=5,0.545,0.05,1,CON2STR("880006$O",0)), COLOR00FF00;
上市日期:CONST(DAYTODATE((DATETODAY(DATE)-FINANCE(42)))+19000000),COLORYELLOW,NODRAW;
当日高度涨停:=IF(BARSLASTCOUNT(当日涨停板)>=3 AND (REFX(当日涨停板,1)=0 OR ISLASTBAR),BARSLAST(当日涨停板=0),DRAWNULL);
DRAWNUMBER(当日高度涨停>=3,1.02*H,当日高度涨停),,DRAWAbovE,COLORGREEN;
DRAWTEXT_FIX(1 AND (PERIOD=5 OR PERIOD=6 OR PERIOD=7),0.00,0,0,STRCAT('所属地区:',DYBLOCK)),COLORRED;
DRAWTEXT_FIX(1 AND (PERIOD=5 OR PERIOD=6 OR PERIOD=7),0.00,0.1,0,STRCAT('所属行业:',HYBLOCK)),COLORFF00FF;
DRAWTEXT_FIX(1 AND (PERIOD=5 OR PERIOD=6 OR PERIOD=7),0.00,0.2,0,STRCAT('所属概念:',GNBLOCK)),COLORYELLOW;
IF(MA2>=REF(MA2,1),MA2,DRAWNULL),COLORFF00FF,LINETHICK2;
IF( PERIOD=5 AND MA3>REF(MA3,1) ,MA3,DRAWNULL),COLORGREEN,LINETHICK2;
TJ1:=(MA(C,20)>=MA(C,90) OR EMA(C,20)>=MA(C,90) OR MA(CLOSE,12)>MA(CLOSE,26)) AND (((C/REF(C,1)-1)*100>=8.5 AND H/C<1.015 AND V>1.8*REF(V,1))) AND C/LLV(C,10)<1.3 AND C/HHV(H,30)>=0.9;
TJ2:=(MA(C,20)>=MA(C,90) OR EMA(C,20)>=MA(C,90) OR (MA(CLOSE,12)>MA(CLOSE,26) AND V>1.8*REF(V,1))) AND ((C/REF(C,1)-1)*100>=9.5 AND H=C) AND ((MA(C,20)>=REF(MA(C,20),1) AND MA(C,10)>=REF(MA(C,10),1) AND MA(C,5)>=REF(MA(C,5),1)) AND V>1.5*REF(V,1)) AND C/LLV(C,10)<1.3 AND C/HHV(H,30)>=0.9;
XA:=(TJ1 OR TJ2) AND COUNT((TJ1 OR TJ2),BARSLAST(crOSS(MA(C,20),MA(C,5))))<=1;
STICKLINE(XA=1,OPEN,CLOSE,3,0),COLORRED;
DRAWTEXT(XA=1 AND PERIOD=5,0.92*L,'★--火箭发射'),COLORYELLOW;

通达信版面简洁操盘主图指标公式

相关文章