在线检测未来函数

通达信天才分时主图指标公式

来源:Internet,编辑:股旁网,2022-07-26

H1:=maX(DYNAINFO(3),DYNAINFO(5));
L1:=MIN(DYNAINFO(3),DYNAINFO(6));
P1:=H1-L1;
阻力:L1+P1*7/8,COLOR00DD00;
支撑:L1+P1*0.5/8,COLOR00DD00;
现价:CLOSE,NODRAW;
stICKLINE(crOSS(支撑,现价),支撑,阻力,1,0),COLORYELLOW;
DRAWTEXT(LONGCROSS(支撑,现价,2),支撑*1.001,'★B'),COLORYELLOW;{吸};
DRAWTEXT(LONGCROSS(现价,阻力,2),现价,'★'),COLORRED;{抛};
AMOUNT/(V*100),COLORBLUE,LINETHICK4;
AAA1:=STRCAT(CON2STR(YEAR,0),'年');
AAA2:=STRCAT(CON2STR(MONTH,0),'月');
AAA3:=STRCAT(CON2STR(DAY,0),'日');
AAA4:=STRCAT('【',IF(WEEkdAY=1,'一',IF(WEEKDAY=2,'二',IF(WEEKDAY=3,'三',IF(WEEKDAY=4,'四',IF(WEEKDAY=5,'五',IF(WEEKDAY=6,'六','日')))))));
AAA:=STRCAT(STRCAT(STRCAT(AAA1,AAA2),STRCAT(AAA3,AAA4)),'】');
AAA01:=STRCAT('流通股',CON2STR(FINANCE(7)/100000000,4));
AAA02:=STRCAT('(亿)增长',CON2STR(FINANCE(43),2));
AAA03:=STRCAT('%收益(年)',CON2STR(FINANCE(33),2));
AAA04:=STRCAT('(元)换手',CON2STR(DYNAINFO(37)*100,2));
AAA05:=STRCAT('%量比',CON2STR(DYNAINFO(17),2));
BBB:=STRCAT(STRCAT(STRCAT(AAA01,AAA02),STRCAT(AAA03,AAA04)),STRCAT(AAA05,' '));
AAAA:=STRCAT(AAA,BBB);
DRAWTEXT_FIX(1,0,0.85,0,AAAA),COLORYELLOW;
AAA06:=STRCAT(DYBLOCK,HYBLOCK);
AAA07:=STRCAT(GNBLOCK,FGBLOCK);
AAA08:=STRCAT(ZSBLOCK,ZHBLOCK);
AAAAA:=STRCAT(STRCAT(AAA06,AAA07),STRCAT(AAA08,' '));
DRAWTEXT_FIX(1,0,0.80,0,AAAAA),COLORWHITE;
DRAWTEXT_FIX(1,0,0.90,0,ZDBLOCK),COLORCYAN;
成交额:=V*C/100,NODRAW;
BA2:=SUM((IF(((成交额/8>20) AND (CLOSE>(REF(CLOSE,1)))),成交额,0)),0);
BA3:=SUM((IF(((成交额/8>20) AND (CLOSE<(REF(CLOSE,1)))),成交额,0)),0);
BA6:=(BA2+BA3);
BA7:=IF((ISLASTBAR),((100*BA2)/BA6),0);
BA8:=IF((ISLASTBAR),((100*BA3)/BA6),0);
{DD1:=1;}
BAAA1:=STRCAT(STRCAT('机构买',CON2STR((100*BA2)/BA6,0)),'%');
BAAA2:=STRCAT(STRCAT('机构卖',CON2STR((100*BA3)/BA6,0)),'%');
BAAA3:=STRCAT(STRCAT('总买入',CON2STR((100*(BA2-BA3))/BA6,0)),'%');
sslB:=STRCAT(STRCAT('三日量比',CON2STR((vol/FROMOPEN)/(MA(V,3)/240)*100,0)),'%');
DRAWTEXT_FIX(1,0,0.02,0,BAAA1),COLORRED;
DRAWTEXT_FIX(1,0,0.10,0,BAAA2),COLOR00FF00;
DRAWTEXT_FIX(1,0,0.18,0,BAAA3),COLOR00FFFF;
DRAWTEXT_FIX(1,0,0.26,0,SSLB),COLORRED;
MA25:EMA(CLOSE,25);
FJ:EMA(CLOSE,905);
STICKLINE((MA25 >FJ),MA25,FJ,0.8,0),COLOR0000FF;
STICKLINE((MA25 >FJ)AND MA25<REF(MA25,1),MA25,FJ,0.8,0),COLOR00CCFF;
STICKLINE((MA25 >FJ)AND FJ<REF(FJ,1),MA25,FJ,0.8,0),COLORCYAN;
STICKLINE((MA25 <FJ),MA25,FJ,0.7,0),COLOR00FF00;
STICKLINE((MA25 <FJ)AND MA25>REF(MA25,1),MA25,FJ,0.8,0),COLORCYAN;
STICKLINE((MA25 <FJ)AND FJ>REF(FJ,1),MA25,FJ,0.8,0),COLORLIRED;
DRAWICON(CROSS(MA25,FJ),FJ,23);
分时顶:HHV(H,480),COLOR3399FF,DOTLINE;
分时低:LLV(L,480),COLORFFFF33,DOTLINE;

通达信天才分时主图指标公式

相关文章