在线检测未来函数

通达信阳包阴主图指标公式

来源:Internet,编辑:股旁网,2022-08-04

本文指标含有选股公式如下:
股旁网此处内容已被隐藏,请输入验证码查看内容。
验证码:
请关注本站微信公众号,回复“1009”,获取验证码。
提示:在微信里搜索“股旁网”或者微信扫描右侧二维码。

{财务数据}
所属板块:=stRCAT(STRCAT(STRCAT('行业: ',HYBLOCK),STRCAT('  地域: ',DYBLOCK)),STRCAT(' 概念: ',GNBLOCK));
股本:=STRCAT(STRCAT('总股本: ',CON2STR(TOTALCAPITAL/1000000,2)),'亿');
流通盘:=STRCAT(STRCAT(' 流通盘: ',CON2STR(CAPITAL/1000000,2)),'亿');
市值:=STRCAT(STRCAT(' 流通市值: ',CON2STR((CAPITAL/1000000)*C,2)),'亿');
上市日期:=STRCAT(' 上市日期: ',CON2STR(HHV((BARSCOUNT(C)=0)*(DATE+19000000),0),0));
股本市值:=STRCAT(STRCAT(STRCAT(总股本,流通盘),市值),上市日期);
{显示设置}
DRAWTEXT_FIX(ISLASTBAR,0.005,0,0,所属板块),COLORYELLOW,LINETHICK2;
DRAWTEXT_FIX(ISLASTBAR,0.005,0.07,0,股本市值),COLORGREEN,LINETHICK2;
DRAWTEXT_FIX(C>0,0.078,0.06,0,EXTERNSTR(0,2)),COLORFF00FF,LINETHICK2;
DA3:=YEAR AND MONTH AND DAY;
AAA:=STRCAT(CON2STR(YEAR,0),'年');
AAB:=STRCAT(CON2STR(MONTH,0),'月');
AA33:=STRCAT(CON2STR(DAY,0),'日');
AA4:=STRCAT('【',IF(WEEkdAY=1,'星期一',IF(WEEKDAY=2,'星期二',
IF(WEEKDAY=3,'星期三',IF(WEEKDAY=4,'星期四',IF(WEEKDAY=5,'星期五',
IF(WEEKDAY=6,'六','日')))))));
AA:=STRCAT(STRCAT(STRCAT(AAA,AAB),STRCAT(AA33,AA4)),'】');
SA:DRAWTEXT_FIX(DA3,0,1,0,AA),COLORGREEN;
TY:=H;
TY2:=L;
A1:=REF(TY,10)=HHV(TY,2*10+1);
B1:=FILTER(A1,10);
C1:=BacKSET(B1,10+1);
HD:=FILTER(C1,10);
A2:=REF(TY2,10)=LLV(TY2,2*10+1);
B2:=FILTER(A2,10);
C2:=BACKSET(B2,10+1);
LD:=FILTER(C2,10);
前期高:REF(H,BArslAST(HD)),COLOR00FF00,NODRAW;
STICKLINE(H,前期高,前期高,2,0),COLORmaGENTA;
前期低:REF(L,BARSLAST(LD)),COLORRED,NODRAW;
STICKLINE(L,前期低,前期低,2,0),COLORBLUE;
{DRAWNUMBER(FILTER(C1,10),HIGH,H),DRAWAbovE;
DRAWNUMBER(FILTER(C2,10),L,L);}
半分位:=(O+C)/2;
昨半分位:=REF(半分位,1);
STICKLINE(ISLASTBAR,昨半分位,昨半分位,2,0),COLORWHITE;
{DRAWNUMBER(ISLASTBAR,昨半分位,昨半分位);}
C2A:=REF(C,1),NODRAW;
涨停:=REF(C,1)*1.1-C<0.01 AND H=C,NODRAW;
STICKLINE(涨停,OPEN,CLOSE,1,0),COLORRED;
STICKLINE(涨停,H,L,0,0),COLORRED;
跌停:=IF((C2A-C)*100/C2A>=(10-0.01*100/C2A) AND L=C,1,0),NODRAW;
STICKLINE(跌停,OPEN,CLOSE,1,0),COLORGREEN;
STICKLINE(跌停,H,L,0,1),COLORGREEN;
ZT:=C/REF(C,1)>1.097;
XH:=FILTER(ZT,13);
BH:=BARSLAST(ZT);
CZ:=REF(H,BH)-REF(L,BH);
{STICKLINE(C,(REF(L,BH)+CZ*0.5),(REF(L,BH)+CZ*0.5),2,0),COLORRED;
STICKLINE(C,REF(L,BH),REF(L,BH),2,0),COLORBLUE;}
{DRAWTEXT(ZT,L*0.98,'涨停'),COLORF00FF0;}
VARZT:=BARSLAST(C/REF(C,1)>1.097);
{STICKLINE(VARZT=2,L*0.97,L*0.98,0,0),COLOR0000FF;}
DRAWTEXT(VARZT=3,H*1.02,'3天'),COLORYELLOW;
{STICKLINE(VARZT=4,H*1.03,H*1.02,0,0),COLOR9966FF;}
DRAWTEXT(VARZT=5,H*1.02,'5天'),COLORYELLOW;
{STICKLINE(VARZT=7,L*0.97,L*0.98,0,0),COLOR00FFFF;}
DRAWTEXT(VARZT=8,H*1.02,'8天'),COLORYELLOW;
{STICKLINE(VARZT=12,H*1.03,H*1.02,0,0),COLORFF33FF;}
DRAWTEXT(VARZT=13,H*1.02,'13天'),COLORYELLOW;
{STICKLINE(VARZT=20,L*0.97,L*0.98,0,0),COLOR0066FF;}
DRAWTEXT(VARZT=21,H*1.02,'21天'),COLORYELLOW;
{STICKLINE(VARZT=33,H*1.03,H*1.02,0,0),COLOR9932CD;}
DRAWTEXT(VARZT=34,H*1.02,'34天'),COLORYELLOW;
{STICKLINE(VARZT=54,L*0.97,L*0.98,0,0),COLOR006600;}
DRAWTEXT(VARZT=55,H*1.02,'55天'),COLORYELLOW;
{STICKLINE(VARZT=88,H*1.03,H*1.02,0,0),COLOR00FF00;}
DRAWTEXT(VARZT=89,H*1.02,'89天'),COLORYELLOW;
{STICKLINE(VARZT=143,L*0.97,L*0.98,0,0),COLORCCFFFF;}
DRAWTEXT(VARZT=144,H*1.02,'144天'),COLORYELLOW;
{STICKLINE(VARZT=232 ,H*1.03,H*1.02,0,0),COLORFF0033;}
DRAWTEXT(VARZT=233,H*1.02,'233天'),COLORYELLOW;
{STICKLINE(VARZT=376,L*0.97,L*0.98,0,0),COLORFF9966;}
DRAWTEXT(VARZT=377,H*1.02,'377天'),COLORYELLOW;
JJ:=(3*C+H+L+O)/6;
VAR1:=(8*JJ+7*REF(JJ,1)+6*REF(JJ,2)+5*REF(JJ,3)
+4*REF(JJ,4)+3*REF(JJ,5)+2*REF(JJ,6)+REF(JJ,8))/36;
TJ1:=vol=HHV(VOL,10) AND VOL>2*REF(VOL,1) AND CLOSE>VAR1 AND C>REF(C,1);
LJL:=FILTER(TJ1,5);
TJ2:=IF(BARSLAST(LJL)=1 AND CLOSE>REF(HIGH,1),1,
IF(BARSLAST(LJL)=2 AND CLOSE>REF(HIGH,2),1,IF(BARSLAST(LJL)=3 AND CLOSE>REF(HIGH,3),1,0)));
TP:=TJ2=1;
{STICKLINE(CLOSE,REF(LOW,BARSLAST(LJL)),REF(LOW,BARSLAST(LJL)),2,0),COLORYELLOW;}
TJ3:=IF(BARSLAST(LJL)=1 AND CLOSE>REF(LOW,1),1,
IF(BARSLAST(LJL)=2 AND CLOSE>REF(LOW,2),1,IF(BARSLAST(LJL)=3 AND CLOSE>REF(LOW,3),1,0)));
STFZ:=TJ3=1;
CL:=STFZ AND TP;
TJCL:=FILTER(CL,3);
DRAWTEXT(LJL,L*0.98,'↖黄金量'),COLORYELLOW;
STICKLINE(LJL,OPEN,CLOSE,1,0),COLORYELLOW;
STICKLINE(LJL,H,L,0,0),COLORYELLOW;
B_1:=CLOSE>=REF(HIGH,1) AND LOW<=REF(LOW,1);
DRAWTEXT(B_1,LOW*0.96,'↖阳包阴'),COLORYELLOW;
STICKLINE(B_1,OPEN,CLOSE,1.5,1),COLORYELLOW;
STICKLINE(B_1,H,L,0,0),COLORYELLOW;
盘古均线:EMA(CLOSE,13),COLOR00CCFF,DOTLINE,LINETHICK2;
{趋势线:((MA(CLOSE,3)+MA(CLOSE,6)+MA(CLOSE,12)+MA(CLOSE,24))/4+expma(CLOSE,10))/2;}
MA5:MA(CLOSE,5),COLORWHITE,DOTLINE,LINETHICK1;
{MA10:MA(CLOSE,10),COLORCCCC00;}
MA20:MA(CLOSE,20),COLORFF66FF,DOTLINE;
MA60:MA(CLOSE,60),COLOR66FF00,DOTLINE;
{顶点:IF(CURRBARSCOUNT<=60, CONST(IF(ISLASTBAR=1,HHV(H, BARSLAST(CURRBARSCOUNT=60)),1)),DRAWNULL),COLORRED,DOTLINE;
低点:IF(CURRBARSCOUNT<=60, CONST(IF(ISLASTBAR=1,LLV(L, BARSLAST(CURRBARSCOUNT=60)),1)),DRAWNULL),COLORMAGENTA,DOTLINE;
STICKLINE(cci>=200 AND H>=顶点,O,C,3,0),COLORBLUE;
STICKLINE(CCI<=100 AND L<=低点,O,C,3,0),COLORYELLOW;}
{DRAWTEXT(ISLASTBAR,顶点,'高点参考'),COLORRED;
DRAWTEXT(ISLASTBAR,低点,'低点参考'),COLORMAGENTA;}{COLORBLUE;};
{LK:=H<REF(L,1);
T:=BARSLAST(LK);
LKL:=REF(L,T+1);
HH:=HHV(H,T+1);
XG:=REF(HH<LKL,1) AND T>=3 AND L>REF(H,1) AND L>REF(HH,1);
FT:=BACKSET(XG,T+1);
STICKLINE(FT AND XG=0,C,O,3,0),COLOR00FFFF;
STICKLINE(FT AND XG=0,H,L,0,0),COLOR00FFFF;
STICKLINE(FT AND XG=0,LKL,LKL,4,0),COLORFFAA00;
STICKLINE(FT AND XG=0,REFX(REF(HH,1),BARSNEXT(XG)),REFX(REF(HH,1),BARSNEXT(XG)),4,0),COLORFFAA00;};

通达信阳包阴主图指标公式

相关文章