在线检测未来函数

通达信妖股启动主图指标公式

来源:Internet,编辑:股旁网,2022-08-31

本文指标含有选股公式如下:
股旁网此处内容已被隐藏,请输入验证码查看内容。
验证码:
请关注本站微信公众号,回复“1009”,获取验证码。
提示:在微信里搜索“股旁网”或者微信扫描右侧二维码。

AAA:=(3*C+H+L+O)/6;
VAR01:=(8*AAA+7*REF(AAA,1)+6*REF(AAA,2)+5*REF(AAA,3)+4*REF
(AAA,4)+3*REF(AAA,5)+2*REF(AAA,6)+REF(AAA,8))/36,COLORFF7700;
VAR02:=(HHV(VAR01,5)+HHV(VAR01,10)+HHV(VAR01,20))/3;
VAR03:=(LLV(VAR01,5)+LLV(VAR01,10)+LLV(VAR01,20))/3;
VAR04:=(HHV(VAR02,5)+HHV(VAR02,10)+HHV(VAR02,20))/3;
VAR05:=(LLV(VAR03,5)+LLV(VAR03,10)+LLV(VAR03,20))/3;
VAR06:=(LLV(VAR01,2)+LLV(VAR01,4)+LLV(VAR01,6))/3;
Z1:=stRCAT(HYBLOCK,' ');
Z2:=STRCAT(Z1,DYBLOCK);
Z3:=STRCAT(Z2,' ');
DRAWTEXT_FIX(ISLASTBAR,0,0,0,STRCAT(Z3,GNBLOCK)),COLORLIRED;
DA:=(3*CLOSE+OPEN+LOW+HIGH)/6,POINTDOT;
X2:(20*DA+19*REF(DA,1)+18*REF(DA,2)+
17*REF(DA,3)+16*REF(DA,4)+15*REF(DA,5)+14*REF(DA,6)+13*REF(DA,7)+12*REF(DA,8)
+11*REF(DA,9)+10*REF(DA,10)+9*REF(DA,11)+8*REF(DA,12)+7*REF(DA,13)+6*REF(DA,14)+5*
REF(DA,15)+4*REF(DA,16)+3*REF(DA,17)+2*REF(DA,18)+REF(DA,20))/210,COLOR141414,NODRAW;
回踩线:ma(X2,5),LINETHICK1,COLORGREEN;
MAA5:=MA(C,5),COLORRED,LINETHICK1;
MAA10:=MA(C,10);
MAA30:=MA(C,30),COLORRED,NODRAW;
MA5:=MA(CLOSE,5);
MA10Q:=MA(CLOSE,10),NODRAW;
MA20Q:=MA(CLOSE,20),NODRAW;
MA60Q:=MA(CLOSE,60),NODRAW;
AA1E:=AMOUNT/V;
BB1E:=L<AA1E*0.9;
CC1E:=(C-REF(C,1))/REF(C,1)*100>1.2;
DD1E:=L<MA(C,5)*0.921;
EE1E:=V<MA(V,5)*1.5;
资金异动:=BB1E AND CC1E AND DD1E AND EE1E,LINETHICK0;
DRAWTEXT(资金异动,(LOW* 0.95),'↖资金异动'),COLOR40CCFF;
MA5A:=MA(CLOSE,5),NODRAW;
MA10A:=MA(CLOSE,10),NODRAW;
MA20A:=MA(CLOSE,20),NODRAW;
MA30A:=MA(CLOSE,30),NODRAW;
MA54A:=MA(CLOSE,54),NODRAW;
MA60A:=MA(CLOSE,60),NODRAW;
MA120A:=MA(CLOSE,120),NODRAW;
HJ_8:=(REF(CLOSE,3)-CLOSE)/REF(CLOSE,3)*100>5;
HJ_9:=FILTER(HJ_8,10);
HJ_10:=BArslAST(HJ_9);
HJ_11:=REF(HIGH,HJ_10+2);
HJ_12:=REF(HIGH,HJ_10+1);
HJ_13:=REF(HIGH,HJ_10);
HJ_14:=MAX(HJ_11,HJ_12);
HJ_15:=MAX(HJ_14,HJ_13);
HJ_16:=(CLOSE-REF(CLOSE,1))/REF(CLOSE,1)*100>5;
HJ_17:=HJ_10<150;
HJ_18:=(OPEN-HJ_15)/HJ_15*100<30;
HJ_19:=(CLOSE-LLV(LOW,HJ_10))/LLV(LOW,HJ_10)*100<50;
HJ_20:=(CLOSE-REF(OPEN,5))/REF(OPEN,5)*100<30;
HJ_21:=vol/MA(VOL,5)<3.5;
HJ_22:=(CLOSE-REF(CLOSE,89))/REF(CLOSE,89)*100<80;
HJ_25:=HJ_16 AND HJ_17 AND HJ_18 AND HJ_19 AND HJ_20 AND HJ_21 AND HJ_22;
暴利:=FILTER(HJ_25,15);
PL1:=(((CLOSE-MA54A)/MA54A)<0.1);
PL2:=(((CLOSE-MA10A)/MA10A)<0.3);
偏离率:=(((PL1=1) AND (PL2=1))*0.2);
平台突破:=((((偏离率=0) AND (REF(偏离率,1)=0.2)) AND (REF((COUNT((偏离率=0.2),10)=10),1)=1))*-0.1);
妖股突破:=平台突破=-0.1;
XDF:=(暴利 OR 妖股突破);
VARA0:=DMA(AMOUNT/VOL/100,VOL/CAPITAL);
VARAA:=DYNAINFO(7)/(REF(CLOSE,1))>1.05 AND (DYNAINFO(7)/O>1.05);
FLIGA:=(VOL/REF(VOL,1)>1.2 AND COUNT(CLOSE>OPEN,1)) OR (LOW>REF(HIGH,1) AND COUNT(OPEN>CLOSE,1) AND VOL/REF(VOL,1)>1.2);
妖股:XDF AND C/REF(C,1)>1.095 AND FLIGA AND VARAA,NODRAW;
DRAWICON(妖股,LOW,7);
DRAWTEXT(妖股,LOW*0.97,' ↖妖股启动'),COLORYELLOW;
BDGD:=C=HHV(C,5);
GDSJ:=BARSLAST(BDGD);
底:LLV(L,5),COLORFF9933,LINETHICK1,crOSSDOT,NODRAW;
顶:HHV(H,5),COLOR0099CC,LINETHICK1,CROSSDOT,NODRAW;
前高:IF(GDSJ>0,REF(C,GDSJ),REF(C,GDSJ)),COLORFFFF00,POINTDOT,LINETHICK2,NODRAW;
MA5S:=MA(C,5),LINETHICK2,COLORFF00FF,NODRAW;
MA13S:=MA(C,13),LINETHICK2,COLOR00FF00,NODRAW;
MA20S:=MA(C,20);
MA30S:=MA(C,30);
MA60S:=MA(C,60);
MA120S:=SMA(C,120,1);
TP:=CROSS(C,REF(前高,1));
出击:=TP AND COUNT(TP,5)=1;
TPSJ:=BARSLAST(出击);
HC:=CROSS(REF(前高,TPSJ+1),L) OR CROSS(REF(前高,TPSJ),C);
回踩:=HC AND TPSJ>1;
mtm:=C-REF(C,1);
DX:=100*EMA(EMA(MTM,6),6)/EMA(EMA(Abs(MTM),6),6);
放量上涨:=CLOSE/REF(CLOSE,1)>=1.01 AND VOL/REF(VOL,1)>=1.5 AND VOL>MA(VOL,5) AND REF(VOL,1)/REF(MA(VOL,5),1)<=1.8;
箱体形成:=((HHV(C,3)/LLV(C,5)-1)*100<=DX AND (HHV(C,5)/LLV(C,3)-1)*100<=DX)*0.3;
接近箱顶:=(CLOSE/REF(HHV(CLOSE,5),2)<=1.02 AND HIGH/REF(HHV(CLOSE,5),2)>=0.98)*0.5;
P1:=BARSLAST(箱体形成);
P2:=BARSLAST(接近箱顶);
期待突破:=(放量上涨 AND 接近箱顶 AND P1<=3 AND P2<=1)*2;
关注:=(放量上涨 AND 接近箱顶)*1;
ZH520:=ABS(MA5S-MA20S)/MA20S*100<=5;
ZH530:=ABS(MA5S-MA30S)/MA30S*100<=5;
QSXS1:=MA5>REF(MA5S,1);
QSXS2:=MA20S>REF(MA20S,1);
QSXS3:=MA30S>REF(MA30S,1);
DTPL:=MA20S>MA30S AND MA30S>MA120S;
LYHT:=DTPL AND QSXS2 AND QSXS3 AND NOT(QSXS1) AND REF(QSXS1,1);
老鸭回头:=LYHT*50;
wr5:=100*(HHV(H,5)-C)/(HHV(H,5)-LLV(L,5));
WR6:=100*(HHV(H,6)-C)/(HHV(H,6)-LLV(L,6));
WR:=80-(WR5*3+WR6*2)/5;
坑:=IF(WR<0,WR,0);
LYT:=DTPL AND QSXS2 AND QSXS3 AND COUNT(QSXS1,4)<=1;
GJHS:=C>MA5 AND ((QSXS1 AND NOT(REF(QSXS1,1))) OR C>REF(C,3));
LYKK:=GJHS AND (ZH520 OR ZH530) AND LYT;
买:=(LYKK AND NOT(REF(LYKK,1)))*50;
买1:=IF(LLV(DX,2)=LLV(DX,7) AND COUNT(DX<0,2) AND CROSS(DX,MA(DX,2)),1,0);
卖1:=IF(HHV(DX,2)=HHV(DX,7) AND COUNT(DX>50,2) AND CROSS(MA(DX,2),DX),1,0);
VARC0:=SMA(MAX(C-REF(C,1),0),6,1)/SMA(ABS(C-REF(C,1)),6,1)*100;
VAR6S:=REF(C,1);
VAR07:=SMA(MAX(C-VAR6S,0),6,1)/SMA(ABS(C-VAR6S),6,1)*100;
优选:=(买 AND COUNT((MA13S>MA20S),5)=5)*100;
DRAWTEXT(买>0,L*0.99, ' '),COLORRED;
DRAWICON(CROSS(82,VARC0),H*1.03,2);
DRAWTEXT(CROSS(84,VAR07),H*1.04,'顶'),COLORFFFF00;
M5:=MA(CLOSE,5),COLORYELLOW,LINETHICK0;
M24:=MA(CLOSE,24),COLORGREEN,LINETHICK0;
强弱分界线:MA(CLOSE,72),COLORFF00FF,LINETHICK2;
M200:=MA(CLOSE,200),COLORCYAN,LINETHICK0;
DRAWKLINE(H,O,L,C);
DRAWTEXT(CROSS(M5,M24),L*0.95,'启动'),COLORWHITE;
DRAWTEXT(CROSS(M5,强弱分界线),L*0.97,'有戏'),COLORWHITE;
DRAWTEXT(CROSS(M5,M200),L*0.96,'加速'),COLORWHITE;
N:=13;
VAR111:=HHV(HIGH,N);
VAR222:=LLV(LOW,N);
阻力线:=EMA((CLOSE-VAR222)/(VAR111-VAR222),21)-0.5,NODRAW;
操作线1:=EMA((CLOSE-VAR222)/(VAR111-VAR222),5)-0.5,NODRAW;
DRAWTEXT(CROSS(操作线1,阻力线) AND 阻力线<0.1,H,'突'),COLORWHITE;
DRAWTEXT(CROSS(阻力线,操作线1) AND 阻力线>0.25,H*1.05,'-破位'),COLORGREEN;
VAR0:=IF(DATE<=1261231,1,0);
bbi:=(MA(CLOSE,3)+MA(CLOSE,6)+MA(CLOSE,12)+MA(CLOSE,24))/4;
IF(VAR0=1,BBI,DRAWNULL),COLORYELLOW,LINETHICK1;
IF(CLOSE>BBI AND VAR0=1,BBI,DRAWNULL),COLORRED,LINETHICK2;
IF(CLOSE<BBI AND VAR0=1,BBI,DRAWNULL),COLORGREEN,LINETHICK1;
DIF1:=EMA(CLOSE,10)-EMA(CLOSE,33);
DEA1:=EMA(DIF1,10);
VAR001:=DIF1-DEA1;
MTR:=EXPMEMA(MAX(MAX(HIGH-LOW,ABS(HIGH-REF(CLOSE,1))),ABS(REF(CLOSE,1)-LOW)),14);
HD :=HIGH-REF(HIGH,1);
LD :=REF(LOW,1)-LOW;
DMP:=EXPMEMA(IF(HD>0&&HD>LD,HD,0),14);
DMM:=EXPMEMA(IF(LD>0&&LD>HD,LD,0),14);
pdi:=DMP*100/MTR;
mdi:=DMM*100/MTR;
ADX:=EXPMEMA(ABS(MDI-PDI)/(MDI+PDI)*100,6);
ADXR:=EXPMEMA(ADX,6);
VAR002:=PDI-MDI;
VAR003:=ADX-ADXR;
ENTER:=TFILTER(COUNT(CROSS(CLOSE,BBI),10)>0 AND VAR001>0 AND VAR002>0 AND VAR003>0 AND VAR0=1,COUNT(CROSS(BBI,CLOSE),10)>0 AND VAR001<0 AND VAR002<0 AND VAR0=1,1);
EXIT:=TFILTER(COUNT(CROSS(CLOSE,BBI),10)>0 AND VAR001>0 AND VAR002>0 AND VAR003>0 AND VAR0=1,COUNT(CROSS(BBI,CLOSE),10)>0 AND VAR001<0 AND VAR002<0 AND VAR0=1,2);
DRAWTEXT(ENTER,LOW*0.96,'龙抬头'),COLORRED;
PT:=REF(HIGH,1)-REF(LOW,1);
cdp:=(HIGH + LOW + CLOSE)/3;
买01:=CDP+PT,COLORBLUE,DOTLINE;
买02:=CDP-PT,COLORFF00FF,DOTLINE;
卖01:=2*CDP-LOW,COLORYELLOW,DOTLINE;
卖02:=2*CDP-HIGH,DOTLINE;
近高值:=IF(买01>卖01,卖01,买01);
近低值:=IF(买02<卖02,卖02,买02);
AA:=(C-REF(C,1))/REF(C,1)*100;
DRAWTEXT(AA<-5,H,'★'),COLORWHITE;
DRAWNUMBER(AA<-5,O,L)COLORFF00FF;
VAR1:=CLOSE>REF(CLOSE,1) AND CLOSE>REF(CLOSE,2);
VAR2:=REF(VAR1,1) AND CLOSE<=REF(CLOSE,1) AND CLOSE>=REF(CLOSE,2);
VAR3:=REF(VAR2,1) AND CLOSE>=REF(CLOSE,1) AND CLOSE<=REF(CLOSE,2);
VAR4:=REF(VAR3,1) AND CLOSE<=REF(CLOSE,1) AND CLOSE>=REF(CLOSE,2);
VAR5:=REF(VAR4,1) AND CLOSE>=REF(CLOSE,1) AND CLOSE<=REF(CLOSE,2);
VAR6:=REF(VAR5,1) AND CLOSE<=REF(CLOSE,1) AND CLOSE>=REF(CLOSE,2);
VAR7:=REF(VAR6,1) AND CLOSE>=REF(CLOSE,1) AND CLOSE<=REF(CLOSE,2);
VAR8:=REF(VAR7,1) AND CLOSE<=REF(CLOSE,1) AND CLOSE>=REF(CLOSE,2);
VAR9:=REF(VAR8,1) AND CLOSE>=REF(CLOSE,1) AND CLOSE<=REF(CLOSE,2);
VARA:=REF(VAR9,1) AND CLOSE<=REF(CLOSE,1) AND CLOSE>=REF(CLOSE,2);
VARB:=REF(VARA,1) AND CLOSE>=REF(CLOSE,1) AND CLOSE<=REF(CLOSE,2);
VARC:=REF(VARB,1) AND CLOSE<=REF(CLOSE,1) AND CLOSE>=REF(CLOSE,2);
VARD:=CLOSE<REF(CLOSE,1) AND CLOSE<REF(CLOSE,2);
VARE:=REF(VARD,1) AND CLOSE>=REF(CLOSE,1) AND CLOSE<=REF(CLOSE,2);
VARF:=REF(VARE,1) AND CLOSE<=REF(CLOSE,1) AND CLOSE>=REF(CLOSE,2);
VAR10:=REF(VARF,1) AND CLOSE>=REF(CLOSE,1) AND CLOSE<=REF(CLOSE,2);
VAR11:=REF(VAR10,1) AND CLOSE<=REF(CLOSE,1) AND CLOSE>=REF(CLOSE,2);
VAR12:=REF(VAR11,1) AND CLOSE>=REF(CLOSE,1) AND CLOSE<=REF(CLOSE,2);
VAR13:=REF(VAR12,1) AND CLOSE<=REF(CLOSE,1) AND CLOSE>=REF(CLOSE,2);
VAR14:=REF(VAR13,1) AND CLOSE>=REF(CLOSE,1) AND CLOSE<=REF(CLOSE,2);
VAR15:=REF(VAR14,1) AND CLOSE<=REF(CLOSE,1) AND CLOSE>=REF(CLOSE,2);
VAR16:=REF(VAR15,1) AND CLOSE>=REF(CLOSE,1) AND CLOSE<=REF(CLOSE,2);
VAR17:=REF(VAR16,1) AND CLOSE<=REF(CLOSE,1) AND CLOSE>=REF(CLOSE,2);
VAR18:=REF(VAR17,1) AND CLOSE>=REF(CLOSE,1) AND CLOSE<=REF(CLOSE,2);
VAR19:=REF(VARD OR VARE OR VARF OR VAR10 OR VAR11 OR VAR12 OR VAR13 OR VAR14 OR VAR15 OR VAR16 OR VAR17 OR VAR18,1) AND VAR1;
VAR1A:=REF(VAR1 OR VAR2 OR VAR3 OR VAR4 OR VAR5 OR VAR6 OR VAR7 OR VAR8 OR VAR9 OR VARA OR VARB OR VARC,1) AND VARD;
DRAWICON(VAR19,REF(CLOSE,1)*0.96,1);
DRAWICON(VAR1A,REF(CLOSE,1)*1.05,2);
VAR020:=CLOSE*VOL;
VAR030:=EMA((EMA(VAR020,3)/EMA(VOL,3)+EMA(VAR020,6)/EMA(VOL,6)
+EMA(VAR020,12)/EMA(VOL,12)+EMA(VAR020,24)/EMA(VOL,24))/4,13);
强势线:1.06*VAR030,POINTDOT,COLORWHITE,LINETHICK2;

通达信妖股启动主图指标公式

相关文章