在线检测未来函数

通达信智取妖底主图指标公式

来源:Internet,编辑:股旁网,2022-11-01

本文指标含有选股公式如下:
股旁网此处内容已被隐藏,请输入验证码查看内容。
验证码:
请关注本站微信公众号,回复“1011”,获取验证码。
提示:在微信里搜索“股旁网”或者微信扫描右侧二维码。

ma5:MA(CLOSE,5);
MA13:MA(CLOSE,13);
MA21:MA(CLOSE,21);
MA75:MA(CLOSE,75);
A1:=((MA(C,60)-L)/MA(C,20))*200;
B1:=((MA(C,60)-L)/MA(C,60))*200;
C1:=((MA(C,30)-L)/MA(C,60))*200;
M1:=REF(CLOSE,1);
M2:=SMA(MAX(CLOSE-M1,0),7,1)/SMA(Abs(CLOSE-M1),7,1)*100;
G1:=FILTER(REF(M2,1)<20 AND M2>REF(M2,1),5);
TU:=C/MA(C,40)<0.74;
PER1:=5;
MMA:=EMA(C,PER1);
SMMA:=EMA(MMA,PER1);
IMPETMMA:=MMA - REF(MMA,1);
IMPETSMMA:=SMMA - REF(SMMA,1);
DIVMA:= ABS(MMA - SMMA);
TDJ:=(H-L)/REF(C,1)>0.05;
AVERIMPET:= (IMPETMMA+IMPETSMMA)/2;
TDF:= POW(DIVMA,1)*POW(AVERIMPET,3);
NTDF:=TDF/HHV(ABS(TDF),PER1*3);
YUL:=COUNT(TDJ,5)>1;
启动:=TU AND TDJ AND YUL;
确定:=crOSS(NTDF,-0.9);
波段:=FILTER((G1 AND C1>20 OR C>REF(C,1)) AND REF(启动,1),10);
选股:=FILTER(REF(启动,1) AND (确定 OR C>REF(C,1)) AND "macd.MacD">-1.5,10);
妖底:=COUNT(选股,13)>=1 AND 波段;
信号后:=EXIst(妖底,13) AND C<O;
{信号:=TFILTER(妖底,信号后,15);}
DRAWTEXT(妖底>0.1,L*0.94,'↖智取妖底'),COLORYELLOW;
DRAWICON(妖底>0.1,L*0.96,34),COLORRED;
DRAWTEXT(FILTER(信号后,13),H*1.05,'可能变盘'),COLORRED;
DRAWICON(FILTER(信号后,13),H*1.01,39),COLORRED;
VAR2:=(REF(HIGH,1)+REF(LOW,1))/2;
VAR3:=MA(CLOSE,21)+2*STD(CLOSE,21);
VAR4:=REF(CLOSE,1);
VAR5:=SMA(MAX(CLOSE-VAR4,0),7,1)/SMA(ABS(CLOSE-VAR4),7,1)*100;
VAR6:=CROSS(79,VAR5);
VAR7:=FILTER(VAR6,4);
卖出:=FILTER(((CROSS(VAR2,VAR3)) OR VAR7),2);
DRAWICON(卖出,HIGH*1.035,2);
DRAWTEXT(卖出,HIGH*1.02,'卖出'), COLORGREEN;

通达信智取妖底主图指标公式

相关文章