在线检测未来函数

通达信大阳操盘主图指标公式

来源:Internet,编辑:股旁网,2022-11-11

本文指标含有选股公式如下:
股旁网此处内容已被隐藏,请输入验证码查看内容。
验证码:
请关注本站微信公众号,回复“1013”,获取验证码。
提示:在微信里搜索“股旁网”或者微信扫描右侧二维码。

DRAWTEXT_FIX(ISLAstBAR,0,0,0,HYBLOCK);
DRAWTEXT_FIX(ISLASTBAR,1,0,0,DYBLOCK);
DRAWTEXT_FIX(ISLASTBAR,0.5,2,0,GNBLOCK);
DRAWTEXT_FIX(ISLASTBAR,0,0,3,FGBLOCK);
PE:=DYNAINFO(39),NODRAW;
EPSRATE:=FINANCE(43);
PEG:=DYNAINFO(39)/FINANCE(43),NODRAW;
DRAWTEXT_FIX(ISLASTBAR,0.07,0,0,'营业收入'),COLORRED;
DRAWTEXT_FIX(ISLASTBAR,0.07,0.06,0,CON2STR(FINANCE(20){/FINANCE(34)*4}/100000000,2)),COLORRED;
DRAWTEXT_FIX(ISLASTBAR,0.14,0,0,'主营毛利率'),COLORmaGENTA;
DRAWTEXT_FIX(ISLASTBAR,0.14,0.06,0,CON2STR((FINANCE(20)-FINANCE(21))/FINANCE(20)*100,2)),COLORMAGENTA;
DRAWTEXT_FIX(ISLASTBAR,0.233,0,0,'收入同比增长'),COLORCYAN;
DRAWTEXT_FIX(ISLASTBAR,0.233,0.06,0,CON2STR(FINANCE(44),2)),COLORCYAN;
DRAWTEXT_FIX(ISLASTBAR,0.34,0,0,'市销率'),COLORGREEN;
DRAWTEXT_FIX(ISLASTBAR,0.34,0.06,0,CON2STR(C*FINANCE(1)/FINANCE(20),2)),COLORGREEN;
DRAWTEXT_FIX(ISLASTBAR,0.4,0,0,'净利润增长率'),COLORRED;
DRAWTEXT_FIX(ISLASTBAR,0.4,0.06,0,CON2STR(FINANCE(43),2)),COLORRED;
短线5:=MA(C,5),COLORCYAN;
主力操作线:(EMA(C,14)) ,LINETHICK1,COLORLIGRAY;
M14:=主力操作线;
生命线:=(MA(C,25)) ,LINETHICK1,COLORYELLOW;
不惑线43:=(MA(C,30)) ,COLORCYAN;
长线持仓线:=(EMA(C,204)) ,LINETHICK1,COLORRED;
主力成本线:(EMA(C,55)) ,COLORRED;
boll:=MA(CLOSE,14);
压力:BOLL+2*STD(CLOSE,14),DOTLINE,COLORBLUE;
支撑:BOLL-2*STD(CLOSE,14),DOTLINE,COLORBLUE;
IF(M14>REF(M14,1) ,M14,DRAWNULL)COLORMAGENTA,LINETHICK1;
IF(M14<REF(M14,1) ,M14,DRAWNULL),COLORGREEN,LINETHICK1;
STICKLINE(C/REF(C,1)<1.105 AND C/REF(C,1)>1.095 AND C=H,C,O,2,0),COLORLIMAGENTA;
STICKLINE(C/REF(C,1)>1.105 AND O<C ,C,O,2,0),COLORMAGENTA;
STICKLINE(C/REF(C,1)>1.095 AND L=H AND C=H,C,O*0.97,2,0),COLORLIRED;
STICKLINE(C/REF(C,1)>1.19 AND C=H,C,O,2,0),COLORRED;
STICKLINE(C/REF(C,1)>0.895 AND C/REF(C,1)<0.905 AND C=L,C,O,2,0),COLORBLUE;
STICKLINE(C/REF(C,1)<0.895,C,O,2,0),COLORLIBLUE;
STICKLINE(C/REF(C,1)<0.905 AND L=H AND C=H,C,O*0.97,2,0),COLORCYAN;
ZT:=REF(C,1)/REF(C,2)>1.045 AND REF(L,1)=REF(H,1) AND REF(C,1)=REF(H,1);
ZT1:=C/REF(C,1)>1.045 AND L=H AND C=H;
DRAWICON(DYNAINFO(8)>0 AND V<REF(LLV(V,21),1 AND NOT(C=H AND C=L)) AND NOT(ZT1),LOW*0.97,16);
DRAWICON ((C=HHV(C,10) AND H=HHV(H,10) AND C>O*1.01 AND H<C*1.04 AND V>=HHV(V,10) AND V>(REF(V,1)*1.8)),L*0.95,1);
QS1:=3*SMA((CLOSE-LLV(LOW,14))/(HHV(HIGH,14)-LLV(LOW,14))*100,5,1)-2*SMA(SMA((CLOSE-LLV(LOW,14))/(HHV(HIGH,14)-LLV(LOW,14))*100,5,1),3,1);
压力1:=BOLL+2*STD(CLOSE,14);
支撑1:=BOLL-2*STD(CLOSE,14);
BILI:=压力1/支撑1 ;
{DRAWICON ((BILI>1.4 AND REF(BILI,2)<REF(BILI,1) AND BILI<REF(BILI,1) ),H*1.05,2);}
DRAWICON ((QS1>90 AND BARSCOUNT(CLOSE)>30 AND REF(QS1,2)<REF(QS1,1) AND QS1<REF(QS1,1) ),H*1.05,12);
DRAWICON ((QS1<10 AND BARSCOUNT(CLOSE)>30 AND REF(QS1,2)>REF(QS1,1) AND QS1>REF(QS1,1) AND C>REF(C,1) AND C>O ),L*0.95,11);

通达信大阳操盘主图指标公式

相关文章