在线检测未来函数

通达信整合大盘和个股信息的VOL指标公式

来源:Internet,编辑:股旁网,2011-07-21

X:=CONST(DATE);
Y:=IF(DATE<X, 240, FROMOPEN);
上证昨日额亿:REF("999999$AMOUNT",1)/100000000,NODRAW;
上证今日额亿:"999999$AMOUNT"/Y*240/100000000,NODRAW;
上证预计额比:"999999$AMOUNT"/Y*240/REF("999999$AMOUNT",1),NODRAW;
123456, COLORBLACK, NODRAW;
个股预计量万:VOL/Y*240/10000,NODRAW;
预计量比:VOL/Y*240/REF(VOL,1),COLORYELLOW,NODRAW;
总交易日:=BARSCOUNT(CLOSE);
STICKLINE((VOL/Y*240)=CONST(LLV(VOL,60)),CONST(HHV(VOL,70)),(VOL/Y*240),2,0),COLORYELLOW;
STICKLINE((VOL/Y*240)=CONST(LLV(VOL,总交易日)),CONST(HHV(VOL,70)),0,0.5,0),COLOR006432;
DRAWTEXT((VOL/Y*240)=CONST(LLV(VOL,60)) AND (VOL/Y*240)>CONST(LLV(VOL,总交易日)),CONST(HHV(VOL,70))*0.7,'量底'),COLORYELLOW;
DRAWTEXT((VOL/Y*240)=CONST(LLV(VOL,60)) AND (VOL/Y*240)=CONST(LLV(VOL,总交易日)),CONST(HHV(VOL,70))*0.7,'绝对量底'),COLORYELLOW;
NOTEXTVOLUME:VOL,VOLSTICK;
NOTEXTVOL5:MA(VOL,5);
NOTEXTVOL10:MA(VOL,10);
{上证成交额直观描述}
预计变化:=(上证预计额比-1)*100;
预计1:=CONST(IF(预计变化>=40,1,0));
预计2:=CONST(IF(预计变化>=30 AND 预计变化<40,1,0));
预计3:=CONST(IF(预计变化>=20 AND 预计变化<30,1,0));
预计4:=CONST(IF(预计变化>=10 AND 预计变化<20,1,0));
预计5:=CONST(IF(预计变化>=5 AND 预计变化<10,1,0));
预计6:=CONST(IF(ABS(预计变化)<5,1,0));
预计7:=CONST(IF(预计变化<=-5 AND 预计变化>-10,1,0));
预计8:=CONST(IF(预计变化<=-10 AND 预计变化>-20,1,0));
预计9:=CONST(IF(预计变化<=-20 AND 预计变化>-30,1,0));
预计10:=CONST(IF(预计变化<=-30 AND 预计变化>-40,1,0));
预计11:=CONST(IF(预计变化<=-40,1,0));
位置1:=PERIOD=5 AND CURRBARSCOUNT=34;
DRAWTEXT(预计1=1 AND 位置1, CONST(HHV(NOTEXTVOLUME,70))*0.88, '大盘猛烈放量40%以上'), COLORFF00FF;
DRAWTEXT(预计2=1 AND 位置1, CONST(HHV(NOTEXTVOLUME,70))*0.88, '大盘大幅放量30-40%'), COLORFF00FF;
DRAWTEXT(预计3=1 AND 位置1, CONST(HHV(NOTEXTVOLUME,70))*0.88, '大盘放量20-30%'), COLORFF00FF;
DRAWTEXT(预计4=1 AND 位置1, CONST(HHV(NOTEXTVOLUME,70))*0.88, '大盘放量10-20%'), COLORFF00FF;
DRAWTEXT(预计5=1 AND 位置1, CONST(HHV(NOTEXTVOLUME,70))*0.88, '大盘轻微放量5-10%'), COLORFF00FF;
DRAWTEXT(预计6=1 AND 位置1, CONST(HHV(NOTEXTVOLUME,70))*0.88, '大盘成交额小幅波动±5%'), COLORFF00FF;
DRAWTEXT(预计7=1 AND 位置1, CONST(HHV(NOTEXTVOLUME,70))*0.88, '大盘轻微缩量5-10%'), COLORFF00FF;
DRAWTEXT(预计8=1 AND 位置1, CONST(HHV(NOTEXTVOLUME,70))*0.88, '大盘缩量10-20%'), COLORFF00FF;
DRAWTEXT(预计9=1 AND 位置1, CONST(HHV(NOTEXTVOLUME,70))*0.88, '大盘缩量20-30%'), COLORFF00FF;
DRAWTEXT(预计10=1 AND 位置1, CONST(HHV(NOTEXTVOLUME,70))*0.88, '大盘大幅缩量30-40%'), COLORFF00FF;
DRAWTEXT(预计11=1 AND 位置1, CONST(HHV(NOTEXTVOLUME,70))*0.88, '大盘猛烈缩量40%以上'), COLORFF00FF;
{大盘KDJ,RSI超跌,牛熊市都能用}
{www.gUPang.com 股旁网_最新股票指标公式}
上证J超跌:=CONST(IF("999999$KDJ.J"<=5,1,0));
上证R超跌:=CONST(IF("999999$RSI.RSI1"<=20,1,0));
DRAWTEXT(上证J超跌=1 AND 上证R超跌=0 AND CURRBARSCOUNT=15, CONST(HHV(NOTEXTVOLUME,70))*0.6, '上证KDJ超跌(小于5),有反弹预期');
DRAWTEXT(上证J超跌=0 AND 上证R超跌=1 AND CURRBARSCOUNT=15, CONST(HHV(NOTEXTVOLUME,70))*0.6, '上证RSI超跌(小于20),有反弹预期');
DRAWTEXT(上证J超跌=1 AND 上证R超跌=1 AND CURRBARSCOUNT=15, CONST(HHV(NOTEXTVOLUME,70))*0.6, '上证KDJ-RSI都超跌(小于5或20)');

通达信整合大盘和个股信息的VOL指标公式

 

相关文章