在线检测未来函数

通达信电鱼指标公式

来源:Internet,编辑:股旁网,2012-04-16

AA:=(O+H+L+C)/4;
BB:=MA(AA,3);
CC:=SUM(IF(AA>REF(AA,1),AA*VOL,0),4)/SUM(IF(AA<REF(AA,1),AA*VOL,0),4);
DD:=REF(100-(100/(1+CC)),1);
A1:=HHV(AA,15);
A2:=LLV(AA,15);
A3:=A1-A2;
A4:=EMA((AA-A2)/A3,2)*100;
B1:=HHV(AA,60);
B2:=LLV(AA,60);
B3:=B1-B2;
B4:=EMA((AA-B2)/B3,2)*100;
C1:=HHV(AA,240);
C2:=LLV(AA,240);
C3:=C1-C2;
C4:=EMA((AA-C2)/C3,2)*100;
短期:A4,COLORWHITE;
中期:B4,COLORYELLOW;
长期:C4,COLORFF00FF;
STICKLINE(短期>90 AND 中期>70,86,94,6,0),COLORWHITE;
STICKLINE(短期<5 AND 中期<30,0,8,6,0);
{www.gupang.com 股旁网_通达信股票指标公式}
IF(FILTER(中期<REF(中期,1)AND 中期>90 AND BB<REF(BB,1),5),80,100),COLORBLUE,LINETHICK2;
IF(FILTER(中期>REF(中期,1)AND 中期<5 AND C>REF(C,1),5),20,0),COLORRED,LINETHICK2;
D1:=中期>REF(中期,1)AND 短期>REF(短期,1)AND 长期>REF(长期,1)AND 长期<8 AND 中期<10 AND 短期<15;
D2:=CROSS(短期,中期)AND 中期<8;
D3:=CROSS(短期,长期)AND 长期<8 AND 中期<20;
DRAWICON(FILTER((D1 OR D2 OR D3) AND DD<15 AND C>REF(C,1),5),5,1);
DRAWICON(FILTER((中期<REF(中期,1)AND 短期<REF(短期,1)AND 长期<REF(长期,1)AND 中期>95 AND 短期>85)OR (长期>100 AND 中期>100 AND 短期>100),5),95,2);
强弱分界:50, POINTDOT,COLORWHITE;
警戒区:90,LINETHICK1,COLORWHITE;
安全区:20,COLORFFFF00;
{}
VAR1:=REF(LOW,1);
VAR2:=SMA(ABS(LOW-VAR1),3,1)/SMA(MAX(LOW-VAR1,0),3,1)*100;
VAR3:=EMA(IF(CLOSE*1.2,VAR2*10,VAR2/10),3);
VAR4:=LLV(LOW,38);
VAR5:=HHV(VAR3,38);
VAR6:=IF(LLV(LOW,90),1,0);
VAR7:=EMA(IF(LOW<=VAR4,(VAR3+VAR5*2)/2,0),3)/618*VAR6;
VAR8:=((C-LLV(L,21))/(HHV(H,21)-LLV(L,21)))*100;
VAR9:=SMA(VAR8,13,8);
底线:0,COLOR00FFFF;
主力吸货:VAR7,COLOR0000FF;
{吸筹1:STICKLINE(VAR7,0,VAR7,6,0),COLOR0000FF;
吸筹2:STICKLINE(VAR7,0,VAR7,5,0),COLOR6600FF;
吸筹3:STICKLINE(VAR7,0,VAR7,4,0),COLORBB00FF;
吸筹4:STICKLINE(VAR7,0,VAR7,3,0),COLORFF00FF;
吸筹5:STICKLINE(VAR7,0,VAR7,2,0),COLORFF33FF;
吸筹6:STICKLINE(VAR7,0,VAR7,1,0),COLORFF66FF;
吸筹7:STICKLINE(VAR7,0,VAR7,0,0),COLORFF99FF;}
风险:CEILING(SMA(VAR9,13,8)),LINETHICK2,COLORGREEN;
涨跌:MA(3*SMA((C-LLV(L,27))/(HHV(H,27)-LLV(L,27))*100,5,1)-2*
SMA(SMA((C-LLV(L,27))/(HHV(H,27)-LLV(L,27))*100,5,1),3,1),5),LINETHICK2,COLORRED;

通达信电鱼指标公式

 

相关文章